AfterDawn Forums

3rd RMA on same GPU

This discussion thread has 2 messages.

#1
Hello, back in February my brother bought some components for his first build which included an AMD Sapphire HD 6850. Once I put everything together for him it would sometimes get a BSOD or start to artifact, we returned the CPU and PSU thinking it was one or the other (thinking back now I can't remember why) we then tried my HIS brand GPU on his system and it worked flawlessly and we swapped since at the time there were no issues on my end. His system consists of the following:

CORSAIR Vengeance 4GB (2 x 2GB) DDR3 SDRAM
ASUS M5A78L-M LX PLUS AM3+ AMD 760G
AMD FX-4100 Zambezi 3.6GHz (3.8GHz Turbo) Socket AM3+ 95W Quad-Core
Seagate Barracuda ST500DM002 500GB 7200 RPM SATA HDD
HIS IceQ Turbo H677QNT1GD Radeon HD 6770
750W PSU that I purchased at Best Buy, can't remember the brand or model
Windows 7

Now a couple of weeks ago I started noticing that there were small dead pixel looking things on my screen and figured it was the GPU this whole time, so I RMA'd it since it was still under warranty through AMD. While I waited for my replacement card to arrive I used my old 4670, same brand and everything which worked without issues.

When the replacement card arrived it gave me much worse issues with the bottom of the screen artifacting, freezing up and even giving me a couple BSOD's. I sent it back, again my old 4670 goes in with no issues. My 2nd replacement arrives, I remove my OC's this time and change all the settings down to normal factory settings, replaced my main HDD with an SSD, tested my RAM while I waited for the 2nd replacement card to arrive and when it finally does...same thing. I finally take the plunge and wipe out windows 7 and install 8 thinking it was perhaps some leftover driver that driversweeper wasn't removing...same thing. AMD is understandably hesitant to do a 3rd replacement and asked me to test the card out on another system, I took it back to my brother and swapped it in to his system and he gets atikmpag.sys error on his BSOD, what I used to get when I was running Win 7. In Windows 8 I get Video_Scheduler_internal_error what seems to be every other bootup. What could be the issue? I've already ruled out faulty RAM, leaking capacitors, bad PCIE slot, bad HDD (disconnected all but OS drive).

I tried going into safe mode, ran drive sweeper, rebooted in safe mode, deleted display driver in device manager, rebooted in regular mode and reinstalled the drivers from both AMD and also from the Sapphire website all to no avail. The quickest way I can get the system to lockup is by changing me resolution and each time I get a notice at the bottom right saying that my graphics driver had become unresponsive but has recovered.

Before I send the GPU back to AMD to get a 4th one, what can any of you suggest I do?

This is my system:

Windows 8 Pro clean install
COOLER MASTER HAF 932 Advanced RC-932-KKN5-GP Steel ATX Case
GIGABYTE GA-EP45-UD3P LGA 775 Intel P45 ATX Intel Motherboard
Intel Core 2 Quad Q8200 2.33GHz LGA 775 95W Quad-Core Processor
ADATA Vitesta 8GB (4 x 2GB) 240-Pin DDR2 SDRAM DDR2 800 (PC2 6400) Dual Channel Kit Desktop Memory
Cooler master CPU cooler
3 1TB HDD's
1 DVD/CD Drive
1 Blu-ray Drive
COUGAR CMX 1000CMX 1000W PSU
Sapphire Radeon HD 6850
▼▼ This topic has 1 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Just got an OCZ-ZX1000W PSU on the suggestion of another forum with same results, can anyone give any other suggestions?
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.