AfterDawn Forums

Toshiba netbook booting to black screen

This discussion thread has 3 messages.

Greetings people of AfterDawn,


I've got a problem here with a Toshiba Netbook (NB200-10G) that I've been banging my head up against for weeks now so any ideas are welcome.

Machine first exhibited a problem booting when it was brought to me with what appeared to be a straight forward disk failure (the problem is still the same, I get past the BIOS screen and POST and then go straight to a black screen with a single white blinking _ cursor which never leaves).

The initial problem appeared to be down to simple HDD failure, the disk didn't work in another machine and was exhibiting the usual clicking that's typical of a broken read head so I replaced the disk with another one that I know to be working fine, BIOS also detects this drive as a boot option, it also detects all installed memory.

The same issue occurs with the new HDD installed, so no big deal, that's what I'd expect with a blank HDD, but I can't get a single thing to boot to actually do an installation.


Attempted to get in to the built in recovery (redundant since it depends on a recovery partition on the original HDD which is dead now).

Attempted to reset power controller (heard that current can be purged in a lot of cases by holding down power button or repeated presses), no joy with either.

Attempted to boot from two Linux USB sticks (LinuxMint and Fedora) which are detected as valid options in the BIOS boot options.

Attempted to boot from an external optical drive (the drive is detected as a device in the BIOS boot options), it doesn't have it's own PSU and is powered over USB but the motor is turning without a problem and it works on another machine.

Installed a version of Linux with cross platform drivers on another PC and put the HDD in the netbook (I'd have settled for just seeing a kernel panic at this point).

Reset the BIOS to default settings in case I'd missed a silly setting that was stopping boot.

Tried USB sticks and optical drive in a number of socket combinations to ensure it wasn't just down to a low power USB port.

Tried to boot using the built in PXE over DHCP ethernet, I don't have a server running RIS of any form but I didn't even see the usual DHCP request failure that you'd expect to see if there was no RIS on offer.

Checked that there isn't something stupid like a loose cable connecting the screen to the mobo or a physical blockage or damage to the sata ports (I was getting desparate).


Removing the mobo battery to totally reset BIOS settings (mostly because I can't work out for the life of me where it is on the board and someone has managed to badly damage some of the screws so they'll need to be drilled out). If anyone has a service manual I'd be very grateful.

Updated the BIOS with a new version or flashed with the same version to rule out a problem passing info from BIOS to a bootloader (have now tried with the XP and W7 bootloaders as well as GRUB and LILO). I've had no joy tracking down a copy of BIOS that will work with anything other than a floppy.


If anyone has any advice I'd love to hear it at this point!
This message has been edited since its posting. Latest edit was made on 23 Dec 2012 @ 11:01
▼▼ This topic has 2 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
Bump? Nothing, anyone? Don't tell me I've got a problem nobody on AfterDawn can solve
is your boot cd\dvd actually bootable? did you try booting with that cd\dvd in that optical drive on another pc to see if boots or not?
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.