AfterDawn Forums

Loading javascript() - segfault in module12283.js

This discussion thread has 6 messages.

#1
Strange one.. wanted to report in the java problem thread but no way to post..

This is the only site which causes a segfault on loading some java module.. which causes a browser immediate exit.

Only other clue I have.. it has been happening for a few days since that annoying pop in from the side box displaying lower right with an annoying ad in it has gone walkabout.

Like I say.. it's the only site I use which does this.. Normally I would put it down to having not enough ram, but I can use facebook fine.. and wordpress blogs..

Epiphany browser on Ubuntu 2.6-32 kernel and Cinnamon desktop. Latest "official" linux java too.

I can't be bothered running strace because it gives me the same result.. something is calling a faulty java module, or is trying to create a buffer underrun.

Anybody running windoze experienced any odd malware type attacks recently?



ARR! Them pesky Navy! Get out of my sea!
irc://irc.villageirc.net/afterdawn http://www.pirateparty.org.uk/
▼▼ This topic has 5 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
moved to correct forum. i've had no malware attacks but do have a problem with pm forum as it locksup my ie8 on xp pro sp3. lockup does goe away if i wait a bit.
#3
interesting.. I'll have to hunt this down.. I'm having to start up my browser on pretty much every page move tonight. It takes me 3 or 4 attempts to read a thread. *off to have a look in my browser logs* .. trouble is it just exits so it doesn't get to log anything


Mar  2 02:07:38 juliadream-laptop kernel: [ 2571.577192] x-www-browser[1935]: segfault at 0 ip 01837044 sp bf899b30 error 4 in libwebkit-1.0.so.2.17.9[ee6000+d8a000]
Mar  2 02:09:05 juliadream-laptop kernel: [ 2659.590462] x-www-browser[1998]: segfault at 0 ip 018b2044 sp bfdbaac0 error 4 in libwebkit-1.0.so.2.17.9[f61000+d8a000]
Mar  2 02:16:25 juliadream-laptop kernel: [ 3099.444459] x-www-browser[2061]: segfault at 0 ip 01885044 sp bfefba90 error 4 in libwebkit-1.0.so.2.17.9[f34000+d8a000]
Mar  2 02:20:10 juliadream-laptop kernel: [ 3324.298350] x-www-browser[2152]: segfault at 0 ip 01859044 sp bfb96350 error 4 in libwebkit-1.0.so.2.17.9[f08000+d8a000] 

As you can see it's something to do with a standards compliance by the look of it triggering something the browser code doesn't like. I will investigate further.
This message has been edited since its posting. Latest edit was made on 01 Mar 2012 @ 21:49



ARR! Them pesky Navy! Get out of my sea!
irc://irc.villageirc.net/afterdawn http://www.pirateparty.org.uk/
#4
no problems here but haven't used pm forum yet.
#5
I'm stumped.. it's the only site which does it.



ARR! Them pesky Navy! Get out of my sea!
irc://irc.villageirc.net/afterdawn http://www.pirateparty.org.uk/
#6
Finally got to the bottom of it. The java error was the last thing which was loading before stupid proprietary adobe flashplayer got upset about an ad in an iframe.. The problem is common across most versions of the 11.xxxxx flashplugin, the cure is to replace with 10.3.183.18 from adobe archive.. and it's then back to the full system lockups that heap of garbage causes instead of unusable browsers.

Problem solved.. just reporting in that I found the problem.



ARR! Them pesky Navy! Get out of my sea!
irc://irc.villageirc.net/afterdawn http://www.pirateparty.org.uk/
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.