AfterDawn Forums

PS3 turns on, but nothing happens.(no menu screens or anything)

This discussion thread has 12 messages.


I was wondering whether any of you have experienced my problem. I turned on the PS3, but the menu doesn't load, so hardware wise it's turned on ( I can hear the fan), but nothing else happens. I can put in and eject discs fine. The controller can't seem to detect the hardware, I press the PS button, but the controller keeps flashing red, and doesn't detect that the system is turned on.

I've called tech support and they told me to hold the power button for few times, but nothing ever happens when I do that, there is always an empty screen.

If any of you can help/provide assistance of any kind with this issue, it would be greatly appreciated. Thank you!
▼▼ This topic has 11 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
"I've called tech support and they told me to hold the power button for few times, but nothing ever happens when I do that, there is always an empty screen."
-I take it that you mean you held the power button until it beeped a few times...if not, try this first.

Is the power light green?

Is the controller plugged in by USB? If not, does this change the flashing?

Is there any change on the screen when powering on?
Hi KillerBug,

Yes, I mean't the power button, I held it down for 2 beeps and 3 beeps and nothing ever showed up.

Yes, the power light is green.

Yes, I plugged in the controller with the usb cord, the 4 lights still always flash, it never settles on one player slot.

I don't see anything when powering on, maybe a slight flicker, but barely noticeable.

I also changed TVs and switched between HDMI and AV component to check, but still nothing.
Hi there. Try to connect your console to a TVset with low resolution. Use usual av-cable. Disconnect your controller. Turn your console off. Press a reset button for 5-6 seconds, your console settings will return to initial setup. I hope.
put out ps3 hdd and power on ur ps3 and wait 3-5 mins than screen will apper

or power on and press hold on red light and wait while light green than red again and press red light again and wait whili 1 times beep and 2x beep than hold off power switch.

Thanks for the suggestions. I've tried changing cables and resolutions, but no luck (I think it's the console's problem, as it doesn't even recognize my controller). I've done all the holding power button options, but I haven't taken out the HD and then powered on the PS3. This is safe to do?
yes you can remove hdd with safely but dont forget turn off console :)
just switch ps3 then hold eject button.try that
If it won't give you anything when you remove the hard drive, it would seem to be a serious problem.

It might be fixed with the heatgun/oven repair used for the YLOD (these fixes usually don't last very long, if they work at all)

Or you might send it in to sony to have them do a fix (a fix that probably will not last very long either, but worthwhile if the system is still under warantee)

Thanks for all your help! I did all of the above and it doesn't look like anything worked. Does this sound like a hard drive problem? I'm going to buy a SATA drive online and replace the original, if that doesn't work, I'm leaning towards just buying a Slim :(
If you don't get a screen when the hard disk is removed, then it can't possibly be a hard drive issue.

You might as well buy a slim...a phat is virtually useless until gethot pays his taxes (unless you ruin the only thing that it has going for it by upgrading the firmware).

BTW...don't toss your old PS3; even a dead PS3 is worth money.
i had the same problem on one i brought off a mate that he brought of his mate can u get the recovery screen up ? turn on your ps3 wait 4 it to boot up as it would normally then hold the power buton unitll it turns off. hold the power buton till it beeps 3 times then turns off. now hold the power buton untill you see the screen flash or flickers and it should take you to the recovery screen it took me ages to get to it but i got their in the end and please do it on a standerd tv not a plasma/lcd as i could not get to a recovery menu on them dont know why ? then try the opions on there.when i did get these non of them worked 4 me so i end up takeing out the hdd turn of the ps3 (wait 30 second of so then remove it) put it back in and see if the ps3 will reformat it 4 you and that never worked 4 me so i formated it in my pc to fat32 then still no luck went back to the recovery menu updated filmware and keep crashing in the end i took ps3 to bits and cleand the board with some vodka mixed with Isopropyl Alcohol becuse i was runing low put all back to gether and yes now im useing it madness i know looked like there was some condensatinnbuild up or it had got wet at some pont

This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.