AfterDawn Forums

What's the status on jailbreaking PS3s on 4.25 firmware?

This discussion thread has 3 messages.

#1
Hi guys

Been out of the PS3 modding scene for a while. Got my minimus AVR here and wondering if it's still possible to jailbreak PS3s running the latest firmware (which I'm guessing at time of writing is 4.25?)

Thanks.

http://my.afterdawn.com/mik3h/blog_entry.cfm/1394 - Guides written by me.
http://www.adbuddies.org/ - Join us Live on IRC!

(Kudos to Ripper For The Beautiful Sig!)

▼▼ This topic has 2 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Originally posted by Mik3h:
Hi guys

Been out of the PS3 modding scene for a while. Got my minimus AVR here and wondering if it's still possible to jailbreak PS3s running the latest firmware (which I'm guessing at time of writing is 4.25?)

Thanks.
well.... if you still are on 3.55 you can just update to a more recent cfw 4.21 or 4.3x... i think you can use the avr to downgrade ps3 units... given you use the proper hex file and program the avr with FLIP... other than that you cant JB new models(3k 4k) read about these and see what fits you more

rogero
http://www.tortuga-cove.com/forums/viewtopic.php?f=127&t=4336

rebug
http://rebug.me/category/rebug-firmware/

another thing is if you have 4.25 and have anything older or 25xx model you can downgrade using a flasher...
This message has been edited since its posting. Latest edit was made on 01 Feb 2013 @ 17:12

PC i7 3770K 8Gb Ram Radeon 290X 4TB WD Black 60Gb SDD
Xbox360 Slim RGH Dash 16202
Xbox360 PHAT 14719 BENQ drive
Black PS3 CECH-L04 PS3ITA 4.50 Converted DEX
White PS3 CECH-2506B PS3ITA 4.50 Converted DEX
Black PS3 DECH-J00A DEX FW4.50
#3
Quick question that deals with the same topic. Is there any reason to stay on 3.55 over updating to play the new games? I'm on 3.55 and just wondering if I'll lose anything by updating to one of the two you mentioned above. Last I heard (months ago) was that all the latest keys had been unlocked and patches for all the games will be available, which I've noticed seems to be true. I'd assume I'd need new patches for my old games I have working on 3.55 now if I were to update?
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.