AfterDawn Forums

4.2U Wii wont load many Homebrew apps

This discussion thread has 23 messages.

#1
Hey i have a friend on msn i did a webcam chat and helped him softmod his wii it all wen successful but the problem is they cant access many homebrew features he can access like anyregion changer and 1 or 2 more thing and thats it he cant even load the wad manager dol 1.3 or the latest update of it is there a fix to this problem i really feel bad that he couldnt get it working properly emulators wont load on it either we really need to get this working i will really Appreciate any help even if its only a little bit of help.
Thanks
▼▼ This topic has 22 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Its because the majority of those apps use IOS249. When Nintendo released 4.2, they installed what's called a "stub" IOS249. This means that whenever you try and load a homebrew app that requires IOS249, you'll get a black screen. What you need to do is delete IOS249 and reinstall it with cIOS38 rev14b.

Assuming you've already installed BootMii and TBR,

Here's How: (From WiiHacks.com)

1) Download and extract this file. http://www.mediafire.com/?5wgnmyy5wve Password: "www.wiihacks.com".

2) Copy everything in the "Place to SD 4" Folder into the root of your SD Card.

3)If you already installed BootMii, Wadmanager should start.(On ios select, select ios36)

4)Select SD card and press A to continue.

5)Select ios249 from wad folder and press A

6)change the action to "uninstall wad", press A

7) Exit the installer and head back to the Wii System menu. Take out the SD card and delete the files you copied from the "Place 2 SD 4" folder.

8) Download and extract this file. http://filetrip.net/f5958-cIOS--installer-38r14.html Copy the "cIOS38r14_installer" folder to the Apps folder on your SD card.

9) Load HBC then select cIOS38 rev14b. Select to load IOS36 when it asks. Let it install, wait till it says: SUCCESS PRESS ANY BUTTON TO RESTART WII.

10) Load a homebrew app that didn't work before.

11) Be astonished as the app successfully loads...
#3
This sounds like what I ran into. When I attempt to load a app it gives me a black screen and freezes the system. Im going to try this.
#4
Thabkyou so much but my friend has trouble with PBR it gets errors and i gave them step by step tutorial from youtube video
#5
will it matter if TBR didnt install properly?
This message has been edited since its posting. Latest edit was made on 26 Nov 2009 @ 3:44
#6
Hey when I did this on the
Installing Custom IOS line I got a Install ERROR! (ret = -2011)

How ever everything works
#7
Originally posted by scarfaceg:
will it matter if TBR didnt install properly?
I also had 4.2U and it required that I use TBR-MOD because of 4.2 compatibility. Reg TBR gave me errors but TBR-MOD worked perfectly. Link: http://filetrip.net/file.php?id=7458

Try the process again with this TBR-MOD. here's a video for help: http://www.youtube.com/watch?v=ltrd3oq8hPc

~ Jon
#8
yeah i only just found out we needed the modded TBR for it to work not that long ago thanks anyway
#9
Hey we did the youtube video tutorial but at 1 of the steps wen we tried installing the IOS it said install failed not a trucha bug or something like that it says so if we still uninstall IOS 249 will it still be safe?
#10
umm i followed ur tutorial but it freezes wen we put ios 249 only wen its 249 if its anything else it doesnt freeze how can we fix this problem?
#11
You should not have followed my tutorial if you hadn't already done TBR. SO we'll start over. Now, you still need to do the TBR. I will help you as much as I can, giving you what you need to know for the time being.

Okay here we go:

Step 1: The TBR-MOD (I'll be using the SAME steps as the video in the previous post)

1) Download & extract the TBR-MOD app (download link in previous post)to your apps folder on your SD Card.

2) Run it on your Wii. It will boot and ask you which IOS to load. Its default is IOS36. Hit A.

3) Wait for the program to state "Hit 1 to continue" near the bottom of the text. Hit 1. Go down to "Downgrade IOS15" using the down arrow on the D-Pad. Hit A. It will prompt you to select a download method. Select "Download from NUS" using the right arrow on the D-Pad. Hit A.

4) After a couple of second it will prompt you again for a download method, select "Download from NUS. It will prompt to start Part 1 of the the installation. Hit A. Then prompt you for Part 2. Hit A again.

5) Once its finished, hit any button and it will return to HBC. Load TBR-MOD again. Select IOS15 to load. Hit A. Wait until it displays the message and Hit 1. Select "IOS36 Menu".

Set these Settings:

Install IOS to Slot: 36 (default)
Patch Hash Check (truch): YES
Patch ES_Identity: YES (optional, for Preloader)
Patch Nand Permissions: NO (optional)


Once Set, hit the VERY first option which says "Install Patch IOS36" Select "Download from NUS" as the download option. It will prompt you for installation, Hit A.

6) Once it displays the message, hit any button to exit. It will boot back to HBC. Load TBR-MOD for the last time. Select to load IOS36. Select "Restore IOS15". Then as the download method select "Download from NUS" It will prompt you for installation, Hit A.

7) Done. Once it displays the message, hit any button to exit. If you get any errors, state WHEN (state the step number) and WHAT it says. Once you've done this report back and here and say that it was a success.
#12
Thats exacly what we did but it said something along the lines of saying its not trucha install failed on the last step of trucha MOD i dont get it and ever since then the wad managers freeze wen choosing IOS in step 5 is where it says install failed saying its not trucha i better double check on that im not sure im not 100% sure if its step 5 or the part when we restore i better check up on that sorry
#13
Make sure that you loaded IOS15 in step 5, selected "IOS36 Menu", and you selected "Patch Hash Check (trucha): YES"

Those are the only things I can think of that would make it say that in step 5. If it happened when restoring IOS15 that would be quite odd and puzzle me, O.o Compare what you did with the video in the previous post and see whats different.

~ Jon
#14
ok thanks a lot for helping me out i'll try again very soon
#15
Originally posted by darksole3:
Hey when I did this on the
Installing Custom IOS line I got a Install ERROR! (ret = -2011)

How ever everything works
same thing happeed to me but I still get black screens
can any1 help me please?
#16
@ Stallio95: Sounds like you didn't do the TBR. Follow directions above or follow this guide: http://sites.google.com/site/completesg/.../trucha-bug-4-2

@ Scarefaceg: You may also have a look at that guide if you need more help than I am giving you... At this moment, I can't tell if your TBR installation was successful. (Don't do this next step if you know it was successful) We're going to try a new method that hypothetically should work but may not to achieve the same result as TBR. We're going to use DOP-IOS MOD to try and install a trucha signed IOS36.

Download Link: http://filetrip.net/ajax.php?action=download&id=8734

1) Extract and copy the "Dop-IOS MOD" folder to your apps folder on your SD card like any other app. Run it on your Wii.

2) When it asks which IOS to load select IOS36.

3) Navigate using the D-pad to IOS36 (yes find it again and it may be set to IOS36 already as default) Hit A 3 times to confirm all patches. It will install and once you are back to the main DOP-IOS MOD screen, hit HOME to return back to HBC.

Post back here if you've had any problems and report for further instructions
#17
lol i already have that app i use it now ad then its my friends wii i been trying to hack so it could be difficult to find out exacly what it says since we doing it over msn
#18
Originally posted by jonjon95:
Its because the majority of those apps use IOS249. When Nintendo released 4.2, they installed what's called a "stub" IOS249. This means that whenever you try and load a homebrew app that requires IOS249, you'll get a black screen. What you need to do is delete IOS249 and reinstall it with cIOS38 rev14b.

Assuming you've already installed BootMii and TBR,

Here's How: (From WiiHacks.com)

1) Download and extract this file. http://www.mediafire.com/?5wgnmyy5wve Password: "www.wiihacks.com".

as i am doing this step of the proccess i start wad manager and select ios 249 and the wii freezes up and the wiimote shuts off this is differant then the first time i tried to do this and it failed i went down after that and did tbr fix and now it freezes
2) Copy everything in the "Place to SD 4" Folder into the root of your SD Card.

3)If you already installed BootMii, Wadmanager should start.(On ios select, select ios36)

4)Select SD card and press A to continue.

5)Select ios249 from wad folder and press A

6)change the action to "uninstall wad", press A

7) Exit the installer and head back to the Wii System menu. Take out the SD card and delete the files you copied from the "Place 2 SD 4" folder.

8) Download and extract this file. http://filetrip.net/f5958-cIOS--installer-38r14.html Copy the "cIOS38r14_installer" folder to the Apps folder on your SD card.

9) Load HBC then select cIOS38 rev14b. Select to load IOS36 when it asks. Let it install, wait till it says: SUCCESS PRESS ANY BUTTON TO RESTART WII.

10) Load a homebrew app that didn't work before.

11) Be astonished as the app successfully loads...
#19
Originally posted by jonjon95:
Its because the majority of those apps use IOS249. When Nintendo released 4.2, they installed what's called a "stub" IOS249. This means that whenever you try and load a homebrew app that requires IOS249, you'll get a black screen. What you need to do is delete IOS249 and reinstall it with cIOS38 rev14b.

Assuming you've already installed BootMii and TBR,

Here's How: (From WiiHacks.com)

1) Download and extract this file. http://www.mediafire.com/?5wgnmyy5wve Password: "www.wiihacks.co

2) Copy everything in the "Place to SD 4" Folder into the root of your SD Card.

3)If you already installed BootMii, Wadmanager should start.(On ios select, select ios36)

4)Select SD card and press A to continue.

5)Select ios249 from wad folder and press A

6)change the action to "uninstall wad", press A

7) Exit the installer and head back to the Wii System menu. Take out the SD card and delete the files you copied from the "Place 2 SD 4" folder.

8) Download and extract this file. http://filetrip.net/f5958-cIOS--installer-38r14.html Copy the "cIOS38r14_installer" folder to the Apps folder on your SD card.

9) Load HBC then select cIOS38 rev14b. Select to load IOS36 when it asks. Let it install, wait till it says: SUCCESS PRESS ANY BUTTON TO RESTART WII.

10) Load a homebrew app that didn't work before.

11) Be astonished as the app successfully loads...
i tried to run tbrmod and had issues so i did the dop-iso mod and it worked so i went back to do this step and in step 6 after i click to uninstall the wad i get an error message stating
delete tickets...error (ret=-1017
deleting title contents...error (ret=-1017)
deleting title... error (ret=-1017)
press any button to continue

where did i go wrong
This message has been edited since its posting. Latest edit was made on 23 Dec 2009 @ 15:32
#20
If anyone wants to try a different guide I created a 4.2 softmod guide yeasterday which is in my sig.

TBR has updated to version 1.11 which is 4.2 compatible and uses newer IOS versions then it did before. I use the updated TBR in my 4.2 guide.
This message has been edited since its posting. Latest edit was made on 23 Dec 2009 @ 18:16


#21
I'm having the issue of the black screen on usb loader gx...

I have a modchip and backups play fine, but i'm trying to get my hard drive working. uloader seems to work fine, but other apps like usb loader gx, cios installer, get a black screen..the usb loader gx channel give me a black screen then an exception and stack error..I've tried to delete ios249 and then load cIOS38 rev14b, but i get a -1017 error on 249..

Can anyone let me know what i have to do to get usb loader gx working?

Thanks
#22
Error Code 2011


You need to connect to the internet to install this app.It also depends on how you are connecting to the net. I use to get the error code 2011. I use the usb net adapter to connect to the internet. Your Wii has a mac address. When you switch you connection from your computer to your Wii it will not automatically pick up the mac address.You have to reset your router and reconnect your wii. You reset your router by disconnecting it from the power outlet you wait ten seconds and plug it back in and wait for your router to reset.

I had problems using the wi-fi connection on the wii so i used the usb internet adapter. I know you can use the wi-fi feature but this is how i got my wii to work.

Different strokes for different folks. Hope this helped
#23
Originally posted by joelw23:
I'm having the issue of the black screen on usb loader gx...

I have a modchip and backups play fine, but i'm trying to get my hard drive working. uloader seems to work fine, but other apps like usb loader gx, cios installer, get a black screen..the usb loader gx channel give me a black screen then an exception and stack error..I've tried to delete ios249 and then load cIOS38 rev14b, but i get a -1017 error on 249..

Can anyone let me know what i have to do to get usb loader gx working?

Thanks
Please ask USB Loader GX questions in a new thread. There is a separate thread for USB loading as well linked in this guide. Please don't ask USB Loader questions in that thread either. Neither of the guides use USB loader GX so we don't need confusing post being asked about aplications that are not used in the guides.
This message has been edited since its posting. Latest edit was made on 08 Feb 2010 @ 20:44


This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.