AfterDawn Forums

Problem loading wads on wii

This discussion thread has 7 messages.

#1
I have the homebrew channel installed and my wii is modded so that it can play backed up wii and gamecube games. What I am trying to do is install wads for the wii. I have tried the apps wad installer and wad manager. I load them up from the homebrew manager and it goes to a black screen with some text, but when I tell it to load the wad it gives me an error ret = -1 for both wad installer and wad manager. I have the wad in question in the wad folder of my sd card. The wad folder is in the root of the sd card. I am using the latest wii firmware 4.0, and a sdhc card formatted as fat 32. There is no option to format it to fat 16. I've tried using multiple wads so that isn't the problem.

Again the problem is that wads won't load from wad installer or wad manager, I get the ret = -1 error. any ideas on what to do?
▼▼ This topic has 6 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
The latest Wii firmware is 4.1

But does WAD Manager give you a list of wads to install?

The folder you have the wads in is named wad (not wads)?

You may need to try using a different SD Card.

Try a NON SDHC card.
This message has been edited since its posting. Latest edit was made on 23 Jul 2009 @ 12:52
#3
Yeah the firmware must be 4.1 It doesn't give me a list of wads to install. I tried a different SD card, this time it showed me a list of WaDs to install in the WaD manager. It seemed to be going ok but then I got the error,

opening WaD file, please wait... OK!
Installing WaD, please wait...
>> Installing ticket... ERROR! (ret! = -2011)

Press any button to continue

Weird, I'm not sure what to do. Do I need to downgrade the firmware or change to a cios thing or what?
#4
Try running IOS DOwngrader to downgrade your IOS's. If you updated from 4.0 to 4.1 then you might need to also run IOS60Patch again.
This message has been edited since its posting. Latest edit was made on 23 Jul 2009 @ 15:20
#5
I fixed -2011 error by using the tutorial in the following thread
http://www.wiihacks.com/other-faq-guides-t...os-any-wii.html In page 10 post 92 of that thread there is a helpful video that further explains the details on fixing the -2011 error. I'm linking it in case someone in the future does a google search for one of these errors and comes to this thread, so they will know what to do. I'm not sure if the error 2011 fix will work with firmware 5.0 or 6.0 because as of the time of this writing the latest firmware is 4.1. Thanks for the helpful info larrylje, the wad installed and is working correctly now.
#6
says webpage cannot be found^^
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.