AfterDawn Forums

DSi with firmware 1.4E and DSTTi card

This discussion thread has 21 messages.

#1
Should this work?
Trying to use the card with this firmware but receiving an error message from the DSi telling me to power it off.
Would like to know if it is the firmware limitnig this or a hardware error with DSTTi card.
▼▼ This topic has 20 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
I have got the same error after updating the firmware to 1.4E, the ttdsi card has been testing in another ds and working fine. i guess will have to check the dstt site to see if there is a update for the ttdsi.
#3
The DSTTi cannot update its boot loader

I think you now have a very nice door wedge, 1.4 has blasted all cards, however some can update their Kernal software and may be resurrected. Not the DSTTi :(

For All Flashcart Firmware Updates http://www.linfoxdomain.com/nintendo/ds/
Sakura for the M3Real - Amazing Firmware
http://handheldsources.net
#4
I'm guessing alot of people doesn't know about firmware 1.4 cause i still see alot of posts of people asking where to get these flash cards that are not upgradable.I have a supercard DsOnei.Hopefully the firmware writer does what its suppose to do.
#5
Originally posted by meo626:
I'm guessing alot of people doesn't know about firmware 1.4 cause i still see alot of posts of people asking where to get these flash cards that are not upgradable.I have a supercard DsOnei.Hopefully the firmware writer does what its suppose to do.
But now it is upgradable: http://gbatemp.net/index.php?download=7042
And I can confirm this.
#6
Hi Sorry if I am repeating prev questions but I can't find answer in any of the searches I did. I have just bought a DSTTi with an 8gb sd card. I have kernel V1.17 on it but the menu just errors out. Is there any firmward around that I can put on this to allow me to use this on a NDSi or can you suggest a card to buy that will work like the old DSTT worked with the NDSlite. thx,
#7
Have you upgraded the Kernal of the card (1.4) all the firmwares (and Kernal firmware) is hosted at the site in my signature.


For All Flashcart Firmware Updates http://www.linfoxdomain.com/nintendo/ds/
Sakura for the M3Real - Amazing Firmware
http://handheldsources.net
#8
Hi Kitty
I have downloaded all files from your link and still not working. I tried the DSTTi checkers also and the V1.14 sticks at loading but the older one shows menu and ???. Not sure what any of this means.?? I have used the dstt on the nds but this DSTTi is a pain in the ass. Do you know where I can get a card that will run a 8gb sd with the software pre loaded for the NDSi on software V1.12 as it would be so much easier?
Thanks for the help
Rgds,
K
#9
Unfortunately no card comes pre loaded these days.

I have set up an AceKard 2i and an M3iZero, both worked first time and both can use 8GB cards. If you were going to change the card I would suggest one of these two.


For All Flashcart Firmware Updates http://www.linfoxdomain.com/nintendo/ds/
Sakura for the M3Real - Amazing Firmware
http://handheldsources.net
#10
mobyed200 Suspended account
SPAM removed
This message has been edited since its posting. Latest edit was made on 30 Sep 2009 @ 13:01
#11
mobyed200 Suspended account
SPAM removed
This message has been edited since its posting. Latest edit was made on 30 Sep 2009 @ 13:01
#12
At Last... I have gotten the DSTTi to work after alot of time trying all the diffrent software. Thanks to Kitty for the help.
Thx, K
#13
I'd be really grateful how you did this?

Without realizing I've updated my daughters DSI to v1.4e and now my DSTTi (from www.ndstt.com) card comes up with the black screen, "An error has occured". etc.

It was running with the v1.17 kernel.

I've tried the v1.17a07 kernel with no success.

I have read that I should try the dstti v1.4 kernel - but if the card won't boot to a load screen - how can i select the kernel upgrade
.nds file

Sigh. Any assistance gratefully received..
#14
Originally posted by feather51:


I have read that I should try the dstti v1.4 kernel - but if the card won't boot to a load screen - how can i select the kernel upgrade
.nds file

Sigh. Any assistance gratefully received..

you have to run it on a dsi that has not been updated to 1.4 yet. Or update it on a regular ds lite. Borrow one from a friend or neighbor. Thats the only way to update it.
#15
Hi. There apprears to be some sort of "How To" on the deal extreme site
look up this ref sku.18944
Rgds,
K
#16
Hi. I have just got TTi card for my dsi. I understand from reading the forum that I have to install the kernel on my TTi card before I update the Dsi to V1.4e.
I have just visited what I think is the manufacturers site [url=http://http://www.nds-tti.com/index.asp][/url] and they are showing
Quote:
Note: The perfect solution for NDSI V1.4. 100% supports latest games !
. So if I install the latest kernel V1.18 or V1.19 I assume I can then update the Dsi to v1.4 firmware and the TTi will still work.
My problem, assumptions can make an ass....
My question, has anyone tried this, or know of a known metheod to run the TTi with Dsi V1.4e
thanks in advance and sorry if these question have already been asked, I am a newbie
#17
Ok, think I got this sorted now, installed kernel v1.17 and the Dsi v1.4 patch and all seems ok. Dose anyone know if I can delete the Dsi v1.4 patch files from the sd card after I have completed the update.
#18
Ok Ive read up on the probloms above and think im in the right area ive got a nds lite but im trying to set up a ndstti card up for someone that has a ndsi with 1.4 I know this as thats what stoped his old card working (dont Know which 1)
so have followed the above links and setup the card it tells me its not a fake card
but when i hit the tti_14_check_v2.0.nds file it comes up 1.4 firmware upgrade loading ..... open ROM_PCB1.DAT=ERROR
due to the error mesage i think ive done it wrong or trying it with the wrong file .
or maybe its now set up to work on a 1.4 ndsi
can some one please point me in the right direction
Thanks In advance Bri
#19
Kitty's files worked perfectly

Quick info on what i did

Download the dstti v1.4 firmware.rar file from kitty's page
Download the latest software for your card (1.17 at this time)and copy them to your card along with the three files from kitty's 1.4 firmware file.

Using either a non updated dsi or in my case a normal dslite, run the firmware upgrade program and then voila, you will have a dstti card that will work fine with the 1.4 version of the dsi.

The dstti card now shows up in the menu as "Star wars lethal alliance ubisoft" but i can confirm that it does in fact work just fine for all your backups.

Many,many,many thanks to kittymat for the files and info
#20
you can if you go to ndstt.com
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.