AfterDawn Forums

Can I update a 4.3.3(8J2) to 5.1 Beta and jailbreak that?

This discussion thread has 2 messages.

#1
There was a mistake in the title, I've now found a download for the the 5.1.1 firmware. Here:
http://www.redmondpie.com/download-5.1....official-links/

Can I just use that to update my 4.3.3(8J2) to 5.1.1 and jailbreak that unteathered? Is there any problem with that plan? I was under the impression you needed to upgrade via itunes for some reason? Is that a fact?

I just need to get to iOS5 to be able to run all the apps that require it. I am trying to avoid going to a tethered 6.1 jailbreak.
This message has been edited since its posting. Latest edit was made on 20 Dec 2012 @ 10:30
▼▼ This topic has 1 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Sure! As long as you have 5.1.1 installed on your iPhone, you can jailbreak without any problems.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.