AfterDawn Forums

iPhone 3g - can't get it to unlock!

This discussion thread has 2 messages.

#1
Hi all,

I've recently jailbroken and (attempted to unlock) my iphone. However, with the new SIM in it, the iPhone is constantly "Searching..." for a network

Details are:

iPhone 3g
iOS 4.2.1
Model MB489B
Modem firmware 05.15.04

I used redsn0w 0.9.6rc8 for the jailbreak (standard options - I didn't do the iPad firmware and am wondering if this is my error?)
I then installed Cydia
Then used ultrasn0w (repo666.ultrasn0w.com) for the unlock.

I tried greenpois0n but it didn't recognise the phone in DFU so opted for redsn0w.

So what have I done wrong? I've been through loads of sites, walkthroughs etc and can't see what i've done wrong in the unlock procedure.

If it is that I need to go to the ipad firmware - is that possible now it's already jailbroken?

Could I try blackra1n for the unlock?

So confused!.....


A few more details that may (or may not) help:

Jailbreak didn't work on my vista machine, only my XP machine.
With the new SIM card itunes no longer states "SIM is unsupported"...leading me to believe the unlock has sort of worked.
In the settings on the phone, it recognises the new SIM (or carrier) as orange (which is what the new SIM is - originally O2)



EDIT: just noticed that the ipod player isn't working either now! It starts to load / open a track, then drops back to the album view.....wtf is going on?
▼▼ This topic has 1 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Ultrasn0w doesn't work with 05.15.

The only way you can unlock it is if you update to the iPad Baseband 06.15.00
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.