AfterDawn Forums

Trying to rip the Star Wars Saga with subtitles

This discussion thread has 20 messages.

I'm using DVDfab and Handbrake to rip and convert to M4V. I've done this a couple of times now but I can't seem to get translation subtitles to remain such as when Watto is talking in PH or when Jabba is talking in JotJ.

I selected main movie in DVDfab and let everything as default, in Handbrake I went to the subtitles tab, the only selection available from the drop down was foreign audio search (bitmap) so I added that and slected burned in only. However I've just converted it again and there are still no alien language subtitles!

What am I doing wrong?
▼▼ This topic has 19 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
Here is the tutorial for DVDFab.Maybe this will help.

20 Year U.S.Army Veteran.Vietnam 1969-1972 101st Abn.Div.
I still can't see where I'm going wrong. I've done eveything right in DVDfab and in handbrake I've tried adding forced only which did nothing and burned in which also did nothing. I've done this three times now and each attempt takes 9 hours! I want to make sure I've got it right before I try it again.
Since I have no Blu Ray reader, player or disks - or even examples to test, I can't offer much except that your problem is very common across countless threads.

Here's the best advice I came across.

As an aside, if you have the DVD versions it's a simple matter to open VOB files in DVDSubEdit, select for forced subs then save them as a .srt file which can possibly be used to mux with the Blu Ray (assuming the running time is identical in both versions).
You could rip them separately, something like this

And then add them afterwards, perhaps.

Failing that, I would ask at VideoHelp.
This message has been edited since its posting. Latest edit was made on 16 Dec 2012 @ 13:55

Apparently its not possible to include forced subtitles in Blu-Ray rips as Handbreak doesn't support them yet. The method you suggested seems to be the only way at the moment.

Thanks anyway.
They have a new version of DVDFab available now in case you might want to try it.
This message has been edited since its posting. Latest edit was made on 21 Dec 2012 @ 19:01

20 Year U.S.Army Veteran.Vietnam 1969-1972 101st Abn.Div.
I've got the latest versions of DVDfab and Handbrake.

I noticed that some of the article I was reading are actually quite old and that Handbrake DOES in fact support Blu Ray subtitles now. One article I read said that you need to isolate the subtitles with the alien translations and include them as you would normal subtitles. With Episode I that appears to be the ast track so I'm going to give that a go.
That didn't work but I believe I've found a work around. I have the movie ripped and I have a seperate subtitle file containing the alien language subtitles. I'm going to run it through Handbrake again including this file which I believe should work but just a couple of questions:

1)Will I lose any of the videos quality by running it through Handbrake a second time?

2)I've just started the encode but it says its going to take 5 hours. Is this normal just to add subtitles or is there a quicker way?
It sounds as if you are hardcoding the subs, which may (?) result in some quality loss if the video is re-encoded again and, as you're seeing, is taking a long time.

Soft Subtitles: This means the subtitles will appear as separate selectable tracks in your output file. With the correct playback software, you’ll be able to enable / disable these subtitles as required.

This option shouldn't require the video to be re-encoded, as far as I know.

I'd rather just have them hardcoded to be honest so that I can watch the videos on anything. Providing there isn't much quality loss I don't mind the extra time it takes. I'll find out in about an hour but if the quality has noticably dipped I'll stick with the DVDfab rip and seperate subtitles.
That STILL hasn't worked! It took 7 hours and nothings happened :(

Did I do something wrong? I have an str file which works when selected in VLC player. I went to the subtitles tab in Handbrake, selected Import str and then added the file. Should I have clicked Forced and Burned in or shouldn't it have made a difference?


I spoke to soon, it has worked but not how I wanted. If you play the file through VLC payer and turn subtitles on then it works fine but they have not been burned in so that they will play on other players such as Windows Media Player and iTunes.

Also to save making a new topic, I've been putting my new Blu Ray rips into iTunes but when I try and play them they are ICREDIBLY stuttery and are pretty much unwatchable. The sound it fine but the video just cannot keep up. Is this a problem with iTunes or the file because they play perfectly in all my other player.

I would like to get them working in iTunes, is there anything I can do?
This message has been edited since its posting. Latest edit was made on 30 Dec 2012 @ 15:00
Handbrake can't hardcore .srt subtitles - it says so in the link above.

Take a look here:


I would like to get them working in iTunes, is there anything I can do?
Try going in to Task Manager and setting the Priority of iTunes to Higher and see how that helps.
This message has been edited since its posting. Latest edit was made on 30 Dec 2012 @ 15:06

I already tried the Foreign Audio Search (Bitmap) option to hardcode three times but that didn't work.

Can you just not hardcode Blu Ray subtitles? Some sites say you can't whiles others say you can, but then every option I've tried doesn't work.
Well the thread that I linked on Videohelp moved away from using Handbrake to reach your goal - have you had a look at those other softwares?

I can't give you an answer from personal experience because I haven't done it, but as far as I'm concerned you should be able to.

I'm just going to try MKVToolnix. I was hoping I wouldn't have to download any more softwarebut it doesn't look like I have a choice.

I have been reading that Hanbrake are very close to implimenting the feature so I guess this is just a temporary solution?
lol MKVToolnix doesn't work either, all it does is add an echo to the video.

However subtitles have suddenly started appearing! I'm not sure how I've done this but if I play through Windows Media Player or VLC the subtitles now pop up automatically without having to manually select them. The only catch is I have to have the STR file named the same as the video and in the same folder. I still can't get them hardcoded but at least its a step forward!
The only catch is I have to have the STR file named the same as the video and in the same folder.
Yeah, this is pretty standard across all media players.

I've had a play around with mkvmerge, I managed to stop it adding an echo (I just unchecked one of the audio tracks) and I can get the Subtitles hardcoded but they only appear in VLC player and no matter what the resulting file will not play in iTunes or Quicktime. This is particuarly important as I want to be able to play my videos on my iPhone and Apple TV.

I've just tried doing Toy Story 3 as well, I've read several forums that state that the subtitles for when Buzz is speaking Spanish should be burned in and that no action is required but those aren't appearing either :(
Could it be something to do with my monitor or the software I'm using for playback? I know for some reason the TV/DVD player I have in my bedroom wont display subtitles.

I think my best option is to simply wait until they add the feature to Handbrake. Its already on the nightly build so I guess it should only be a few months? In the meantime would it be wise for me to simply rip/convert the Blu Rays as normal and then aquire the .srt file so that they can be merged in the future? I can be patient with my other Blu Rays but I'm borrowing the Star Wars saga off a friend and he wants it back soon.
Have you tried the nightly build? Don't be too concerned, they wouldn't put anything online that will cause your PC to meltdown etc.

It won't be anything to do with your monitor, and more likely something to do with the players in question. I would suggest VLC is the standard and it is iTunes etc at fault - I assume you have the option to 'Show subtitles when available' in Quicktime ticked?

This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.