AfterDawn Forums

No subtitles from MKV files

This discussion thread has 8 messages.

#1
I'm running Win7 (all newest patches) and have been watching MKVs with no issue. I want to watch a film with subtitles but they won't come up in WMP12. I'm using HaaliMediaSplitter, FFDShow to decode and have DirectVobSub installed.
Haali lists the subs as available and selected and WMP has subtitles turned on but no joy.
Should there be an icon for DirectVobSub when playing a file with subs? How can I be sure Haali is passing the subs to the right program?
I am aware of VLC player - tried it and the subs do work there but i'm looking to make it work in WMP.

Any help would be greatly appreciated.
▼▼ This topic has 7 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
If you have ffdshow installed, open 'video decoder configuration' and check the box for subtitles.
I use the 32 bit version under Windows 7.
#3
Ok, tried that and still no luck.
It appears FFDShow isn't being used to decode this file (h264) as when I run the file only Haali and FFD Audio icons show up in the toolbar - no FFD Video. How do I make this format play via FFDVideo (checking FFDshow video decoder it says H.264/AVC decoded by libavcodec) or how do I make whatever is decoding the video read the subtitles or pass them to WMP12 to display?
Getting a little confused/desperate.
#4
Click on the ffdshow icon on the toolbar - is Haali and subtitles checked (Haali icon should also be on the toolbar).
Still no luck, post here:
http://forum.videohelp.com/



#5
I've realised an issue I'm running on to is that FFDShow is not decoding the video - I have an icon on the taskbar for FFa and Haali, but not FFv. How do I find out what decoder it is using or force it to use FFDShow? I think once it is using that then I will be able to sort out the subtitles.
#6
Try dragging the file into GraphEdit.




#7
Thanks for all your help attar, I've found the problem. I needed to change a setting in Haali - 'Use custom media type for H.264' set to Yes. Now it passes the video decoding to FFDShow which either passes the subtitles to DirectVobSub or displays them itself. Either way, it works. Thinking about it, DirectVobSub isn't used as there is no icon for it appearing.
Incidently, GraphEdit recognised that the video decoding was being passed to 'Microsoft DTV-DVD Video Decoder' then to something called '0002' originally. Any idea what 0002 is? Now with FFDShow decoding the video, GraphEdit has no idea about the video!
#8
Sounds like you figured it out in spite of my 'help'.

Quote:
Any idea what 0002 is?
Nope.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.