AfterDawn Forums

Panasonic DMR-E85H error U99

This discussion thread has 2306 messages.

#1
I have the DMR-E85H Recorder as well as the older DMR-E80H, and after 3 error U99's on the 85H, I have made the following observations: (1)All errors occurred while doing a "Divide". (2) All u99's happened after the hard drive was more than 50% full (may not be relevant however). (3) When I do a "Divide" on the DMR-E80H, it takes about 6 seconds. On the 85H, it takes almost 12 seconds - twice as long! This makes no sense, as the 85H is newer, and should be at least the same if not faster - not slower! (4) While talking to the Panasonic support (?) people, they say they have never heard of this error. From reading previous threads on this board, that can't be true. (5) My feeling is that a software (firmware) glitch is at fault, and a file "directory" area is being written with bogus data (probably video data) and when the firmware tries to make sense of it, it throws up and generates the "Error U99". I was told this is a "Hard Drive Failure" error. I have thoroughly tested the hard drive when this has happened, and no hard errors are found. (6) It seems to me if we could get the specifications of their file structure on the hard drive, most - if not all - of the data could be recovered. I have 2 hard drives with lots of video I would like to recover on them. The third drive I allowed the unit to re-format (after first running FDISK on it with a PC to force the re-format.) I would be interested if anyone has gotten any further with this. I saw someone said "Best Buy" was able to recover a U99 system, but I sure don't know how they did it. Panasonic's answer was to replace the hard drive. I also think they should FIX the firmware, and offer to replace the firmware board on those units. Perhaps if we all got together, we could force a "Recall" on that unit to fix the bug. The best way to prove the bug is the difference in the time it takes the older 80H versus the newer 85H. Oh, and if anyone has that "new" 400 GB unit I've seen advertised (but it hasn't shown up in any stores local to me), I would like to know how long it takes to do a "divide" on that unit! If anyone wants to discuss this privately, my email is "Roger (at) DXCC.COM". Thanks!
Roger
▼▼ This topic has 2305 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
chump05 Suspended due non-functional email address
I had the EXACT problem 2 days ago. U99 error in the middle of a Divide. Drive's at about 50% capacity. Panasonic support said to take it in to be repaired. Tech support is pretty worthless when the only solution they ever have is to tell you to shut it off and try to reset. Panasonic needs to address the issues involved with this unit. $500 is a lot to pay for a beta test/debugging project released to the public.
#3
It's my favorite error.

You can try the factory test menu, which is what worked ONCE, done by the Best Buy service center.

If you're interested in the file format I've done some work, but a lot more needs to be done to retrieve the video.

About number 4, you can find the Japanese website listing this error, how it happens, and their recommendation to never use divide title without first performing the upgrade. As far as I know, the US version can't be upgraded without replacing the digital board, which is what they did after the third U99 error.
#4
What is the "Factory Test"? How do I invoke that? I have talked to some "inner sanctum" engineers at the Panasonic main repair facility in Elgin, Illinois, and they don't seem to know about any of this... For months, I have been told that no one at Panasonic has even heard of this error! Which Japanese website are you referring to? It sounds like the Japanese version of the machine could be upgraded in the field, but the US version cannot. Probably why you have to change out the controller board. Maybe the firmware is not in "Flash Rom" on the US version. I'd sure like to at least "Try" the factory test before shipping it to Panasonic! Thanks...
Roger
#5
Oh, forgot to ask -- It seems you (E85H?) have had the digital board replaced? Is that correct? And I assume you haven't gotten the dreaded "U99" since then? I would be interested to know if it takes 5 seconds now to do a "Divide" operation. Or does it still take 11-12 seconds? Thanks.
Roger
#6
I noticed the few times I tried it that the divide was faster. But I never divide anymore, I use chapter divide and playlists to dub. If I really want both items from one title to be split, I use dvd-ram to write a chapter, then read it back as a new title.

It's factory service mode, not factory test.
http://www.avsforum.com/avs-vb/showthread.php?s=&threadid=477334&highlight=u99

Here's the Japanese page:
http://panasonic.jp/support/dvd/faq/e85h/info/
You can have google translate it to engrish.
#7
If the U99 error ever causes your hard drive to jam, here is what you do to avoid having to take it to any repair shop.

1. Replace the hard drive (which is what I did by getting one off another machine) & it will debug the machine of the U99 error asking you to reformat the new hard drive. Now your machine will work without the u99 error. Only now you probably want your old drive containing all of your TV shows, movies, etc back in the unit.

2. Turn the unit off, unplug the unit's Power Plug and take out the new hard drive and put the old hard drive back in but do it where you can easily unplug the white Power Wire to the hard drive a few steps later (-not the hard drive's wide black wire). If you are angling the hard drive in order to later unplug the white wire, make sure to protect the hard drive from shorting out by using cloth, etc underneath from it touching any metal.

3. Leaving the machine's cover off, plug in & turn the unit back on. Machine will begin to boot & a message will pop up asking you to "Format" . Of course if you have nothing on it of value go ahead and choose "Yes" -BUT- To save your data continue these steps.

4. With the option still on the screen, pull off the white POWER lead wire from the Hard Drive, but do not touch the wide black IDE cable---only the the white POWER wire, also make sure to pull it off evenly.

5. Now with the remote go ahead and hit "ENTER". The unit will try to format only it will get stuck since the machine can not talk to the poweless Hard Drive.

6. After about 5 seconds unplug the DVD Recorder from the AC Plug (wall plug or from in the back of the unit).

7. Plug In the Hard Drive white Power cable.

8. Install the Hard drive properly then put the lid cover back on the DVD Recorder and plug the unit in and turn the Power on.

9. The unit should do a quick scan of the drive restoring all your recorded shows back into it's list.
effectively bypassing the format routine.

(Note in Step #3, there may be a problem with the unit's cover off. On the side of the unit, there is a little hitch that sticks out when the cover is off, which may let your machine know the cover is off & refuse to work. If this is true, stick something to push that little hitch inward so the machine will think the cover is on.)
#8
Hold on! This is a VERY dangerous technique. You could seriously damage the unit or the Hard Drive. It might take longer to impliment, but if you have the skills, it would be better to build up a cable (use a power extension cable - most computer guys have one). Then, cut the two power lines (Red & Yellow) and put a double pole switch between the male & female connectors. That way, you can cleanly cut the power without the chance of shorting anything out. I might even try this myself, as I have two hard drives with video data that I would like to recover. But unplugging the power while the unit is on would make me very nervous. And until I see for myself, I'm not sure if it would recover the data either. By the way, there IS a fix for the "U99" problem. It's been available since last August, but Panasonic America has been keeping it a secret (idiots). I have the upgrade CD, and if anyone has a unit built before August, I can send them the latest version of the firmware. I have been testing it for two weeks -- I have been dividing like crazy (on two machines) and it appears to be fixed. (Panasonic finally admitted to me that there was a bug, and it has been fixed - a bug they denied even existed until I pushed them up against the wall...) By the way, for those following this - I believe the bug was an interrupt/timing thing. I also still believe there is bad code that causes a "Divide" on the hard drive to take 11-12 seconds (but only 5 seconds on a DVD-RAM - which should be slower!!!). But at least the dreaded -data losing- "U99" error has been fixed. Whew!

Roger.
(Roger at dxcc.com)
#9
Oh, one more thing. There is a "Service Mode" that does all kinds of useful things. I once had a problem where the ability to manually set the clock was permanently greyed out. I called support for help, and I was told it was "corrupted" RAM, and the unit had to be serviced. Another case of inept support. There was a simple way to "Clear" the unit back to factory defaults. At that point, I was able to manually set the clock. Of course, I had to go through setting up all of the other parameters but no big deal. Better than losing the use of the machine for 2-3 weeks! Plus paying for shipping, etc. Panasonic (America) Support really is in need of better training - and an attitude adjustment!

Also, I will be writing up a document outlining all the neat things I have found out about this machine. I'll drop a note here when it's done...

A final note: I looked at some of the other machines like this on the market. They all suck compared to this one. Too bad their support people aren't as good as their design people.

Roger.
#10
That would be nice and useful to have. I know how to get into the "Service Mode" but don't really have much info on what to do inside the service mode other than a few little codes I found on the net here and there.

Be nice to know a lot more about this unit since very few tech's know how to fix this machine without shipping it off for 2 to 3 weeks.
#11
Congratulations on a possible fix for the U99 data loss problem... I will let you know how it works for the 5 drives I have that had U99 errors (and I didn;t want to lose the programs! ) Your fix is similar to the recurring DVD-RAM problem write + endless reboot cycle... unplugging the hard drive allows the DVD-RAM to be ejected.

K2SMN, I would like to know that CD in more detail... did you burn it yourself, or did they send it to you ?

If they sent it to you, do you have a contact ?

The reason I ask that particular queston is the japanese website mentions using a particular CD burning format that is not supported by anything I have.
#12
I have finished my document discussing the "U99" error, along with how to prevent that by doing a firmware upgrade. It's easy to do. If you own one of these fine machines, you should read this. There is a way to check your current version of the firmware, and instructions to do the upgrade. I have placed it on my website. Here is the link- http://www.dxcc.com/dmr-e85h.htm -- good luck.
Roger
#13
dabv Suspended due non-functional email address
Does anyone know if it is possible to upgrade a panasonic DMR-E80H? Can the firmware be changed so I can use the TV Guide onscreen feature that is found in the DMR-85H? Is it possible to change the hard drive for a larger hard drive?

dabv
#14
Just an Update... I finally had a chance to try out rtjoby's method to recover a drive that had the "U99" error. I did build the cable to cut the power to the hard drive at the right time - safely. I followed rtjoby's instructions. I put the old drive in and powered the machine up. It went through some "Please Wait" stuff and then shut down. (This is normal when you unplug the machine from the AC Mains.) I then pressed the power button, and much to my surprise it started up normally. No "Format" as I thought it would have. However, when I looked at the files on the drive, they were the ones that were on the "good" drive I had just taken out - NOT the files on the old drive...? So, I shut it off again. When I next powered up, it finally went in to the "format" routine. The interesting thing here is that it had "remembered" the files from the good drive I had just taken out. It also - initially - found the hard drive OK. (There are some really weird firmware algorithyms here...) At any rate, I followed the instructions and removed power from the drive and answered "Yes" to the format question. It just hung there of course. I unplugged the unit. I turned the power to the drive back on. I plugged in the unit. After some more "Please Wait" messages, it tried to start-up but then went back to the "Format Drive" routine. I went through this 3 times with no luck. No matter what I did, it wanted to format the drive. I then tried another of my trashed ("U99") drives. Same thing. No luck. Finally, I put the "good" drive back. When I powered up, everything looked normal. No format message. However, when I looked at the list of files, they had strange data. There was an "X" in the left column, the name was missing, the date was missing (--/--) and the time was 12:00am on all files. Also, I couldn't "Play" them and I couldn't "Erase" them. Very odd. I finally just re-formatted the drive (via the disc menu). Note: I had already copied anything important and was prepared to do this! The bottom line: This method does not work! Any other ideas?
Roger.
#15
Perhaps the method works only for ridding it of the latest drive to have the error... where the built in file list would match the drive.
#16
The description given by rtjoby seemed to say that he had put a new drive in the unit - formatted it and used it. THEN he put back the original drive and used his described method to recover the files on it. I'd be curious if the original drive was pulled out because of an error "U99", or if he just swapped out the drive? Then, when he put the old one back, since it didn't have the "U99" error, his method worked. My drives were pulled out because of the error...
Of course, since we'll never get that error again (since the firmware upgrade), it doesn't matter anymore. I'm still trying to figure a way to recover the data on the 4 old drives I have here. If I ever do manage to do it, I'll post how here...
Roger.
#17
I just read through this thread and have a off subject problem that I kinda feel I've run into a brick wall. I had a e85 that i just returned today. This was the third actually. The tv guide feature never seemed to sync and after 4-6 days the unit would lock up and the only thing I could do is unplug it and plug it back in and away I would go for another 4-6 days again. Hearing all your posts about panny's tech support was interesting at the least. I've called at least a dozen times and was told something different each time. Early on one tech did admit they heard of the problem (while using tv guide the screen would go bright green and the unit would lock)and said that units made before a certain date had this problem. Of course no one after that would admit this to be true. The last lock-up happened 2 days ago (3/1/05) that day I called tech support back and they said the did know of the problem and it was a firmware issue. They instructed me to take it to a service center and they would send the center the upgrade disk. Unfortunately, the tech center said it would take 2 weeks to do this upgrade. Panny's tech said units with the 3rd and 4th digit of the serial number that was 4h or lower (4g, 4f...) were effected. They also made me feel as if I was the only one on planet Earth that this has happened to. Has anyone experienced this issue? I was also wondering if the firmware update posted here would of fixed the problem. As a side note, no one seems to have these units now. I tried a half dozen Best buy's and Circuit city's and they're all out. I'm thinking Panny may have a new unit coming out soon - Anyone heard of this?

Thanks,
Joe
#18
Yes Joe, this upgrade would fix the problem. Why Panasonic doesn't make this upgrade easier is beyond my comprehension. The unit is well designed, built well and performs well. Better than any other DVR I have tried. But Panasonic (America) support stinks. You can do the upgrade yourself in just a few minutes. Did you read my description? (at the url mentioned in an earlier post.) Too bad you returned the unit today. Since I don't use the "TV Guide" feature, I had never noticed those problems. However, I do know the firmware upgrade does fix it - as well as a number of other things...
Roger.
#19
wbarnes Suspended due non-functional email address
Hey Roger (and all) - Thanks so much for your info. I got the DMR-E85H a couple of weeks ago, and have enjoyed gettings a grasp of all the features. But, I have been reading about the "bugs," and finally ran across this thread and your "Snafu" account as the definitive description on the web. I have downloaded your 6 meg upgrade file, but haven't run it yet. I want to save everything I have on the HDD to DVD-R's or DVD-RAM's first, b/c I'm assuming the firmware upgrade will format the HDD? (maybe not, but I'm going to be safe rather than sorry).

I have not done any dividing of titles yet, but I'm sure not going to now until I upgrade - haven't had the dreaded U99 error yet, though I HAVE had the "green Progam Guide" freeze-up described earlier . . .

My question -- the back of my unit says it was manufactured in Oct. 2004, but nevertheless when I put the unit in Service Mode, it says the that the Main Firmware Version is indeed 0950DL, whereas your upgrade is 0970DL. So, I am assuming I should definitely do it????
#20
Roger,

Thanks for the info. As it stands now, you can't find these anywhere. Circuit city's web page says "out of stock" and everywhere else I've tried is out also. I'm guessing there's a new model in the works. I just hope they get it out soon...I really miss the damn thing.

Joe
#21
wbarnes,

Oct, 2004, that's interesting. What is the 4th digit of your serial? Panny states h or higher has the new firmware.

Joe
#22
wbarnes Suspended due non-functional email address
Mine is a "J". I don't have it right in front of me, but it was KS4J_______, or something. Does that jive with what Panasonic told you? From looking at a translated version of the Japanese Panasonic support web site referenced above, I got the impression that all of the units numbered "F" and later in the alphabet (G, H, etc.) would be OK. Maybe that's just in Japan, though - maybe it's a different sequence of serial numbers here. . . .
#23
wbarnes,
Panny said h and above was the new firmware. If you have a J and your tv guide screen has locked up they're incorrect. I can't find any of these above e. I think I'm going to hold off for a few weeks and see if a new model come out. How long have you had your? How often has it locked up? I could go about 4-5 days. I could tell it was getting ready to crap out, It would become unresponsive to scrolling the guide.
Joe
#24
Regarding the comments from K2SMN (3 March 2005 @ 18:03) about changing hard drives, and having the DMR list the previous drive's contents: I read elsewhere on the web a few months ago that the "file system" (i.e. the directory of shows) is stored in memory (flash?), and not on the disk, which would be consistent with K2SMN's observations.

The report stated that when a lot of shortening of titles was done, the algorithms for handling the file system screwed up (basically, it got fragmented, and the user had to dump the contents to DVD-RAM, format the drive, and then reload the drive from DVD-RAM).

My DMR-E85H has had a variety of problems: the TV Guide lock-up (green screen, etc.), U99, rebooting on its own and claiming that all shows were lost (a manual reset, holding the power button for ~5 seconds, brought the recorded shows back), etc.

I'm trying to follow Roger Amidon's instructions for upgrading the firmware, but have run into a roadblock. Last night I put the unit into service mode so that I could see the firmware versions. That worked fine. But this morning the unit won't enter service mode. Sigh. I did the manual reset, no go; power-cycled it, no go. You'd think the unit sensed trouble on the way! :-)
#25
wbarnes Suspended due non-functional email address
I thik it just did the "green screen" once, it may have "froze up" one other time - the Navigator wouldn't come on or something. Both times, I just powered down, and repowered up, and everything was fine. I have had the unit for two weeks.

I was all set to do Roger's firmware update, although he has told me my firmware version (09050DL?) has the "U99" bug fixed. Nevertheless, as his is slightly newer, I was thinking of doing it anyway. But now, with the kinks mentioned, I just don't know.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.