AfterDawn Forums

Dvd Shrink gets Out Of Memory error, how to fix?

This discussion thread has 11 messages.

#1
I'm getting an error when I try to backup The Forgotten and I'm using DVD Shrink 3.2 ver.3.2.0.15

The error is:

Out of Memory
Not enough storage is available to process this command.
DVD Shrink encountered an error and cannot continue.

I have 512 MB ram and Max of 4095 MB Virtual Memory on my drive.

The whole movie is over 7 GB and I can rip it fine to the drive. I can even backup with DVD Shrink and do the whole movie omitting only languages and subtitles other than English. I get Shrink to make a new directory of Video_TS files to 4.7 GB.

However, when I try to just grab the first Title set of the movie, again omitting all languages and subtitles other than English, I get half way and the error "Out of Memory" pops up. The selected total video to backup is only 3,510 MB. And my HD's have more than 22 GB free before I start the process.

The one thing I did notice was that when backing up the one title, Shrink reports during the backup that my "Buffered:" memory gets as far as 1,687 MB and the error comes up.

But when I do the whole Disc it only reports "Buffered:" memory at 64 MB and doesn't seem to go over that from what I've observed, and it does a successful backup with over 7 GB with the same movie.

What can I do to get Shrink to lock "Buffered:" memory access to under 1 GB? Or is the some sort of other problem with Out of Memory coming up?
▼▼ This topic has 10 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Errorcode - Out of memory/Not enough storage is available to process this command.
http://forum.digital-digest.com/showthread.php?s=&threadid=45265
#3
I had that problem, and tried damn near everything to get around it. Here's what finally did:

The Forgotten has 2 versions of the movie on it-the theatrical version and an extended one with an alternate ending. You need to use reauthor mode, I grabbed both movie titles, and (IMPORTANT!) change your start frame to where you see the Columbia logo. If you want both titles like I did you need to do this for both titles. That should solve your problem and your buffer should not get over 100 MB. If you notice your buffer go over that just cancel the backup and try again, this time change your start frame to a little bit later (like at the end of the Columbia logo). Also watch it just after 50% when it starts getting into the second title (if you choose to get both). Make sure the buffer stays at a normal level there too.
This message has been edited since its posting. Latest edit was made on 27 Jan 2005 @ 6:49

Convert PAL to NTSC or NTSC to PAL------>http://forums.afterdawn.com/thread_view.cfm/167922
ScubaPete's guides------>http://www.dvdplusvideo.com/tutorial007.html
Bbmayo's guides------>http://home.comcast.net/~bbmayo/index.html

My ever-growing movie collection------>http://www.intervocative.com/dvdcollection.aspx/squizzle
#4
I had a feeling I would be able to grab both the normal and extended versions with no problem because I had no problem grabbing the whole disc. But I was hoping to just grab the normal version to get the best quality without having to compress since it would be under 4.7 GB. And was doing excactly what you did when I was grabbing the movies alone, I changed the start point to just before the logo since I had noticed a long gap before the movie started. Is there any other way I can stop DVD Shrink from buffering > 1 GB when grabbing the one title off of Forgotten?
#5
I don't think so, but if anyone knows of a way, I'd like to know too. I hope that not many movies in the future are gonna be like this. It really pissed me off.

Convert PAL to NTSC or NTSC to PAL------>http://forums.afterdawn.com/thread_view.cfm/167922
ScubaPete's guides------>http://www.dvdplusvideo.com/tutorial007.html
Bbmayo's guides------>http://home.comcast.net/~bbmayo/index.html

My ever-growing movie collection------>http://www.intervocative.com/dvdcollection.aspx/squizzle
#6
I have had two movies do this to me. What was weird is that I only had one dvdshrink going at the time. I usually run between 3-6 with no problems. I forget the first movie that did this but the 2nd one was The Grudge. What I did was to use shrink with the original dvd and click open disk instead of using decrypter to rip the movie.


#7
When I did this movie and tried to reathor, I had the same problem even with 1Gig of virtual memory. So what I did instead was use full disc mode and insert a still image in the special features folder, manually adjust the compression of the menus folder as low as it would go and then get rid of the various audio and subtitle streams that I didn't want. After doing that, I still managed above 90% for the main movie folder which was good enough for me so I clicked Backup.

Hopefully this will help somebody.


#8
I've tried and tried also, I tried to get Resident Evil II to backup after using DVDD. Shrink runs my system out of memory, CloneDVD and Nero Recode2 both do it as well. I have 1Gb of Ram and I changed the drives virtual memory to about 2GB's. 1024x2=2048

I just don't get it?!

So, after getting so frustrated, I gave up on it! I've read posts with other saying they were able to use shrink and others who could not! where do some of us go from here?
#9
Well my new error message is

InterfaceThread Runtime Exception!
Message=Out of system Resources

Decrypter is the only program telling me this.


#10
Hmmm, I've tried decrypting Resident Evil 2 with DVDD in IFO mode and as far as I can tell, it rips good, but when I try to get shrink to open the files I get the following error "Invalid data in file (VTS_02_1.VOB) Overlapped I/O operation is in use.

I don't get this error if I load the same movie but from and .ISO file.
#11
If I remember correctly I used shrink to "open disk" instead of using decrypter.


This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.