AfterDawn Forums

Drive problems: Tray wont open

This discussion thread has 13 messages.

#1
I need some help, I tried to open my dvdrom tray and it wont open. I press it and it just doesnt open. I even tried putting a pin into the manual release hole.
I need some help.
Could it possibly be driver-related?
▼▼ This topic has 12 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
shut down the computer, disconnect the data cable from drive & restart computer so have power to open the drive than reconnect the data cable to see if drive opens after computer restarts again
#3
If that does not work try this...

Brobear suggested this once in a forum thread and it worked. Remember some have kids in the house too!!!

Believe it or not, the person with the same problem had 2 dvd/cd's in the drive at the same time. With your PC off, take a small screwdriver and lightly pry the tray door open.
This message has been edited since its posting. Latest edit was made on 03 Mar 2005 @ 14:29
#4
Did you try clicking on My Computer, right click on the drive in question then clicking "eject"?
#5
ddp, Im not sure what your asking me. You want me to open my computer, and pull the plug on the drive? Ive never opened a computer....yikes...
#6
Fixed.
I went into the hardware profiles, disabled the drive, then enabled it and it sprang to life. Dont know the problem, but its fixed. Thanks anyways.
#7
it's not that bad & you'll see what the inside looks like. shut down the computer, disconnect the external powercord to case as some computers still have some power(about 5v) than disconnect the wide 40 or 80 wire(40 pin connector)cable from drive, reconnect external power cable & turn on computer. than push cd tray button to see if tray pops out. if still no after a few attempts than get a new drive
#8
teach & learn
#9
jer2911tx Suspended due non-functional email address
i've had this happen before.
next time, try ctrl alt delete and check what processes are running, the drive could be hung up and not responding, so cancel its task.

or go to my computer and right click on the drive and click on eject.
#10
Nero's InCD and Roxio's D2D will sometimes do that to your drives. Are there any other reasons to NOT have packet writing software on your computer? :)

Actually, I could list a few more. :)
This message has been edited since its posting. Latest edit was made on 05 Apr 2005 @ 14:23

Life is good!
GrandpaBruce - Vietnam Vet - 1970 - 1971
Computer: Intel Core i7-920 Nehalim;Asus P6T Deluxe V2
#11
Im having trouble with it, like that same guy, i just bought this new game and apparently it says the disc has got to b in the dvd drive, but it doesnt open, thers a light that flashes when i click it but nothings happend, i've gone to it n right click, eject, but still nothing happens, and im afraid to try n force it open because it seems like its about to break, n e other suggestions?
#12
I just got it to open actually, BUT the reason y it never did open is because the belt broke.. which just fell out when i opened it, do any of you kno what its called? the DVD drive belt, it snapped... *sigh* if any of u kno wut its called that would b great, thanks
#13
if a dvd rom drive than scrap old drive & get a new 1 as about $30Can. or get a dvd burner for about $71Can
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.