AfterDawn Forums

audio out of synch

This discussion thread has 14 messages.

#1
Fiz24 Suspended due non-functional email address
I have a divx file and the audio is ahead of the video. Could someone advise how I can correct this.

Many thanx for any suggestions
▼▼ This topic has 13 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Hi Fiz,
To resynch the DivX, you need to re-time it in NanDub.
Set both A & V to 'direct stream copy', then advance or retard the audio relative to the video to achieve sync at the beginning of the AVI.
If the sync wanders away as the AVI progresses, you must adjust the video framerate to achieve sync at the end of the DivX.
If you are sync'd at the start, and at the end, and the sync wanders around in the middle of the program, you're bunned ;^(
Ask back here if you have any problems.
Regards


ABit AB9 Pro
Intel Core 2 Duo E6420 @ 2.4GHz
2GB OCZ PC2-6400 Platinum XTC R2
ATI Radeon X1900XT 512MB
Enermax Liberty 620W
320GB/16MB WD, 150GB/16MB Raptor
Plextor PX-755SA DVD (SATA)
#3
Fiz24 Suspended due non-functional email address
Thanks for the help. Will give NanDub a go, not used before, but your explanation sounds simple.

Fiz
#4
check out this link for an excellent guide and explanation on audio problems.and the ways to fix them



http://nickyguides.digital-digest.com/



join me,and other members here,on the "unofficial" afterdawn live chat channel ->
http://www.adbuddies.org/
#5
Hello all
I have the same problem.
is there any other software that can do the same as nandub or avinfo?
Nandub is complicate for me and avinfo doesn't work.:-[
#6
1) VirtualDubMod. Open your AVI. Do Stream___Stream List___Save WAV.
2) HeadAC3he. Encode that WAV audio stream into MP3. Choose, just below the input's file name, a proper delay. Usually, if you encode the sound CBR you don't have any delay, but if the audio was badlly encoded you'll have a constant delay. Listen to the movie and find out the proper delay to apply.
Click [Options>>] a couple of times until you can choose the LAME configuration. Choose as Preset Alt CBR. Check the mode becomes CBR. Choose a proper bitrate (e.g. 112 or 128 kbps)
3) VirtualDubMod and Open your AVI (again). Do Stream___Stream List. This time DISABLE the old sound stream and ADD your new MP3 audio stream you just made.
Keep Video's settings at Direct Stream Copy and do File__Save (F7) to save your new AVI. If you checked Video__Direct Stream Copy , the video won't change a bit, but the sound will be your delayed MP3 sound stream.
I cannot do more. Free software, a full detailed guide....
This message has been edited since its posting. Latest edit was made on 10 May 2005 @ 4:48
#7
I'm sorry, but I respectfully disagree ;^(
He can quickly & easily re-time the video and audio he has (be it AC3 5.1, AC3 2.0, VBR MP3 or CBR MP3) in about 90 seconds, with the very simple solution I have described.
Direct-stream copy both.
Adjust the synch.
Done.
@ Narutard
Nandub is very, very simple.
It is the same as VDubMod, but it works with VBR and AC3 audio.
You open the AVI, select direct-stream video, select direct-stream AVI audio, leave the interleave setting on the default (every 1 video frame) and then adjust the audio to begin sooner, or begin later, using the 'Audio skew correction' on the Audio > Interleaving options menu.
The adjustment is in milliseconds (ms).
Remember that 1000 ms = 1 second, and you're good to go :^)
'Save file as...' and then give it a new name (or same name in different directory).
I have explained this very simple solution so many times that I grow weary of explaining it, LoL ;^) can n00bies not search to find the previous explanations?
It seems that even the Moderators are not listening to me...
L8R

ABit AB9 Pro
Intel Core 2 Duo E6420 @ 2.4GHz
2GB OCZ PC2-6400 Platinum XTC R2
ATI Radeon X1900XT 512MB
Enermax Liberty 620W
320GB/16MB WD, 150GB/16MB Raptor
Plextor PX-755SA DVD (SATA)
#8
Thanks Aldaco
Thanks OGS

I'll give it a try again
#9
i got the same problem but i got a wmv file. is VirtualDub just for AVI what is a program for wmv files that i can fix the audio out of sync? or can i use nandub and is there a guide on wmv files to fix the audio out of sync. i found the guide for AVI but havnt found 1 for wmv any 1 know plz let me know...

thanks..
#10
Alas, VirtualDub has no WMV support. TMPGEnc can transform WMV --> MPG and you can apply the trick to that MPG, but you can only find some version (like v1.3) which supports ASF.
Therefore, for what I know:
1) the problem of a a constant out-of-sync can be solved by 1.1) extracting the sound stream from the MPG you obtain by transforming WMV --> MPG with TMPGEnc, then 1.2) re-encoding the sound stream to MP2 with HeadAC3he applying a delay to countereffect the un-sync 1.3) re-multiplexing that stream to the movie (video=MPG movie, sound=the delayed one)
2) the probelem of an un-sync due to the use of CBR MP3 compression applies only in the AVI files
#11
but what if your file is an mpg?
#12
is there a guide that shows u step by step cuz iam clue less on how to use this program?
#13
The_OGS,

I resynched a video of mine as per your directions, but it doesn`t seem to resynch the audio at all. It takes about 90 seconds as you said, and it creates a new file but the audio is still just as desynched as it was in the previous file. Is there something else that has to be done?
This message has been edited since its posting. Latest edit was made on 27 Jun 2005 @ 17:09
#14
Hi Shryke,
Quote:
adjust the audio to begin sooner, or begin later, using the 'Audio skew correction' on the Audio > Interleaving options menu. The adjustment is in milliseconds (ms).
So, if you are ~2.5 seconds out, that is 2500ms.
If you adjust wrong (50/50 chance) you will double the problem by doubling the error, instead of correcting it, y'know?
It usually takes trial&error and some listening training to identify early/late and estimate the milliseconds - I got quite good at it (then I started using GordianKnot: no more problems).
Anyway, you are moving the audio early/late, relative to the video.
If your file is 'the same' maybe you're doing it wrong...
If however your file is different (but not necessarily synch'ed yet) then at least it's working, and you must keep at it until you get it closer & closer.
Regards


ABit AB9 Pro
Intel Core 2 Duo E6420 @ 2.4GHz
2GB OCZ PC2-6400 Platinum XTC R2
ATI Radeon X1900XT 512MB
Enermax Liberty 620W
320GB/16MB WD, 150GB/16MB Raptor
Plextor PX-755SA DVD (SATA)
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.