AfterDawn Forums

Azureus NAT Error with Wireless Adapter

This discussion thread has 31 messages.

#1
My knowledge of this stuff is pretty limited, so I'll try and be direct as possible and hopefully someone can help me out:

Basically, whenever I run Azureus, I can't download anything and if I try and test the server port, I always get an NAT Error. I'm running my Internet via a Wireless G USB Network Adapter which picks up the signal from a cable modem. If anyone has any suggestions on how I can get rid of the NAT Error and get my downloads to work, it would be very helpful.
▼▼ This topic has 30 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
I get exactly the same! Even whe I have turned NAT off for my wireless ADSL router. Tried setting up TCP/UDP ports and got nowhere. Set them up within Windows Firewall (ZoneAlarm was harder to use) and router firewall.

I have no idea how to get Azureus working and I'm supposed to be an expert!
#3
hi pepes
i dont know which router you are using but,
on the d-link wireless you need to,
first go into azurius and set up the port settings to 49152 for example,
now you need to gain your ip address from your computer,
then open up your router config page
if you have the d-link
goto into your internet explorer and in the search bar type in
192.168.1.1
this will take you to your sign on screen
and if you have left it by default type admin and admin for the password.
now goto wireless scroll around and find your d.m.z settings page
this stands for de militarize zone.
what you are going to do here is enter your ip address of your computer then save these settings(important to do this)
what you have done now is moved your computer out from the protection of the routers firewall which is virtually inpenetrable,
you will now be able to access your downloads,
but remember that now your computer is wide open to all the web and it`s usuall viruses etc, make sure you have a good antivirus program installed and download your self a good trojan blocker/remover cos you will need them for your own safety
good luck guys
all the best
if you need anymore help..then post me
i will try my best to get you moving
badger

badger
#4
The trouble with this is that you shouldn't actually need to do it. I had exactly the same problems but then thanks to losing the connection, I did the following:-

reset router to factory defaults
rebuilt PC
tried Azureus again and bingo!

I don't know why my setup now works and it didn't before. I'm even using ZoneAlarm Pro on this PC and Windows Firewall on another and both seem to work perfectly if a bit slow.
#5
To all above,

Have you tried going back to version 2.2.0.* (available on sourceforge site) I think the new version has a few 'issues'


#6
Hi all, this is to help people using routers.

If Azureus is showing yellow smilies and you have a router, then you need to set up port forwarding. Don't worry about your Norton/Zone alarm firewall, if they are setup to allow Azureus internet access then thats not whats wrong.

To fix the problem, you will need to add Azureus port forwarding to your router. As these settings can be in different sections here is a site that provides details for setting up port forwarding for a number a routers and programs (quite a lot really).

Instructions are found here: http://www.portforward.com/routers.htm

If for some reason you can't find your router, which is highly inprobable below are some brief instructions:

You will need a static IP, e.g if you have a router it will be something like 192.168.1.xxx, to find this out go Start > Run > cmd (this opens up the Dos Prompt) type ipconfig /all (look down to the number across from IP Address, this is your address, different to your external address).

Once your know your IP address you can map a port range for forwarding purposes. Open up your router by typing in its addressing into a internet browser, for me this was 192.168.1.2 Login with username and password then setup port forwarding, this was under virtual server for me e.g. Start 6881 End 6999 TCP 192.168.1.xxx
Save, restart router.

In Azureus > Tools > NAT / Firewall Test > Make sure the listening port is something like 6881. After 5-10 minutes the smilies should change colour from yellow to green.

:)
#7
Hmmmm...

When I reset my router to factory default and rebuilt my PC, Azureus started working perfectly although possibly slower than I would expect for a 512Kbps connection. So there was something wrong but I don't know what! When rebuilt I replace Windows Firewall with ZoneAlarm Pro and it worked. But that I think is just a coinicidence.
#8
ok - i've read SO many posts and ideas about NAT errors in Azureus but i can't get it working. i can download torrents - but always at yellow smiley status. i enabled port forwarding on my linksys router exactly as suggested by portforward.com, i opened ports 6881-6889 on my windows sp2 firewall (suggested in this forums FAQ), and i still can't get rid of the NAT error. any more ideas??

ps not sure if it's related but sometimes i get an error when starting Azureus that 6881 cannot be opened for "listening" because it is in use - but i'm not sure that's possible. how would i release it if it were?

THANKS.
#9
i also forwarded port 65535 after reading somewhere that that was "magic" in some way (ha!). no dice. opened that in the windows firewall (TCP and UDP), and forwarded it to my static IP. still NAT error. jeez this is a nightmare.
#10
@ zilla31,

did you also make it the 'listening port' for Azureus?




#11
yes i've done that - and i have that "bind to local IP address" empty just like you do in your screen shot. anything else to try? i'll be happy to send screen shots of any of my settings pages if that will help :)
#12
ps it seems that no matter what i set the "listening" port to, when i restart Azureus it tells me that the port is not available all of a sudden... but i'm pretty positive nothing else is using 65535 :) and that no other instance of Az is running... not sure if that's another clue...
#13
ok i rebooted everything this morning and all of a sudden i've got green smiley's all over the place and an "ok!" from the NAT test for 65535. but now i've got a new problem - when i try and host a torrent on Az's internal tracker - i get a JVM_Bind error pop-up:

org.gudy.azureus2.core3.tracker.host.TRHostException: TRTrackerServer: accept fails: java.net.BindException: Address already in use: JVM_Bind

this mean anything to anyone???
#14
My setup is a wireless one, using a D-Link router and Norton 2003 (with the Windows firewall disabled).

Norton automatically came up with an alert asking me if Azureus was allowed to access the internet, and I said 'always', expecting that to be the end of it. My router normally automatically figures itself out so I wasn't anticipating having any problems there, but oh how I was wrong...

Anyway, after I'd done mostly what the people here have suggested with respect to opening the ports in the router separately (although I don't use static IPs for my wireless network) things seemed to be working fine for a while, and my little smiley face was green and sexy, but after a while it went yellow again, and when I tested NAT in Azureus it was failing again on port 6881 (which I'd set it to, and it was working in the past).

Turns out on top of everything else mentioned here, Azureus seemed to be trying to sent stuff to a port 0 every now and then. I wish I new more about this port crap, but all I can say is in very simple terms that Norton didn't like that at all, and labelled it an "Invalid UDP Destination Port Attack" (presumably port 0 is invalid). So basically, every now and then, Azureus would piss of Norton, and Norton would retaliate by shutting down access to the port that Azureus wanted, for 30 minutes on my computer.

To make things work fine and dandy you might have to disable this intrusion detection signature in Norton. To do that, go to Norton Internet Security,
--> Intrusion Detection
--> Configure
--> Signatures
--> Scroll down to "Invalid UDP Destination Port"
--> Exclude

Anyway, I hope this saves someebody some time!
#15
This was sent to me by email.... hope some of you find it usefull...

--Quote--

I'm not a member of any Azureus help forum or anything, but it would be helpful if Sourceforge would update the FAQ on their website. I had this problem, the NAT Error issue and the Sourceforge/Azureus FAQ told me nothing. In fact, it confused me even more. The initial FAQ was written for someone using a MAC OS and since I use Windows XP, this was of no use to me. However, things started falling in place once I found http://www.portforward.com/. This site was of enormous help. I looked up my Motorola WR850G wireless router and got the step-by-step instructions for setting up port 6881 up for TCP/UDP forwarding.

The steps are:

1) Log onto your router, mine was 192.168.10.1, IP address (http://<router address>, this is found in your network connection, under details). The IP address should be the same as your Default Gateway, DHCP Server or DNS Server, mine were all the same IP address.

2) After successfully logging into the router, go to Network Settings -> Virtual Settings (Port Forwarding).

3) Open your browser and type in http://www.portforward.com/routers.htm and search for your router. After finding the router, click on the "port forwarding" URL (it'll have your router name in it). Put this info into the router program that is running in the first window, i.e. label the name field something easy to remember why this setting is there and set it up both TCP and UDP using port 6881 in both port fields. Add and then apply. Logout of router.

4) Open the firewall program. Find your firewall instructions at http://www.portforward.com/firewall.htm. For example, Zone Alarm, go to Program Control -> Programs and highlight Azureus, then select Options -> Expert Rules -> Add Rule and name the rule in the Name field and change Track to None. Next go to Protocol -> Modify -> Add Protocol -> Add Protocol (leaving the setting "Any" alone. Now select TCP and UDP in Protocol field and put Azureus in the description field. At the bottom of this window you'll see two "Any" boxes. Highlight each, one at a time and type 6881 into both boxes. Click OK -> OK -> Apply, then exit Zone Alarm.

5) Open Azureus and select Tools -> Options -> Connection and input 6881 (if not already there) as your Incoming TCP Listen Port and input your hidden IP (192.168.10.xx, in my case, 192.168.10.3) as your Bind to Local IP Address. Don't input the visible IP address that everyone else sees. Now Save settings.

6) You may or may not need to complete this step. This is optional, but enter the Windows XP firewall client or whatever is the one that came with your OS and set up an exception for Azureus, by setting up both a TCP and UDP rule for using port 6881, click out by using OK until all firewall windows are closed.

7) Exit all programs and reboot.

8) Click on a torrent or download the torrent file and double-click on it. If this was done correctly, the torrent will show up with a "green smiley" every time.

This may not work on a network if two or more computers are simultaneously trying to download torrents. In which case, the first computer to initialize the torrent download will get the green smiley and all others will still get yellow smileys (only if your bandwidth isn't large enough). On my 384 broadband connection, only one computer can use the BT protocol at a time and get green smileys. This was what worked for me, after exhausting research.

I hope that this can help any of your forum members. You may repost, add, modify information, but initial credit goes to the author, me. I hope that you can make a "sticky" on this. Sorry to bother you, but I have seen this problem countless times and always to those using this BT client. It took way to long searching Google to realize that "plain English" help for "noobs" isn't readily available. This is why I thought to recount my experiences in this e-mail.

Kevin

-- Quote --

Thanks Kevin, I'm sure this will be a great help to many.

Kevin is using 6881 in his example. If you choose to use another port, and there are many reasons why you might. Dont forget to change it in all places required.
:)
This message has been edited since its posting. Latest edit was made on 16 Aug 2005 @ 22:32


#16
Hi the Azureus Irc have the answers you need

#17
Hi here is hoe to open ports in the router and the firewall
http://www.portforward.com/

#18
Can anyone help. I typed my ip adress into the adress bar, and logged onto the comcast network thing we use. I went to port forwarding and put in the stuff buffy said to. When I clicked apply at the bottom, it just brought me to the top of the page. I don't think its saving the change. Am I doing something wrong?
#19
Hi, I have have the feared-by-all NAT error w/ Azureus (port 35000) and have tried EVERTHING! I have a deticated firewall [IpCop v1.4.6 (newest)] and I forwarded port 35000 TCP and UDP to my router (192.168.1.1). I have a D-Link router (DI-624) and used the guide at www.portforward.com to set up port forwarding for port 35000 TCP and UDP to my computer [192.168.1.100 (static)]. And I used the guides at www.portforward.com to set up my Norton Internet Security 2005 to allow all connections for Azureus. So everything should work, right?! Cuz I have both my hardware and software firewalls AND my router forwarding or allowing port 35000 TCP and UDP. What else can I do?!

All my stuff I know about is listed below:
RCA Cable Modem
IpCop newest version (1.4.6)
D-Link DI-624 router
Norton Internet Security 2005
Azureus 2.3.0.4

THANX!


#20
Id just like to make a point of a few things.. firstly if you have a dynamic ip you cannot use port forwarding as far as im aware..
and secondly im not sure how many of you are aware but most modem/routers have a built in firewall. so if you have a software firewall an are willing to disable the firewall that come with your modem.. google your modem an type firewall an you should find a guide on how to disable it.. That nat error will genraly be cause because the port is blocked..
so other then that if you have dynamic ip an you have disabled every firewall you know of includeing ones built into your modems...
and your ports are still blocked well as far as i know you are screwd
and no one as far as i have found will have an answer for u..
also dont save your time an energry an dont bother trying to port forward if you have a dynamic ip. because as soon as you put in the ports you want to forward you have to turn your modem off also when you restart you will get a new ip therefor those ports can no longer be forwarded because your ip address will change.. so no matter what you do everytime u change setting to match the new ip u have to turn modem off and on for settings to take affect, then you are back where you started.. so if there is a soultion to this or then getting a static ip because some isp will charge u extra for that, id like to hear it..
sorry i cant help but thats ok because i dont think anyone else can either

War does not determine who is right, it determines who is left
#21
While this link mentioned is very interesting:

http://www.portforward.com/routers.htm

And it will get your bittorrent working, it may not solve your connectivity problem to the Internet while bittorrent is on if you are using a cheap wireless router. Please read my 9/15 posting here:

http://forums.afterdawn.com/thread_view.cfm/225002
#22
Tommy- Allow me to be the first to tell you that maybe your awareness is less than average, as you used that phrase at least 10 times within one post. If you have a dynamic IP address....which is received by your router..which then routes that DYNAMIC IP address into a static IP address, which by now I hope you've figured out by now that this is actually what the router is for. Not to be rude, but obviously yours is being used as a paper weight if you have yet to figure out something as simple as IP routing.....let me ask you this....why did you buy your router again; why not the switch? Obviously you're "aware" that they don't do the same thing. Simply put, don't give advice and talk as though if you don't know something it can't be done, because you're wrong and ignorant to think that someone hasn't figured it out.

As for the port problems with Azureus, I suggest that you try changing your port to around 5100-5600 and try porting through your router. I've got 3 computers on a Linksys wireless router and only one is having Nat Errors while the other 2 can run simultaneously. I'll post here when I get the 3rd fixed with the solution.

Spec breakdown:
Nat Error w/ Inspiron 5100 running XP SP2, Azureus 2.3.0.4

Running fine w/ Athlon XP 64-bit 3200+, running XP 64-bit...that's right, it's running.....muwahahahahaha, Azureus 2.3.0.4 (you have to slightly modify Azureus's code to get fully functioning with XP 64-bit...e-mail me or post here for more info on that

Running fine w/ Inspiron 8100 running XP SP2, Azureus 2.2.2.0
#23
chojin_uk Suspended due non-functional email address
So shadowbw, what do you have to do to the Azuerus code to get it properly working on XP64 ??


TIA

****GO BOIL YOUR HEAD****
#24
The big issue: My modem is also a router...
I went trough a lot of forums and had always found the same answers. The NAT error is due to your router or firewall config.

I disabled my ZoneAlarm firewall and enabled Windows SP2ís one and still NAT error. I even had to reboot my pc every time Iíve done the Azureus NAT test. I found out how to configure ZoneAlarm Pro to open the port but the free version is different, I havenít test it.

One could see that many people had all the different solutions to their NAT problem that still did not solve mineís. And voila I wonderedÖ Ömy modem is also a router. My ISP even gave me an IP to configure on my computer as static :( (192.168.1.2) my fault, I should have figured that out sooner, it was obvious my modem was also a router. But it only has a RJ45 plug and I got distracted because I am a newbie on this.

Then I tried to find info about this modem my ISP gave me and google found nothing (HUAWEI SmarTAX MT883) I think itís Chinese. I then got to their home page that was not working properly.

I only found info about the MT800 and regarding I am not a network expert, I was not sure how could I forward my chosen port from the modem to my wireless Conceptronic router. Anyway it was not difficult.

All I needed to do was go to the modem config page (192.168.1.1) and under the advanced settings I found:
- Virtual Server - Virtual Server is used to allow Internet users access to LAN services -
Iíve configured it like this:
Status: Enabled
Private IP: The IP my ISP gave me that is configured not on the PC as they told me but on the Conceptronic router as Static IP, in this case: 192.168.1.2
Protocol Type: Both
Private Port: My chosen Azureus port
Public Port: My chosen Azureus port
Schedule: Always

Then I applied rebooted and voila. NAT OK
Of course I had the port forward in the Conceptronic router set to my computerís IP. Iíve configured that computerís IP out of the DHCP range set on the Conceptronic Router to avoid conflicts with other computers on my home network, this way I did not have to set them all static.
About the Windows firewall itís not such a big deal to open the port and itís posted on every forum I went. Go to http://www.portforward.com/ as you may find your firewall and router walkthrough. The ZoneAlarm they talk about there is the PRO one.

Now I get no NAT problem and green faces but, even though my connections are now set to 100 maximum and the other computer are offline my wireless connection crashes after some time online with Azureus. And I have to hard reboot the machine becouse I can't even do the repair as it blocks on the disable wireless adaptor part.
#25
i'am new to bittorrent and i have a problem too!
the problem is how do i identify my router? i have a HP EN1207D-TX PCI 10/100 Fast Ethernet Adapter. and this is not listed in the portforward list of wireless routers. and i'am not connected wireless.....
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.