AfterDawn Forums

Problems with decompressor in VirtualDub

This discussion thread has 16 messages.

#1
I am trying to follow the guide here on Afterdawn to join 2 AVI files together using Virtualdub. When I attempt to open a file, I get the message saying that it can't find a suitable VFW decompressor.

The only codecs I have installed are FFDShow and some OGM and OGG codecs. I have not installed any codec packs because FFDShow was all I needed to view any file using WMP10.

So how do I get a VFW for Virtualdub so I can work with all types of DivX and XViD files? Thanks. :)
▼▼ This topic has 15 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Just to be sure, were the 2 AVIs compressing using the same codec? I wouldn't that you merged a DivX AVI + a Xvid AVI.

Remember:
Quote:
Step. 5 - Open Second AVI file
Locate the second AVI file, select it and click Open, the second file should now be added to the end of the first file. Now this is where you will get problems if you have file with separate framerates, resolutions or codecs.

#3
They're both using the same codec, did a check with GSpot.

But the error with the decompressor appears when I'm opening the first file, so it's not that the files I want are incompatible, it's that VirtualDub right now, can't handle the format. :(
#4
If you use VirtualDubMOd, it will let you open a file anyway, even without a decoder. It just locks it to direct streaming, which is fine if you are joining.

Might have helped if you had said what FourCC, then we would have known if it is something that FFDShow supports as FFDShow also includes VfW decoding and encoding support.

What build of FFDShow do you have installed? As there was a problem with one build where it didn't registry the VfW codec under NT based OS's.
#5
The FourCC for the AVI file I'm trying is DIV3/DIV4. Another one I tried is DV50/DIVX. I'm using VirtualDub 1.6.6 and FFDShow 2005-05-27.

I'm not sure which FFDShow to use, there's a newer 2005-06-03 at free-codecs.com, but then the newest build over at the official homepage is only something aroun 2004.
#6
Both built by me I believe. Expect a new build maybe tonight if I have time after gym.

Anyway, ffdshow supports DivX 3 and 5. Go into the VfW config, either from the start up menu or via VirtualDub's codec seclection. There is a right decoder tab, go there and make sure that ffdshow is enabled, for DivX3 this means libavcodec, for DivX 5.x if you have XviD installed you will have the option between that and libavcodec. Come to think of it, if you had XviD installed it should handle the DX50 one itself, although I guess maybe only if you it enabled in the dshow decoder options?

ffdshow's regular dshow decoder selection is independant from the VfW one.

I should point out that all of my ffdshow builds are cvs builds. As such at the time of compile Milan may have been in the middle of changing things (cvs is updated almost daily, sometimes more than once per day), so don't expect everything to work perfectly.
This message has been edited since its posting. Latest edit was made on 08 Jun 2005 @ 19:25
#7
Hey thanks alot dude! I got it working now! :) I really appreciate the help!

So anyway, I didn't get what you mean by CVS builds, but currently the FFDShow at AfterDawn's download area is 20050526 while at free-codecs, it's 20050607. Is that the latest? Cause the download link there labels it as unofficial while the older ones dated 2004 something are "proper" or something. I'm confused about how all the FFDShow versions. :D
#8
CVS = Concurrent Versions System.
There are a few newer (not that new) builds on the sourceforge site by Milan:
http://ffdshow.sourceforge.net/tikiwiki/tiki-index.php?page=Getti...
also maybe worth reading:
http://ffdshow.sourceforge.net/tikiwiki/tiki-read_article.php?art...

Really though you have to ask yourself whether you need the newer builds though. For instance do you care about AVC decoding?
#9
Er.. it's hard to care about something you don't realize exists. :P

Haha, I get your point, it's just that I always thought newer builds would be better, maybe some codecs got updated or something. Anyway this means there's no difference between 20050527 and your newest 20050607? For the average user at least... :)
#10
Well FFDShow is being updated all the time. You would need to check the cvs and see if there are any changes that interest you. Not sure if unicode subs support is finished, but I just put a new build up not that long ago. Anyone who cares about HD AVC encoding/decoding should definatly update.
#11
Alright, got it. ;)
Thanks alot for all the help dude!
#12
Hi celtic_d, I have the same problem as evilnick.
I would like it if you could explain in more detail how to get to the VFW config file. I will realy appreciate it.

Thank YOu
#13
Getting VirtualDub ERROR


Ok Ive used VirtualDub and FFDShow for years, and have never had any problems opening an AVI file of any kind in it.

I recently downloaded the latest versions of both, and tried to load an XviD file like the one below, and I have a few good working files to choose from, and all play great in any players, but now using the most recent versions or older versions I'm getting this:

---------------------------------------------
Couldn't locate decompressor for format XviD (Unknown)

VirtualDub requires a Video for Windows (VFW) compatible codec to decompress video. DirectShow codecs, such as those used by Windows Media Player are not suitable.
------------------------------------------------------

But FFDShow is installed and working properly

Im using the latest version of WindowsXP Pro with all current updates for SP2.

Looking in this video for example with AVIcheck it shows this
================================================================

File: D:\!! Downloads !!\Goodfellas Cd1.avi
Total Streams: 3
Running Time: 1:12:31
Index Chunk: Yes
Interleaved: Yes
Max Bytes Per Sec: 0
AUDIO: 0 - MP3 (0x55)
Average bitrate Per Sec: 165 kb/s
Samples Rate: 48000 Hz
Channels: 2
Bits Per Sample: 0
Variable Bitrate: Yes (32, 56, 96)
AUDIO: 1 - MP3 (0x55)
Average bitrate Per Sec: 134 kb/s
Samples Rate: 48000 Hz
Channels: 2
Bits Per Sample: 0
Variable Bitrate: Yes (32, 56, 96)
VIDEO: XVID
B-VOP: Yes
S(GMC)-VOP: No
QuarterPixel: No
Frame Size: 640 x 352
Frames Rate: 23.976
Color Depth: 24
Total Frames: 104328

Elapsed Time 00:00

==================================

This is just an example of one of my XviD videos, but it gives me this same error no matter which video I load.
This is crap, Ive never had this problem..... ever...... and FFDShow is active and working. It even gives me this problem with older versions that always worked fine.




BIG BROTHER is spreading a NEW WORLD ORDER and taking all freedoms with it.... http://www.pcnuke.com
#14
As above except you would be enabling FFDShow for XviD instead of DivX.
#15
I am not trying to encode anything, just open it in VirtualDub.... I have never had to set FFDShow like that no matter what video I tryed to LOAD into the VirtualDub program.
#16
Never said that you were encoding.

Other than the FourCC ffds you have to enable decoding in FFDShow or it won't decode it.

The way VfW works is that it firsts checks for a codec registered for the FourCC, then if it can't find one it checks other decoders to see if they will accept and then finally fails as you have seen.

If you don't enable XviD in FFDShow then it won't accept it and if you don't have something else installed then the file won't load. If you had XviD installed then FFDShow would never be used since XviD is set to handle XviD.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.