AfterDawn Forums

NMIndexStoreSvr.exe has encountered a problem

This discussion thread has 56 messages.

#1
Hi,

Just bought the new Nero 7 upgrade, did a clean install using all of the clean tools, and I keep getting the message that "NMIndexStoreSvr.exe has encountered a problem and needs to close." this happens at random times-- for a while it was only happening after I burned a disc, but now it happens as soon as I move MP3 tracks to the disc playlist to be burned. Any ideas? It generally causes the program to crash (or run poorly or slowly), although I've been able to burn a few discs after it happens.
This message has been edited since its posting. Latest edit was made on 20 Nov 2005 @ 10:46
▼▼ This topic has 55 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
gazza1988 Suspended due non-functional email address
i am having the exact same problem.

Mansfield Town Rules!!!!
#3
Make that me three. Only mine does it as soon as I go to select a compilation. Oh, and while we are at it, anyone have any idea why Alcohol 120 won't launch on a windows xp mechine? I saw some postings about a logitech camera being the problem but I don't have one of those. I do how ever have a logi keyboard and tracball mouse, all of which I have removed the drivers for just to see. It still wouldn't launch. Any clues or advice would be nice because I would much rather use Alcohol instead of Nero cuz I can copy DVD's right from disk without first coping to HD. Not to mention Nero has become so bulky, who needs all that crap?! Thanks in advance
#4
hi peeps, have you tried updating to 7.0.1.2 ?... if nit get them here - http://www.nero.com/nero7/eng/nero7-up.php
This message has been edited since its posting. Latest edit was made on 04 Dec 2005 @ 6:12



Main PC ~ Intel C2Q Q6600 (G0 Stepping)/Gigabyte GA-EP45-DS3/2GB Crucial Ballistix PC2-8500/Zalman CNPS9700/Antec 900/Corsair HX 620W
Network ~ DD-WRT ~ 2node WDS-WPA2/AES ~ Buffalo WHR-G54S. 3node WPA2/AES ~ WRT54GS v6 (inc. WEP BSSID), WRT54G v2, WRT54G2 v1. *** Forum Rules ***
#5
You can try disabling the Nero Scout this has been causing these kind of problems.


#6
YES-- this was all experienced with 7.0.1.2 (give people some credit for trying the most obvious solutions!) -- and YES, it turns out that it is Nero Scout, which I've turned off. Everything now works fine.
#7
agostinho Suspended due non-functional email address
I'm having the same problem.
#8
Did you try disabling the Nero Scout this should correct the error.


#9
i know this thread is old, but just in case anyone else wanted to know, thise file is using 800 mb of PF usage and working my cpu at 13% to 50% constantly.
#10
crazyed Suspended due non-functional email address
This is what I did.

Disable "Nero Scout"

Restart XP

CTL-ALT-DEL (click on "processes" and insure no process with nm** is running)

Go to F:\Program Files\Common Files\Ahead\Lib and rename NMIndexStoreSvr.exe to NMIndexStoreSvr.bak (or any non used extension)

Nero should now function properly.

I found that Nero Vision Express seemed to run NMIndexStoreSvr.exe for some reason but it wasn't required as "nero scout" was disabled.

I hope this works for you!!
#11
Thanks, uninstalling Nero Scout and deleting NMIndexstoreSvr.exe (renaming: .bak) solved this problem. Updating to the last version had not a single effect!
#12
It's still here in Nero 7 Ultimate. No way to remove it, or not install it. Following the directions, I found it and renamed it as suggested by past users.

Why is Nero building the once simple, perfect burner software into a "worst class" bloatware program? Why in 7734 do I need Nero to INDEX my hard disk drive for XXX sake? Isn't it bad enough that google and microsoft live want to index it and upload the data to their web sites...
#13
that's why i still only use 6.6.0.18, no need for any bloat or bugfixes as that version is 100% stable (will only upgrade if i ever buy a newer DVD burner that isn't supported by 6.6.0.18)



Main PC ~ Intel C2Q Q6600 (G0 Stepping)/Gigabyte GA-EP45-DS3/2GB Crucial Ballistix PC2-8500/Zalman CNPS9700/Antec 900/Corsair HX 620W
Network ~ DD-WRT ~ 2node WDS-WPA2/AES ~ Buffalo WHR-G54S. 3node WPA2/AES ~ WRT54GS v6 (inc. WEP BSSID), WRT54G v2, WRT54G2 v1. *** Forum Rules ***
#14
It's actually no big deal-- just disable Nero Scout. Scout seems to be a pretty crappy addition to the package, and I'd be interested to know if there are any people out there who really use it. I stay up to date with Nero editions, but haven't had any more trouble with this issue-- just tell the program to disable Scout.
#15
I see that people have had problems with Nero Scout for years, and nothing has changed at Nero!!

I too had the pop-up error messages that NMindexStoreSvr.exe caused a problem and needed to close, so I changed the file .exe to another extension. Although this stopped the pop-up error messages, I now see a string of System Errors in the Event Viewer that say:

Unable to start a DCOM Server: {25E8A7CA-5874-4F85-BC00-35210131C444}. The error:
"The system cannot find the file specified. "
Happened while starting this command:
"C:\Program Files\Common Files\Ahead\Lib\NMIndexStoreSvr.exe" -Embedding

So, I then tried the suggestion to disable the .dll by running:
regsvr32 /u "C:\Program Files\Common Files\Ahead\Lib\MediaLibraryNSE.dll"

but the System errors still are coming in.

Something is trying to start the NMindexStoreSvr - EVERY 20 SECONDS - and I have hundreds of these error messages in the Event Viewer.

I also see in my Services list, a NMIndexingService that shows a Manual start. I changed that to 'disable', but the errors continue.

What program is trying to start the NMIndexStoreSvr every 20 seconds,
and how do I make it STOP? Is it the NMIndexingService?

Bill
#16
I have the same problem as wpwms (above). I've already disabled Nero (well, it doesn't work anymore at least) but the "NMIndexStoreSvr has encountered a problem and needs to close. We're sorry for your inconvenience." still pops up every few minutes, and I don't even use Nero!!

Help please!
#17
To get rid of the error and unregister the .dll, try
at command prompt type in:
regsvr32 /u "%commonprogramfiles%\Ahead\Lib\MediaLibraryNSE.dll

What you believe becomes your world
#18
rekfouri Account closed as per user's own request
i downloaded the fix and it didnt stop the problem im at a loss
#19
Well folks the news doesn’t get any better. The error is still occurring in Nero 8.

Bonrea
#20
I just upgraded from v6 to v8... haven't even run the program yet and am getting these errors. I think I agree about bloatware... but I offered to convert some video to various formats and thought the new tools might help.... Anyway...

I did notice that there is a NMIndexingService listed in the Services administrative tool/control panel (Windows XP). Its path does match C:\Program Files\Common Files\Newo\Lib\NMIndexingService.exe. I have stopped the service and disabled it (properties/general/startup type: disabled). It has not tried to reactivate itself.

So, to remove the service, you would issue these commands:

net stop nmindexingservice
sc delete nmindexingservice

You will, of course, need administrator privileges. (You can type the name with its capitals if you want...)

I have done this and will report back if I see anything nasty as a consequence. Though as I *still* haven't gotten around to running Nero yet, I'm not sure I'd notice the difference.

(I wonder if everyone having this problem were to file support cases against it, maybe it would cost them enough money to be worth fixing it... but I wonder if it's really something Ahead wrote or if they bought it from some independent developer and now it will rot as a piece of the bloat.)

(Edited to add details)
This message has been edited since its posting. Latest edit was made on 15 Dec 2007 @ 21:21
#21
I think Nero BackItUp Scheduler is about to get the same treatment. For Pete's sake... why don't they just sell a whole OS and be done with it?

At least they provide clear descriptions for each service about what it's doing. Not trying to hide things (at least not things that I've found).


net stop "Nero BackItUp Scheduler 3"

sc delete "Nero BackItUp Scheduler 3"

YMMV
#22
Hi.
Just go Start>>Run and run services.msc.
Then stop & disable NMIndexingService.
#23
@magic1362,
This thread has been inactive for at least 3 months...so what's the point of re opening it.



guide by ScubaPete http://www.dvdplusvideo.com/tutorial007.html Nero guide by alkohol http://www.dvdplusvideo.com/Guides/alkohol_guide3.html

New RipIt4Me + DVD Shrink + ImgBurn guid <==== Rip any DVDs http://forums.afterdawn.com/thread_view.cfm/422740 Guides by bbmayo..... http://webpages.charter.net/bacitup/
#24
"This thread has been inactive for at least 3 months...so what's the point of re opening it."

@gwendolin- I have to say I really despise that attitude utterly, and it's not the first time I've seen such forum fascism. What is the problem with you people?

I found this thread BECAUSE I AM HAVING THIS PROBLEM TOO- with Nero8. I just googled it frankly. It was driving me nuts, was it an infiltration, was it my OCing, did I install the new cpu heatsink badly, etc etc? I wasted a day.

Do you get the point NOW gwendolin? Boo to you and your Bl00dy-minded ilk.

And kudos to the folk whom have helped, a whole-hearted thank you.

Its a lot easier being righteous than right.


#25
Don't be so hasty, Gwendolin. It just helped me out.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.