AfterDawn Forums

Help! Hard drive won't boot after cloning

This discussion thread has 9 messages.

#1
hi, hopefully one of you can help, i'm trying to upgrade my current hard drive, a ide maxtor, to larger sata hitachi. i don't want to reinstall everything and was trying to use norton ghost to clone the drive. after cloning, the computer won't boot up from the sata, it says something like non boot error, please insert system boot disk and press enter (similiar to that, going off memory).

i can boot up using the ide maxtor and can see and access the sata after windows has booted. i read somewhere that in order to boot, the operating system has to see the new drive as C: but when i go into computer management i can't change the new drive to C:, its currently like G:. using windows xp. any help would be appreciated.
▼▼ This topic has 8 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
When using Norton Ghost did you create a backup disk? usually on floppy or CD, that's what it is asking for I believe.


#3
SypherTek Suspended due non-functional email address
in order for a sata drive to boot it needs the sata controller driver to be built into the windows installation. if youve cloned from an ide it may not have this.

you could try booting up the pc with the windows disk in,
press f6 when the installation is loading (this is to specify additional devices i.e your sata drive) youll need to download your motherboards SATA diskette to load the sata driver so that xp setup can see the hard drive. when youve loaded the sata driver continue with the setup until it asks if you want to repair a windows installation. choose to repair the installation on the sata drive.

when you are in the recovery console type FIXMBR and hit enter this will fix the master boot record for the hard drive.

when youve done that try to boot from it again (making sure that your ide hd isnt plugged in) if you still have no luck you may just have to install windows onto the drive rather than using the clone

Studio Comp: AMD Athlon XP 3200+ OC ~ 2.35GHz runs at 40 celcius idle and 48 under stress (aerocool GT1000 really works!), Asrock K7VT4A , 1024MB Dual Channel DDR 400, MSI Nvidia FX5200 128MB OC ~ 600MHz mem 350MHz core,80GB SATA + 200GB SATA + 120GB IDE, 7.1 Channel Soundblaster Audigy 2 Platinum EX sound and midi interface. 19" Sony SDM-HS95 TFT monitor - sweeet
Comp2: AMD Sempron 2400+ OC ~ 2.0GHz (Stable), Asrock K7S41GX, 512MB DDR 333, Onboard Graphics, 40GB Maxtor IDE


set of monitors on the way soon :P
Google is your friend...
WorkComp: LAPTOP, intel celeron D 2.4GHz, 256MB DDR, 20GB hd. NO SCREEN IT WAS SAWN OFF :S (bag of crap)
#4
tried your suggestion SypherTek, still not loading. i did a search on how to make a SATA driver boot disk and found that i had to use the cd that came with the mobo (A8N-SLI) while booting the computer. did that and got some options, picked "Make Sil3114 SATA/RAID 32bit Driver Disk" on a floppy.

then rebooted with winxp cd in drive and hit f6 and uploaded the driver disk. after that finished continued with winxp installation until i got the choice of hitting "R" for a repair installation. hit that then got the choice of which drive to use. first when i had both hard drives connected i had a c: and a d: so i figured d: must be the SATA, picked it and then did FIXMBR and restarted but still got the error Disk Boot Failure, Insert System Disk and Press enter.

i thought maybe i picked the wrong drive so i cloned the hard drive again, unplugged the IDE drive and did the same thing and since there was only one drive attached, i thought it had to be this one so picked c:. did the FIXMBR and got the same result, Disk Boot Failure. did i do something wrong or is this just not working. please help any other suggestions would be appreciated.
This message has been edited since its posting. Latest edit was made on 16 Jan 2006 @ 18:15
#5
i was browsing the technical help areas of norton's website and found this, does anyone know how to implement it?


Situation:

You have cloned the first partition from one hard drive to another, and now the destination drive is not bootable.

Solution:
This normally means that the destination partition has not been set to active. It must be set to active in order to be bootable. Depending on what purpose the drive served before the cloning occurred, you may also need to reinitialize the Master Boot Record (MBR). To set a partition to active and reinitialize the MBR, you can either use FDISK, or you can use the following GDISK commands


GDISK 1 /act /p:1 Sets the first partition on drive 1 to active.
GDISK 1 /MBR Reinitializes the Master Boot Record on drive 1.

NOTE: Although reinitializing (writing over) the MBR does not alter the disk's partition information, it can be destructive if other software has written information into the MBR. Typical programs that use space in the MBR include drive translation software such as OnTrack's Disk Manager, or a boot manager such as OS/2's Boot Manager. These types of utility programs are known by various names, such as disk extender, drive overlay, and operating system loader.


how do you use GDISK? i did a search and its some norton program, i have norton system works installed but can't seem to find GDISK. did i already do this by doing the FIXMBR described in my earlier post?
This message has been edited since its posting. Latest edit was made on 16 Jan 2006 @ 18:36
#6
bump
#7
You should be able to set the active partition with fdisk as well. A partition has to be active to be bootable.
#8
i used fdisk to set partition 1 on the SATA drive as active and tried to reboot and instead of getting a disk boot failure message, got error loading operating system failure. :(
#9
Error loading operating system could mean that the boot.ini is not correct. That's what points to where your system partition is located and ntldr
http://www.microsoft.com/resources/documentation/Windows/XP/all/r...

Make sure the parameters for the ARC path in boot.ini are correct. What I am suspecting is that parameter "W" in the example in the link above is incorrect since you are now on a SATA controller.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.