AfterDawn Forums

NDSL R4 SDHC 2GB/4GB Loading Screen (**NO Email posting or banned**)

This discussion thread has 733 messages.

#51
Ownage,

It depends of the game size. NDS games vary from 32 Megabytes (don't confuse with megabits) to 512 Megabytes. You could only fit about three 512 Megabyte games onto a 2GB card (can't do four since you tend to use some space for other files, like firmware). On the other hand, you could fit like 60 32MB games... on average, games seem to be around 128MB... so you do the math....

4GB, 8GB, and 32 GB SDHC cards are supposed to work on the r4 SDHC... but right now I can't even get mine past the loading screen (with a 4GB card), so I can't confirm for sure.
AfterDawn Advertisement
#52
Thanks Donn, I'll let ya know how it goes when I get em :)
#53
Ownage,
Like Skined says depends on the size of the games.
I guess that's dictated by the complexity and quality of the graphics.
My kids 7 and 4 have non-high capacity R4s with 2Gb cards.
For the games they like they each have about 40 games and there is still a bit of space free.

Don
#54
PS Donn, tried the 1.19 files... still no go (though I'm about to try again with a "Games" folder just in case)...

Hoping the 1.24 will do the trick

As we all know, there are many different versions of the cloned R4 carts....

However, I'm starting to suspect that there are many different versions of the "R4 SDHC" cart... if you go to the various R4 SDHC websites.. they all have different version of firmware as the latest version...

Pugg has been talking about the three files:

_DS_Menu.dat
_DS_Menu.ini
_DS_MSHL.nds

While many of the R4 SDHC firmwares have these files, I've also noticed some have:

_AX_Menu.dat and no _DS_menu.ini

so that is what leads me to suspect that we all could have different clone versions of the R4 SDHC card, that actually need different firmwares... not every "R4 SDHC" card is the same...

anyway... just a guess...
#55
Good news bad, bad news for me...

I finally got a firmware that made one of my two R4 SDHC's work!!! :)

Problem is.. it's only one... I have the exact same load on my two 4GB micro SDHC cards... in one R4 SDHC both microSD's work.. in the other, neither does...

Guess that pretty much means that one R4 is defective... or is somehow not making full contact with either the r4 and the micro sd card, or the R4 and the DS contacts..


This does tell me one thing about the R4 clones.. the build quality is not great... for anyone else that has tried many different firmwares, and knows they are doing everything right.. if you do get the "loading" only screen... do know it could just be defective... since I have two, and one works.. I know that's the case for me :(
#56
Finally, COMPLETE success...

This may help someone that is really having endless problems and thinks they have the right firmware.

As you can see above, I had two identical R4 SDHC carts and two identical microSD cards with the exact same load, but only ONE would boot.

I just got the second working! To do so I had to wedge a small piece of cardboard between the microSD card and the R4 SDHC card... Obviously, there is a contact issue between the microSD and R4 cart... So again, a warning to R4 SDHC users, the build quality is not perfect.. While one might work flawlessly, the other could have contact issues... so you may have to fiddle around with the microSD card to make sure it's seated correctly. And, in some cases, you might even have to wedge material in between the microSD and R4 to cause some pressure so that all the copper contacts make full connections. This helped for me for the one card that wasn't booting.

Hope this helps someone :)

Thanks to Pugg for his earlier posts and to TheDon for all his help.
This message has been edited since its posting. Latest edit was made on 14 Dec 2008 @ 18:09
#57
still no go for me...

tried what's listed above, even the cardboard in the back trick... still nothing different...

how frustrating this is
#58
Ok thanks to all that have posted but I'm still at a loose end. I have a ds with a kingston 2gb sd and an r4 sdhc from here Klickstore I have downloaded all of the kernels from 1.19 - 1.25 from r4sdhc.com (store says to use 1.20 for 2gb sd and 1.22 for 4gb upwards) and none seem to work. My friend has an 8gb sd card with kernel 1.22 on and that works in my r4 (Dont know which version or from where) so I bought an 8gb sd card and copied the files from his across and still it wont work. So the sd cards work and the r4 works but they wont seem to work together. I have also tried the piece of card trick to no avail. Both cards have been formatted using panasonic formatter and windows in both fat 16 and 32 and I have tried with and without the games folder. I know it seems like the same questions getting asked over and over but I'm stuck. I've followed everything from the instructions with the r4 down to everything on here but still the dreaded loading screen. Any help would be appreciated
#59
Hi there we have this R4 SDHC card too and dumbass hubby ordered 2gb micro sd cards with it. Will it only work with a micro SDHC card? Please help an old lady in distress. I got that firmware link from you tube but it says service unavailable though that could be my rubbish broadband provider.
Thanks Sarah
#60
Thanks for all your help guys...

I simply formatted my 4GB Card with the Panasonic Software and Downloaded the Latest firmware for SDHC(1.25) and extracted it straight to my card.

Surprised me a whole lot...

Thanks again
#61
Did you get it from www.r4sdhc.com? It keeps giving me service unavailable GRRRRRR
#62
if you keep getting service unavailable keep refreshing the page...

you may have to do it over and over and over again, but eventually you'll get a save screen come up....

just be prepared, that like me, it still may not work
#63
Hells bells I have 20 of them!
#64
Hi Sario,

You have 20 of them?

Anyway I've sent you the two files Pugg sent me.
1.24 was good for me!

Don
#65
Here is the exact link...

http://www.linfoxdomain.com/nintendo/ds/....25_English.zip

Remember... Include the Games folder and extract the RAR right into your Card
This message has been edited since its posting. Latest edit was made on 15 Dec 2008 @ 16:34
#66
I HAVE FIXED IT! Had to use version 1.51. No idea why but was directed to it from the site I bought them off. www.r4ultra.com So the kids wont all be wailing at Christmas!
So for R4SDHC go to http://www.r4ultra.com and download the kernel for English v1.51 its the only one thats worked for me and God knows I have had them all on!
Thanks to everyone for your help and emails this is the best site for stupid people like me you are so tolerant!
Thanks, Sarah x
#67
Sarah,

Yippeeee, I too know the feeling of relief.

Have a nice Chrstmas!

DodDon
#68
sario... YOU LEGEND!

thanks to everyone else for their help, but after trying EVERYTHING...

going to the r4ultra website, and downloading the 1.51 kernal...

IT WORKED... got worried initially, cos the loading screen came up, but then it went away again... and it's yippee from here on out...

cheers guys
#69
Hmm tried the 1.51 kernel as well but still wont work :( is there any way to tell which r4 you actually have ? there seems to be quite a few.
The hammer is slowly working its way from the tool box and I fear this r4 won't joining in the festivities this year.

Cheers

Dave
#70
My latest issue:

I was the guy that got two R4 SDHC's working with 2 4G SDHC cards, although one of them I have to wedge in with some cardboard to get contact....

Anyway, I just got an 8GB SDHC card in the mail today... To test, I formatted with the panasonic SD formatter, and just did a direct copy from one of my working 4GB SDHC cards... the 8GB one repeatedly gets stuck at loading...

This is why I'm soo frustrated.. there seems to be no rhyme or reason to the issues... The 4GB card still works, but the 8GB card, with a direct copy, doesn't... makes no sense.... :(
#71
Help please,
I bought a R4 last year and it worked fine, then we lost it, so I have bought another two for kids at Christmas.
Did everything that has been mentioned on here to format them and load all the correct firm ware.
One of them doesn't work aaaaarrrrgggggggghhhhhhhh ( I really am ready to chuck the thing out and disappoint on of the kids!)
I think it must be the actual R4 as the card works fine in the other card ( which does work)
I hope this makes sense, it does in my head.
I have also tried the small bit of cardboard in the back and no joy with that either!

Jenn
#72
Has anyone actually had an 8gb sd card working yet ? my friends came pre installed and that works on my r4 but copying the files across or installing the newest firmware wont work. Is there something that needs to be done to the sd card ? I have 4 sd cards now (2x2gb and 2x8gb) and I know the r4 works surely I'm not that unlucky to have 4 dodgy sd cards
#73
Format the sd using panasonics SD Formatter, you should never use windows to format SD cards, then put on the software, Kingston cards are the worst, I have had a lot of problems using windows switch to panasonics and they work flawlesly

Added bonus they spot a hacked SD card as soon as they are inserted - always shows the true size not fooled like windows.
#74
Thx Kittymat

I have 2 Sandisk 8gb cards and they have been formatted with the panasonic formatter. What setting should they be formatted to ? I just used the default settings:
size 7.39gb - quick format - adjustment off
I did try the full format once but it takes a while especially if you keep doing it after every kernel you try. Is the size shown in the panasonic formatter correct at default ? TIA for any help
#75
if kingston are the worst then what are the best?

i bought a kingston knowing how good their RAM was and was hoping their SD cards continued their quality of product...
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.