AfterDawn Forums

psp will not read disc - psp bad? please help!

This discussion thread has 10 messages.

#1
I have searched for my problem but could not find it...sorry I am kind of new with all this.

I had bought a new psp a month ago, for my 13 year old son.
It was a 2.01 psp that was upgraded to 2.71 then downgraded to 1.5, then devhook .46 was installed. All was working fine for 3 weeks, new game discs would play, sample disk would play on 1.5 firmware, isos would play - until yesterday when it keep getting "the disc could not be read" error, when trying to boot the sample disc that came with the psp bundle, and a mvp baseball disc. He says he did nothing, turned it off, then the next time it gave the error.

After rebooting it 20 times it finally read the disc and started up with out issue, I rebooted it again 3 times and it would not fail, then after playing it a couple hours, being turned off again, it would not start up - same error. Devhook boots fine and if you try to run an iso - it will not start and give the error "the disc cannot be started the region code is not correct"

It will not read the sample disc in 1.5 mode with the memory card in or out.

So...is the disc drive bad or do I need to try flashing up to 2.0 or 2.71 and then back to 1.5 or what?
Is it possible that the firmware is corrupt and that is causing the disc read errors?

any help would be appreciated!
I really need a starting place here, or take the darn thing back to the store.
thanks Kevin
▼▼ This topic has 9 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Sorry - forgot to add that both discs were verified good, by playing then in a buddies unmodded psp running 2.6 firmware.

thanks again!
#3
upgrade to 2.0 and downgrade to 1.5. its a common problem when u downgrade from 2.71.
#4
yeah it happened to my mate i think down grading from 2.0 gives the cleanst 1.5 so try that

psp life = 2.6-1.5 > Custom Firmware Harley G's > 2.0 > 1.5 > C/FW XxPSPmadxX > 2.0 > 1.5 > 2.71 SE-C>swapped 2.5>2.6>1.5>2.0>1.5>3.03 OE-A>3.03OE-B/3.03OE-C
2.80 downgrading guide... http://forums.afterdawn.com/thread_view.cfm/439978
TA-082 downgrading guide.. http://forums.afterdawn.com/thread_view.cfm/441460
TA-082 2.80 downgrading guide.. http://forums.afterdawn.com/thread_view.cfm/444992
#5
I really appreciate the quick replys.

To help me understand this....why would it work fine for 3 weeks, getting played hours a day, then quit working? Is it possible that the firmware became corrupted? I we are saying here that firmware can make this appear to be a hardware problem?

Where can I get the 2.0 upgrade then the 1.5 downgrade, hopefully an easy installer?
(were I can run the *.exe kind of thing would be great!)

thanks again for all your help!
Kevin
#6
sometimes random things like that happen to the psp. there is no easy downgrade for 2.0 (.exe), but it one of the simplest downgraders out there.
#7
I upgraded to 2.0 and it would not read the disc, immediately put up the error, I never heard it spin the disc either.

I then upgraded to 2.71 and same thing, errored out almost immediately and did not hear the disc spinning.

I luckily was able to return it to the store and find another another 2.01 version PSP.

Do the drives go out on these or did I do something in the upgrade process????

thanks again
#8
sounds like the drive itself went out cuz i have had my psp for well over a year and have upgrade and downgraded plenty of times and my UMD drive is still chuggin along.
#9
I got the new one almost back to were I started....up to 2.71 then back to 1.5 then I went up to 2 then back to 1.5... It was fairly easy to go from 2 to 1.5 firmware.....just need to install devhook tomorrow and I will be back in business.
Hopefully this one will one will work better....and going over the 1.5 upgrade/downgrade from 2.0 will make it more stable (is that possible?)

Where is the "saved data" located on the memory card? I want to try and save that then format the card, reinstall devhook and load the "saved game data" back onto the memory card?

thanks again for your help!
#10
well some people have had the error u described after dowgrading and they upgrade to 2.0 and downgraded back to 1.5 and it solved the problem. your saves are under PSP\GAME\SAVEDATA. Im pretty sure the folder is called savedata.
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.