AfterDawn Forums

How to recover PSP that has bricked

This discussion thread has 7 messages.

#1
I am a dad who bought my 10yr old daughter a PSP for her birthday. It came with 1.5 installed and I've just tried to upgrade to dark alex 303 version but it has bricked. On the first restart I got a blue screen telling me it needed to recover. Then I get a black(ish) screen. I can get the recovery menu up - can anyone explain in really simple terms (as I am not even a noob, I'm a pre-noob) what I can try next to get it working again?
▼▼ This topic has 6 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
fultonla Suspended due non-functional email address
if you can still acess recovery mode that is good very good infact.

click on the link in my sig that says custom firmware winstaller there is a link for a 1.50 recovery installer on there to.

after you get back to 1.5 use the easy winstaller on that page to upgrade to 3.03
#3
Many many thanks. I have recovered to 1.5. It has lost the copy of devhook and umd emulator which were previously instaled but I have a backup of those.
When I plug the power lead in the screen goes blank - is this normal? It wasn't happening before (is there a setting for this? it reset the defaults after restoring 1.5).

I'm going to try the upgrade to 303 again now

again - many thanks!
#4
dammit! bricked again. It rebooted and it came up - I tried to check the version and it showed the blue screen saying the settings were corrupt and it need to reset to default - then i get a dark screen with the mem-chip reader light flashing. Any ideas?
#5
Hmm thats weird...try to recover again. That probobly dosent help. Sorry but i really dont have a clue. If you brick on the installation of custom firmware mabey you should try a winstaller. I dunno hope that helps in the slightest bit. Cheers!!!
#6
fultonla Suspended due non-functional email address
by any chance is it a ta-082 mobo check here
i have heard that if they were hardware downgraded it will have troubles upgrading.(not 100% sure on this)

if it is you could try this upgrade to 2.71 then use the downgrader in my sig the upgrade to the custom firmware using the link in my sig.

again im not sure this would work at all
This message has been edited since its posting. Latest edit was made on 09 Apr 2007 @ 14:18
#7
how do you get into the recovery mode ?
i had fw 302OE on my psp and didnt downgrade to 150 and put 162IE-C
now all it does is when i power it on the orange lite will flash for a second the screen stays black but the back light is on then about 30 seconds it will shut down i try'd holding down the r trigger wile i turn on the power but it does not diplay anything is this a full bricked psp or a siemy bricked one any help would be thankfull
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.