AfterDawn Forums

TSSTcorp CD/DVDW TS-H552D won't recognize disk

This discussion thread has 45 messages.

#1
I have a TSSTcorp CD/DVDW TS-H552D, and have used it for about a year without problems. All of a sudden, however just over the weekend, the drive simply won't recognize any disk that I put in the drive. I have tried uninstalling and reinstalling the drive. I have checked all cables, and just about everything else I can think of. Does anyone have any solution to get the drive to recognize any disk?
▼▼ This topic has 44 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
does windows see the drive? is there an exclamation mark in device manager? any error codes? have you tried a system restore?
#3
WIndows does see the drive, and there are no problems in the device manager. There are no error codes, and yes, I have tried a system restore. The drive does respond to commands such as eject. When a disk is inserted, the drive light turns on as though the disk is being read, but in windows (I am running WinXP SP2), the drive acts as though there is no disk present in the drive. No autorun responds, burn programs ask for a disk... so on and so forth.
#4
get a cd/dvd disk cleaner disk to see if laser lens is dirty.
#5
Forgot to mention that I already did that with no success.
#6
try the drive on another pc to see if works or not as could be a software or hardware problem.
#7
Hi Onegd4u,

did you find solution for the problem?
I face with the same and have no clue how to solve.

please get back to me if u got any answer.
thanks,
Gabor
#8
No, I haven't found a solution yet. I have not had an opportunity to try the drive in another computer just yet, as I recently gave my second computer away. I have opened the drive and cleaned the entire drive manually, still with no sucess. I have switched IDE cable slots with my hdd's, so I know the cables and IDE drivers work. So short of swapping drives with another computer for diagnostics, I don't know what else may be the issue.
#9
try switching the ide ports around so that the hd is on the secondary ide & the rom drive is on the primary ide port.
#10
I have 2 hdd's, and I have just the one cd/dvd drive. I have tried the 3 in all possible combinations, (all while adjusting the boot order in the bios), and no matter the combination, the hdd's work, and the cd/dvd drive does not. Therefore, I am led to believe the problem is in the hardware of the drive proper (somewhere), and not the connecting cables or whatnot.
#11
until you try the drive in another computer or try another drive in your computer you don't know if it is a software problem in windows or hardware problem in the drive.
#12
I also have had exactly the same problems described above. I have followed the route suggested and I also have not resolved the problem. Could it be the Microsoft driver is out of date?
#13
I am having the same problem also but with driver TSST corp CDRWDVD TS-H492C

I have tried pretty much everything except for swapping the drive into a new computer. Its a pain in the ass is what it is

Yo
#14
eriondp, is just a standard driver that ms uses. if you can find or get a win98 or winme bootdisk to see if can read a cd that way. would proof whether it is a hardware or software problem.
#15
I was able to try the drive in another computer this last evening. The computer also runs WinXP, and windows recognized the drive with no problem at all, installed it, the whole works. I tried a disk in the drive, and had the same results- no disk recognition. Because I had the drive sitting on top of the computer when I plugged it in, I was able to notice an interesting fact for at least my drive. I didn't hear the drive spin up at all. I heard the laser try to read the disk, but I didn't notice the drive trying to spin the disk at all :(
#16
look at the postion of the label on the disk as you put it into the drive, is it still in same postion when you pop the disk out?
#17
Yep, same position. I guess that pretty well confirms that this is a hardware problem, doesn't it...
#18
yes as the spin motor is probably seized. is possible to get it going again maybe by opening the drive up to manually spin the motor to unseize it. done that a few times & worked
#19



This is the motor that refuses to turn the disk. When it is picked up, it sounds as though a spring is loose, though I don't know of a spring in this motor. I don't really know how to open this motor to fix it. I think I could fix whatever was wrong if I knew how to open it.
This message has been edited since its posting. Latest edit was made on 27 May 2007 @ 15:23
#20
that is ball bearings you hear as i've heard them before as i have opened a fair number of drives. buy yourself a new drive as can get them for about $35Can & up.
#21
Hey,
This guy Paul private messaged me on and said that he was having the same problem as I was with the TSST corp TS-H492C drive. He informed me that some people had luck with resetting their iMAP to manual and it worked for them. I really dont know why resetting my iMAP would have any effect on my dvd drive. Can anyone let me know how my mail server and dvd drive have something to do with each other or if this Paul guy is just full of crap. Thanks

Yo
#22
Some progress! After trying all combinations of software i am having some degree of success. THE SUCCESS INVOLVED GETTING A TRIAL COPY OF NERO7.9 which i installed over Nero 6. If i wishto continue to burn stuff from my HD it seems the only way to continue is to buy Nero7.9.

I can now read all bought dvds and even burn my own video dvds which work most of the time. When i try a data disc which i have burned with Nero or deep burner, I still have the problem of disk recognition. No data disk i have burned or tried to read has worked however i burnt it. Propietary disks do work. The drive (or software) will not recognise a clean brand new disk. The drive i have is for + or - DL, R and RW disks and will only recognise -R if i am burning videos. I still think it is a failure of the Toshiba disk drive as it does not do what the box says no matter what soft ware i have.
#23
Three days ago, the TSST TS-H552D in my computer stopped working. It cannot read CDs, DVDs, etc. Is there any Website I can go to to get this fixed? What is the latest equivalent of the driver that'll work?
#24
I'm getting the same problem. I switch the drive onto another computer and it worked fine. So, for me at least, it is definitely a software problem. I also updated the firmware and reinstalled Nero 6 and neither made a difference. Does anyone have any idea how to fix this because I don't wanna reformat my computer
#25
did you use the Nero cleaner before reinstalling nreo?
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.