AfterDawn Forums

Internet Security Effecting U Torrent ???

This discussion thread has 14 messages.

Hi and sorry in advance if this has been answered elsewhere, I did do a search but couldn't find anything.

I've been using U Torrent (and previously Bit Comet) for about 18 months and never really had any problems. I got a new PC and put U Torrent on and it worked fine. Now though I am struggling to get download speeds of 60kbps when in the past I was reaching around the 300 mark. I have gone through the U Torrent guide and as far as I can see everything is as it should be. I know i should set the firewalls on my PC to accept U Torrent but for speed sake I have turned off windows, trend pc-cillin and my router firewall but it seems to make no difference. My internet seems fine when U-Torrent is off but as soon as I open it my speed deteriorates. I have ran a speed test and that comes out as down 941Kbps and up 120Kbps (while U Torrent is close) could there be something I am missing in trend or windows that is causing the problem. Please treat me as a complete computer inept, I really have very little knowledge ad would rather someone give me an idiots guide than i waste everyones time with I don't understand questions.

Thanks in advance

▼▼ This topic has 13 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
I would like to make sure about the numbers you are posting, as 8kbs = 1kBs. Please recheck and make sure you are posting the "b" correctly.

As far as I have seen, uTorrent lists its speeds in kBs. So that 60 could be equal to 480kbs.

If your test was 941kbs that would be slightly less than 118kBs. The 120kbs would be 15kBs.

Since you said you were getting 300 before (I am assuming 300kBs = 2400kbs), have you switched ISPs?

What setting did you use in the uTorrent speed guide?

If you have everything else off, I do not see how they could be the problem. Although, it is not a good idea security wise.

What is your router make and model?
Who is your ISP (internet service provider)?
Thanks for your response. You're right I was posting wrong my U-Torrent download speed is approx 60kB/s.

-max upload rate is set at 18 kB/s and it is acheiving that no
-max download rate is set to 0
-Global max connections 450
-Max no of connected peers 200
-Upload slots 5 (with use additional ticked if ,90% )

I've re run the speed test to be 100% sure and this is what it said

Date 10/08/07 05:55:20
Speed Down 1919.54 Kbps ( 1.9 Mbps )
Speed Up 186.13 Kbps ( 0.2 Mbps )
Port 8095

A fair bit faster than last night but my U-Torrent speed is still the same this morning. If I run it while U-Torrent is open and downloading at 30-40kB/s I get these results

Date 10/08/07 06:07:39
Speed Down 656.87 Kbps ( 0.6 Mbps )
Speed Up 96.41 Kbps ( 0.1 Mbps )
Port 8095

I use Virgin Media and a Belkin Wireless G+ Mimo router.
I haven't changed ISP's but have set up wireless but my connection seems fine unless I open U-Torrent. I'm sorry I can't remember if the drop in performance on U-Torrent coincides with the change or not. I'm using U-Torrent version 1.7.2 Hope this sheds some light and thanks again

First of all your global connections are set too high. The usual home router can handle around 255 connections max. Having too many connections open will clog up the router.

Using the speed guide settings in uTorrent will set it up for optimal performance for your speed. With your speed (186kbs) the "xx192k" setting on the speed guide is the proper one. You will see it make significant changes to your connection settings.
Speed guide is located under Options. There is a pull down menu called connection type where you can select thexx192k. Be sure to press "use selected settings" to save. You might as well enable encryption also (see below).

One thing you are going to see (and not like) is that this will set your max active torrents to 1. However, using these settings, you should get better overall download speed. So even though you can only do 1 at a time, you should be able to get several downloads completed quicker than if you had them all downloading at the same time.

Have you run the port test on the speed guide screen to make certain you have set up your router (and software firewall) properly? If it does not pass, let me know.

If your port test is OK, then you can run a test with Slackware 10.2 Torrent (dedicated servers). This is a legal (and free) torrent that has a dedicated server. So it is almost always running well. You do not have to download the whole thing, just let it run 15-20 minutes and see what speeds you are getting.

Also Virgin is on the Bad ISPs (UK) list. You can see the Virgin Media "limit bandwidth" policy here. You might as well tick encryption on the speed guide.

But your main problem is the global connections (assuming your port test comes out OK).

Let me know how it goes or if you have more questions.
Thanks for your help jeffw224

I have run the port test and it comes back the port is not open. I followed the link but I'm afraid all of the stuff listed on there means nothing to me.

As i said in an earlier post the windows, trend pc-cillin and router firewall are switched off, I know that isn't the ultimate answer but I thought that would solve the port problem. I use a sweex wifi utility, don't know if this could be causing the problem, but there doesn't seem to be anything about security on there :s

Sorry for the delayed response, I have been away in Ireland but will be checking back each day now.


I am not sure what link confused you, but the only thing that mattered (at that time) was setting encryption.

However, if the port test is coming back blocked and you have your software firewall disabled, it could either be the router setup or your ISP blocking that particular port.

I noticed you were using port 8095. uTorrent suggests a port above 10,000. Azureus suggests a port within the 29152-65534 range (you should not use 65534). The reasons are that many ISPs are blocking those lower ports because they are standard file sharing ports. see, Port is Blacklisted.

As far as the router, you could check out uTorrent & Routers. It has good guides for setting up almost all router types and models for uTorrent.

As far as firewalls, the Firewalls has links to guides for Windows and PC-cillin.

Hope these help. Let me know if you have questions.
Hi thanks for coming back so quick. It was the port forwarding site that confused me. After taking a bit more time though i found the guide for the belking router and this says i need to set up static ip addresses, is this really necessary as i am sure my work pc doesn't use a static ip and that runs fine with u torrent. If i do need to set up a static ip, will i need to do one for all the pc's using my router? I'll have to leave that till tomorrow so i can print the guide out from work, i have no printer at home at the moment.

Ooops nearly forgot, i've tried the port forward test on a few different ones it is currently set to 44806 and they have all come back as port not open.

Thanks again
The port test will come back not open until it is not blocked by the router and/or software.

I am not familiar with that router model. Some models support UPnP, which, I think, would not require a static IP. However, it is usually suggested to use the manual port forwarding.

I do not have a router myself, so I have not gone through the process. However, in looking over a few guides there, I believe you have to set all static. But it has been laid out well in the guide as once you enter one number it gives the others for you automatically.

I do not know how your office is set up, but you would have to clear up the router and software the same for uTorrent or Azureus on your home.
Sorry, I still have not figured out how to edit.

Just to avoid confusion, I don't know why I said Azureus at the end. I meant for uTorrent or any bittorent client on your home.
Thanks, i went through the port forwarding thing and i think (if i read it right) you can do it with a dynamic ip but you may have to change the settings on the router each time you reboot the computer as your ip may change. Anyway, i managed to get the router sort out the port forward thing for now, in that when i run the test it comes back as it is open and i have changed the settings to as you said. I haven't as yet run the torrent you suggested but i was only getting speeds of 10 kB/s at 3am this morning.

Is it possible that i have been blacklisted or something it seems strange that U torrent worked fine before for me and now all of a sudden it doesn't, i know i have a new pc and have set up wireless but surely that shouldn't make that much difference.

Thanks again for your help, time and patience

I doubt that you are blacklisted. Why would anyone want to block you. (rhetorical question)

It could be the torrent you are on. One of the reasons I prefer Azureus, is that it makes it very easy to see the average swarm speed. I have not used my uTorrent in a bit, but if I remember right, the only way is to highlight the torrent and look at the peers below to see their individual speeds.

If you have not done so already, you probably should enable encryption (on the bottom of the speed guide screen) and see if that helps.

Trying the slackware will give you an idea of what speeds you can get with a good torrent swarm. Since it has the dedicated servers, it almost always will get you good speeds for your connection.

That is true about the dynamic and static. I guess most people don't want to go through it each time.

Originally, the wireless was a big difference in terms of getting connected. Now, it should not be a factor.

Let me know what happens on the slackware.
Thanks for all your help. I am currently running the slackware dl and it everything seems to have improved with speeds touching 200 but dropping to 30 kBs. After watching the download and internet speed I think some of the problem may down to a not so good wireless card in my desk top.
It may well be the wireless card, I do not know.

But you should try some other torrents before bothering changing it.

That 1919kbs on the speed test is just shy of 240kBs, so the 200s you were getting were about the max.
Also the slackware will do those shifts sometimes as the dedicated servers can feed you high numbers and if they shift from you to another peer you will see a big drop.
I had a slackware where I was getting 550kBs, but 400kBs was coming from one of the dedicated servers. When it dropped off, I went down to 100-150kBs.

It looks like you are set up right now. That is good to hear.
Thanks again :)
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.