AfterDawn Forums

PC DVI to HDMI TV no audio Tried Everything!!! NEED HELP

This discussion thread has 21 messages.

#1
Hi,

So here is my problem. I recently purchased a new PC with DVI out. I have 47" Vizio LCD. I purchased a cable that is DVI to HDMI. I know DVI does not have sound, but thats ok the HDMI input to the TV has a rca audio input. So i bought a 3.5mm audio out to RCA cable for my computer so i can plug a rca audio cable directly to the tv from my PC, but there is no sound. I dont know what im missing or im doing something wrong.

When i used my RGB 15pin cable and connect it to the TV it works. I just plug the 3.5mm audio cable to the tv and there is sound. I would rather used the dvi output rather than the rgb bc quality i notice is alot better.

Anyone who has this problem or know how to resolve this please let me know. I also have a receiver if i can plug the rca to that please let me know.

Appreciate all helps!
▼▼ This topic has 20 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
I'm thinking it has something to do with the input on your tv.

The first thing I would do is plug in speakers or headphones in the jack just to check that the sound is working while at the same time plugging in the video to the tv. Just to make sure that the audio is working.

You could also do an audio only input test. Where you pluggin the audio and play something without the video plugged in. Press input until you hear the sound. Remember what input it is. I'm thinking it may not be the same as the input you have with the video.

If you can't work anything out. You can always keep the video the way it is and pluggin directly to a stereo or surround sound system.

HDMI I believe is supposed to have both audio and video, so if it doesn't have separate audio input most likely designed for computer use with the tv there may be some advanced setting on your tv that you need to access to enable audio input with the HDMI.

Experience is something you don't get until just after you need it
#3
how do i plug my audio directly to my surround sound? I have a receivr but dont know how to do it. Ive tried putting the audio directly to the receiver but it doesnt have any sound.
#4
I just assumed it would have an auxiliary input like stereo's and mini stereo's.



Experience is something you don't get until just after you need it
#5
I suspect that you are inputting audio to a different channel on your television. As was stated, HDMI typically includes audio, so it is unlikely you're plugging the audio into the same channel.

You're probably better off running the audio to your receiver/amp instead of through the stereo.
#6
uofakron Account closed as per user's own request
I am having the same problem with 2 different tv's, I worked with BOTH Customer Support centers to conclude that it is a valid issue!!!
Ive since returned them both.

Ive even gone far as buying a second dvi to hdmi adaptor.

MAGNAVOX 52MF437S
SONY BRAVIA KDL52W3000

I learned:
on the magnavox you have to map the audio jacks to the hdmi source in the menu.
on the sony the audio jacks only work with hdmi1 without any menu manipulation.

Before calling the second Customer support, I thought it must be me..., but again they confirmed its an issue. I makes me wonder if magnavox and sony used components from the same manufacturer.

Who knows?
For all I know I can be using the wrong HDMI formatted Cables/adaptor.....
#7
Try DVI to component out on the video card so it only uses the video side. Then a 3.5 to RCA to support the audio. You shouldn’t lose any quality. What happens is the DVI to HDMI only supports the video side from the pc however your tv is looking to that cable “HDMI” to support the audio that is being fed through it but there’s nothing there. Tv’s are not designed to look to other inputs to get a audio signal when HDMI is the source. However there are video cards that support audio through the HDMI port.
#8
Icanbe Suspended due non-functional email address
If your card has a Digital out, get a 1/8" mini adaptor, plug that
into a standard rca cable and then plug the rca cable into the coaxial input on your receiver.

You will probaly have to change the settings on your sound card, I can't rember excalty, but I think you will have to allow SPIF (or something like that, sorry at work right now can't check forsure) passthrough.

As for the TV, I don't think it can be done.

Let me know if that works.
Good Luck




20 Years ago I saw you yesterday, Youre looking at the picture now.
We Are, What We Are - Sepultura
Say what you want, Time will always tell the truth.
#9
meq123 Suspended due non-functional email address
Contrary to popular belief, DVI *CAN* pass audio. The audio is sent on the vdieo lines encoded in the video blanking intervals. For a full explanation, see: http://www.hardforum.com/showthread.php?p=1031650868

Thus, it's likely that your video card is indicating that audio is present to your TV(s) and it's not the TV's fault at all. (I'm hitting the same problem myself with an Olevia 237 TV).

From what I can gather, the nVidea 84/85/8600 cards do this, as (apparently) does my 7100/630i integrated video MB. This may be related to the newer nVidia support of HDCP over DVI. Some video cards apparently provide a method to pass through audio via SPDIF headers on the card. YMMV.
#10
meq123 Suspended due non-functional email address
*** WORKAROUND FOUND ***

There's a way you can configure the NVidia driver (prior to installing it) to override/ignore that it 'discovers' an HDMI connection, and thus NOT send the digital audio signal through the DVI connector (obviously requires that you can and DO use an external analog audio cable). This solves the problem for those of us with HDTV's that auto-sense HDMI/analog audio (mine's an Olevia 237T) and have nVidia graphics (mine's an HTPC based on a 7100/630i motherboard w/integrated graphics). I found this originally at http://forums.nvidia.com/index.php?s...=&#entry330319 - although it was being used for a different purpose - but I can certainly vouch that it works!

Here are the steps in full (rewritten by me)... You need to have your PC hooked up to your TV, so the EDID discoverer can get your display's ID code:

1. Get Phoenix EDID Designer, (http://www.tucows.com/preview/329441), unzip and run the exe (no install reqd)
2. Click Tools->Extract registry EDID, then double click the line for your TV/monitor in the popup
3. Click Tools->Byte viewer, and note down the values in row 00, columns 08-0B (4 bytes)
4. Start the installation of the latest Nvidia drivers and cancel out once the files are extracted
6. Open the file "nv_disp.inf" in a text editor. By default for the current drivers this is in C:\NVIDIA\...\169.21
7. Scroll down to the section [nv_SoftwareDeviceSettings], add the following line there, replacing the "XX" values below with the 4 values noted in step 3:

HKR,, OverrideEdidFlags0, %REG_BINARY%, XX,XX,XX,XX,00,00,FF,FF,04,00,00,00,7E,01,00

(In my case the TV code was SYN 0043, the four values being: 4F,2E,43,00 )

4. Uninstall your current drivers and reboot
5. Install the modified drivers by running the previously extracted setup.exe. By default for the current drivers, this is in C:\NVIDIA\...\169.21. You'll get a warning about the driver not being signed because of the modified inf. Just press OK.

Reboot, and you should have GLORIOUS AUDIO!!!
#11
meq123 Suspended due non-functional email address
Sorry, the link in my previous message got "smushed" (a technical term). The full correct link is:

http://forums.nvidia.com/index.php?showt...t=&#entry330319
#12
Thanx a lot, meq! I have absolutely the same problem here with my 8800GT and I was starting to get desperate. I'll try this as soon as I get home, but it surely sounds very promising :).
#13
I tried reinstalling the NVIDIA driver with proper settings but didn't work. I am using 8600GT with Sony Bravia 32.
#14
i used the spdif off the motherboard and used a 9600 gt video card
it comes with small cable to connect to the motherboard
so now audio and video are being sent to tv which is olevia 237t
#15
It worked! (the trick with editing the Edid Flags before installing the drivers)
Setup is:
video card: MSI NG9500GT
tv: Sony KDL-52W3000
mobo: GIGABYTE GA-MA78GM-S2H Micro ATX AMD Motherboard

For some reason the internal spdif connection from the mobo would not get passed through the videocard's hdmi so I wanted to resort to DVI->HDMI and analog audio both going to the HDMI-1 set of inputs on the TV... and still got no sound.
Funny thing was that I was unplugging the hdmi cable from the tv (leaving the analog audio in) and I would hear the Windows plug-and-play jingle. Which told me right away that the tv does not want to play the analog input as long as it's getting 'something' over the hdmi port.
Now it doesn't anymore !
Thanks a million meq123
#16
This has not worked for me... my audio is still running through my VGA chanel and i cannot get sound on my hdmi/dvi chanel on my LG tv

this is really annoyoing can anyone help i have been at it for ages!!!

ps.. the folder name for my drivers was 178.24 and the file name i manipulated was nv4_disp.inf

does anyone know why mine are diferent?

I am using 32" LG TV with nVidia 8500GT
#17
hi. regarding your problem with the LG tv. I had the same problem: video was coming in the tv through HDMI (TV input HDMI 1) and audio was coming in the tv through analog 3,5 jack (TV input pc/RGB). So i found out later that my video card (a Geforce 8800GT) was actually sending the sound through the dvi-hdmi cable to the tv. but there was no sound to be sent. What i did: i conected the onboard audio card to the video card with a SPDIF to S-Video. If u don't have a SPDIF on your motherboard u can buy a 3,5 jack to S-Video converter. The imortant thing is to have a S-Video in the videocard. This way the video card now received sound from the computer to be sent through the DVI-HDMI cable to the TV. and it works. for more details e-mail me. viciouskaen@yahoo.com
#18
I forgot to mention. No Nvidia driver tweaking is required to solve your problem.
#19
the solution meq123 provided worked great for me. although i did some improv it is the same basic idea. what i did was i copied the cd provided with the graphics card which contains the drivers. i edited them as meq123 instructed and then i ran it from my hard disk(the place which i saved it to}.
#20
For those with NVIDIA videocards use this workaround provided by NVIDIA support center.

DLPFIX:
http://forums.nvidia.com/index.php?act=attach&type=post&id=11106
32 bit version

http://forums.nvidia.com/index.php?act=attach&type=post&id=11107
64 bit version

This will disable the HDMI sound input on the TV so the it can search for other sources.
#21
Thanks meq123, that solution worked for me too:

GeForce 8600 GT
DVI 2 HDMI + line out 2 line in audio
Sony Bravia KDL-26S4000
Driver 182.xx

I also received the hotfix from nvidia support center but did not use them ...
http://nvidia.custhelp.com/cgi-bin/nvidi...hp?p_faqid=2371

Valberg
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.