AfterDawn Forums

Help: How do you hardsub an AVI video

This discussion thread has 37 messages.

#1
Well...I was able to successfully turn the mkv video into an avi. However, the subtitle I get is the softsub one and now I wanna hardsub it with my avi video and how can I do that?

I have read through all the threads that are related to my questions. Some are similar but without any solutions. Even they are similar, but there are slight different in here or there so I make a post asking for help.

This is what I have got and done:
- I have installed the K-lite codec pack in FULL VERSION, that means I have all the codes I need for the job to be done.
- A lot of people suggest using virtualdubmod to do the job, but I don't even know how to start, and when I went to check the compression, I didn't see the list of x264 or h264 there. But the K-Lite Pack I installed already have the ffshow installed which contains the x264 codes there. So no luck with virtualdubmod. And besides, I don't even know how long it is going to take to reencode the whole video with the subs. My PC is only athlon 64 3000, which is a bit slower than any other PC out there nowadays.
- When I tried to do the job, the output size of the file is 100 times bigger than the that of the original file. My video is an anime video which is 160MB, but the output size is 10GB with the use of virtualdubmod. WHY?

I hope you guys could help and shed light on this. I really appreciate it.

Kenryuakuma. Need help as always

Downgrade necessary tool
▼▼ This topic has 36 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
In VirtualDubMod, unless you select a codec under 'Video' - you get huge uncompressed files.

Try XviD4PSP instead.
Drag the file onto the window.
Set the format to 'AVI'.
Assuming you have .srt subtitles, add them and encode.

http://www.videohelp.com/tools/XviD4PSP


#3
XviD4PSP...Since it is PSP, does it mean that it is only for PSP video? I don't watch videos on PSP though.

Anyway, as you suggest I use XviD4PSP, I will give it a shot but I still wanna know what codec I should choose when using the virtualdubmod to match the original file size of my video?

Kenryuakuma. Need help as always

Downgrade necessary tool
#4
Quote:
XviD4PSP...Since it is PSP, does it mean that it is only for PSP video?

No.

VirtualDubMod uses VFW codecs.
Only the codecs listed under 'Video' > 'Compression' can be used.
If it's not listed, it means that your codec pack either does not have one or it hasn't been enabled - and I don't know how you you would enable it.

There is a x264VFW codec listed here - which may work.

http://sourceforge.net/projects/x264vfw/
#5
Hello i'm new to these forums

I also have the exact same problem i converted my MKV anime into AVI which loses its subtitles i then ripped these subtitles using OGM Cleaver it is used for both MKV and OGM files.

This then left me with the AVI exactly how i wanted it and my subtitles exactly how i wanted them. i have been trying for weeks to get it to work the closest thing i got to was Virtual dub and some guide on how to add the subtitles but alas it failed. The compression works fine but the subtitles just don't show up.

And instead of x264 or h264 go to the bottom of the compression the last should b mpeg or something thats the one thats normally used.

Please someone find a solution lol
#6
What format are the subs.
#7
Mine are originally in .SRT or .ASS i followed a guide saying change the .SRT to .SSA using a program but it pops up with an error so i use SubtitleWorkshop and just save it as SSA
#8
When you selected the 'Subtitler' filter in VirtualDub, browsed to the .ssa subs and loaded them, did they show in the 'Preview'?
#9
if you mean the second video thing on the right then no they never. it was exactly the same as the input video
#10
I mean in the filter preview screen.
The show/hide button should be active and allow you to view the subs.

If the subtitles show ok, then back in the main window of Virtualdub, you should be able to press the output play button and the subs should show on the output (right side) pane.


#11
no it doesnt. i tried it with another video file and it did work though and i think it has a problem to do either with the resolution being 704x400 or this thing that comes up it says this

[!] AVI: Variable bitrate (VBR) audio detected. VBR audio in AVI is
non-standard and you may encounter sync errors up to 0ms when attempting
to extract WAV files or playing in some players. If this is a problem, use
Full Processing mode is recommended to decompress or recompress the audio.
(This warning can be disabled in Options, Preferences, AVI. bitrate: 128.0 0.0 kbps)
#12
I doubt it's the video resolution or the VBR audio.

You tried it with another video and the same .ssa file and it worked?

If you want, upload a small clip (30 sec) to the likes of MediaFire and I can see if it will take an .ssa sub.
#13
i shall try but my internets been dodgy recently lol also i donno how to:(
#14
Load the video in Virtualdub.
Drag the slider for 20/30 seconds and click the little half flag thingie to mark the clip.
Click 'Video' > 'Direct Stream Copy'
'File' > 'Save as AVI'.


#15
ok i finally got it on the website. i dno how you will find it but its called Shakugan No Shana 01 30 sec
This message has been edited since its posting. Latest edit was made on 06 Jun 2009 @ 19:18
#16
Upload it to MediaFire and copy the link.
Edit out your email address from the post - Afterdawn doesn't allow it.
It's the pencil/pad logo on the top right of your post.

http://www.mediafire.com/
#17
ah thank you for the heads up why don't they allow it though?
http://www.mediafire.com/?dqzwyln4omf or this one I don't know which http://www.mediafire.com/file/dqzwyln4omf/Shakugan No Shana 01 30 sec.avi thanks
#18
They don't want spambots harvesting email addresses.

I added .ssa subs to your clip ok (circled in red).

Upload the subs and I will try adding them to the clip.


#19
ahh ok makes sense i suppose.

http://www.mediafire.com/?nwtdidjqqzk or http://www.mediafire.com/file/nwtdidjqqzk/Shakugan No Shana 01.ssa

em just checking but you aren't changing those to MKV are you? just curious because it says matroska

im off to bed thanks for the help and i hope you will continue to help thank you
This message has been edited since its posting. Latest edit was made on 06 Jun 2009 @ 20:27
#20
No, it's just a test clip - nothing to do with MKV.

Your subs have the times mixed up.
Your first sub, line 1 start four minutes into the movie.
Line 5 starts at the one second mark - it should be first.
When you ripped the files something got buggered-up?
Either re-rip and check the times (.ssa files open in Notepad) or convert to .srt and edit them to the correct times and convert back to .ssa


#21
The first four listed subs seem out of sequence.
Using the .srt version, I slotted each one into the correct time slot (along with the original line number - which was now out of sequence).
I loaded the .srt into Subtitle Workshop.
It resequenced the line numbers.
Saved as .ssa and uploaded it.


http://tinyurl.com/o7lnzv
#22
wow your like a god it worked:P i also noticed they were 4 that were out of sync but i just deleted those normally because on the video feed the signs are in english lol. how did you resyncronize them? and do you have any idea how i can make the file size stay the same more or less from how it was? thanks
#23
I didn't re-sync them as such.
I opened the .ssa file in Subtitle Workshop then saved it as a .srt file.
Opened the .srt file in Notepad and noted the times of the first four then 'Cut' the first one and 'Pasted' it into the correct slot, then repeated for the subsequent subs.
Opened the corrected .srt file in S.W. and saved as a .ssa file.

Quote:
any idea how i can make the file size stay the same more or less from how it was?
Do you mean that the AVI file coming out of VirtualDub was not the same size as going in?
Normally, in VirtualDub, under 'Video' > 'Compression', you would select the same compressor as the source AVI.
If the source was DivX, you select DivX for the output;push the 'Configure' button and set it to default - or perhaps a slightly higher bitrate because it is being recoded..
#24
hmm but i don't know the compressor that i used. i used Format Factory to change it from MKV to AVI i know that the video was encoded in MPEG4 (DivX) but the only thing close to that would be the Xvid MPEG4 which shrinks the file by about 60MB

The original file has a video bitrate of 940 the other file has one of 697 i went into Video > Compression > then i clicked on the bottom Xvid pone and then clicked configure > and it says target Quantizer i clicked on that and it changed to target bitrate and changed that to 940 to see if that works if it does then im hoping thats it all finished lol
This message has been edited since its posting. Latest edit was made on 07 Jun 2009 @ 10:50
#25
Dragging the video into the likes of GSpot or MediaInfo will show the codec used.
If you want to use the DivX codec, you can download the free version and install it.
It will then show up in VirtualDub.


This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.