AfterDawn Forums

MKV Video File (Two Audio Tracks, How Do I Remove One Track?)

This discussion thread has 10 messages.

#1
I have a High Definition MKV video here with 2 audio tracks. The default audio is Russian dubs, but within Media Player Classic, I can right click on the video, go to audio and select the proper English language.

I want to put this vidoe to DVD but how would I remove the Russian and keep just the English audio?

Thanks for any help.

Intel Core 2 Quad 9450 @3.2Ghz - 2x2GB Corsair XMS2 DDR2 (PC2-6400) 4-4-4-12 - XFX Radeon HD 4890 XXX 1GB - Abit IP35 Pro XE - Hitachi Deskstar 7K1000 750GB - Corsair HX Series 620W - Creative Sound Blaster X-fi XtremeMusic - Hyundai W240D-PVA 24" - Hauppauge WinTV HVR-4000 - Windows 7 Home Premium 64bit
▼▼ This topic has 9 answers - they are below this advertisement ▼▼
AfterDawn Advertisement
#2
Download and install MKVToolnix.
Run MKVExtractGUI and load the .mkv file.
De-select the unwanted track, select the output path and 'Start Muxing'.

http://www.videohelp.com/tools/MKVtoolnix
#3
Hi, thanks for your help and sorry for the delay in response.




There are 2 audio files listed amd since I am not sure what one is Russian and what one is English, I tick both and click extract so I can listen to them to determine. A blank error message appears, and then the 2 files are created in the same directory as the MKV file (0 bytes each in size). A text file was also created which says the following:

Error: Unrecognized command line option ''. Maybe you put a mode specific option before the input file name?

Please help! lol I know something went wrong and I know it doesn't take 1 second to extract audio from an almost 5GB file.
This message has been edited since its posting. Latest edit was made on 27 Jun 2009 @ 14:14

Intel Core 2 Quad 9450 @3.2Ghz - 2x2GB Corsair XMS2 DDR2 (PC2-6400) 4-4-4-12 - XFX Radeon HD 4890 XXX 1GB - Abit IP35 Pro XE - Hitachi Deskstar 7K1000 750GB - Corsair HX Series 620W - Creative Sound Blaster X-fi XtremeMusic - Hyundai W240D-PVA 24" - Hauppauge WinTV HVR-4000 - Windows 7 Home Premium 64bit
#4
I'm not sure why you got the error, but try running MKVMergeGUI (part of the ToolNix package?).
Highlight an audio track and it should list the audio language.
Then uncheck the one that isn't required and mux.


#5
When I try open the MKV file inside MKVMerge, I get a file identification Failed Error (Return Code -1)

What does this mean?

Intel Core 2 Quad 9450 @3.2Ghz - 2x2GB Corsair XMS2 DDR2 (PC2-6400) 4-4-4-12 - XFX Radeon HD 4890 XXX 1GB - Abit IP35 Pro XE - Hitachi Deskstar 7K1000 750GB - Corsair HX Series 620W - Creative Sound Blaster X-fi XtremeMusic - Hyundai W240D-PVA 24" - Hauppauge WinTV HVR-4000 - Windows 7 Home Premium 64bit
#6
I don't know what the error message means - try Googling it for hits.
Try Avi-Mux GUI.
Drag the file onto the window.
Highlight it and 'generate data from source files'.
Uncheck the language to discard and try saving as a new file.

http://www.alexander-noe.com/video/amg/


This message has been edited since its posting. Latest edit was made on 27 Jun 2009 @ 17:37
#7
Originally posted by attar:
I don't know what the error message means - try Googling it for hits.
Try Avi-Mux GUI.
Drag the file onto the window.
Highlight it and 'generate data from source files'.
Uncheck the language to discard and try saving as a new file.

http://www.alexander-noe.com/video/amg/



Hi, I did Google the error message but couldn't find anything useful.

Thanks for AVI-MUX suggestion, it has not only sorted the original problem I had but also helped me with another MKV (where I wanted to remove subtitles). Excellent, thanks very much for your help!

One question though...with the original MKV files, when I opened them in Media Player Classic, they opened instantly, however, with the new files, I have to wait over 20 seconds before the video actually starts as media player classic sits there with the text "opening..." at the bottom. Why is this?

Intel Core 2 Quad 9450 @3.2Ghz - 2x2GB Corsair XMS2 DDR2 (PC2-6400) 4-4-4-12 - XFX Radeon HD 4890 XXX 1GB - Abit IP35 Pro XE - Hitachi Deskstar 7K1000 750GB - Corsair HX Series 620W - Creative Sound Blaster X-fi XtremeMusic - Hyundai W240D-PVA 24" - Hauppauge WinTV HVR-4000 - Windows 7 Home Premium 64bit
#8
Perhaps try another player (VLC?) or another codec (CoreAVC?)
The VideoHelp site may offer some suggestions - I have limited exposure to MKV - thus haven't run into enough problems to offer insight.

http://forum.videohelp.com/
#9
Wormund Suspended account
SPAM removed
This message has been edited since its posting. Latest edit was made on 19 Oct 2009 @ 6:55
#10
Thanks very much, I actually fixed the problem using an application called AVI-Mux GUI (MKV Contents Editor).

Very much appreciated!

Intel Core 2 Quad 9450 @3.2Ghz - 2x2GB Corsair XMS2 DDR2 (PC2-6400) 4-4-4-12 - XFX Radeon HD 4890 XXX 1GB - Abit IP35 Pro XE - Hitachi Deskstar 7K1000 750GB - Corsair HX Series 620W - Creative Sound Blaster X-fi XtremeMusic - Hyundai W240D-PVA 24" - Hauppauge WinTV HVR-4000 - Windows 7 Home Premium 64bit
This discussion thread has been automatically closed, as it hasn't received any new posts during the last 180 days. This means that you can't post replies or new questions to this discussion thread.

If you have something to add to this topic, use this page to post your question or comments to a new discussion thread.