1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

1.50 fw and want to go to 3.72 offical

Discussion in 'Sony PSP - Mod and firmware discussion' started by OrrRider, Nov 21, 2007.

  1. OrrRider

    OrrRider Member

    Joined:
    Feb 16, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Yo I know it sounds stupid but I used by cusins PSP to downgrade mine because he had 3.03 so i could downgrade his and make a pandoras battery . I did all that and now I want to get his 1.5 fw back to original firmware and i keep getting an error " System is not applicable" or somthing like that. I read a thread that said to update to 2.0 then 3.71 but that didnt work same error. Any Ideas.
     
  2. CKhaleel

    CKhaleel Regular member

    Joined:
    Feb 26, 2007
    Messages:
    1,669
    Likes Received:
    0
    Trophy Points:
    46
    The PSP is TA-082 and has been downgraded before, you're stuck.
     

Share This Page