1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.8.0??? Can someone help a newb downgrade to 1.5 and upgrade to whatever the best custom firmware?

Discussion in 'Sony PSP - Mod and firmware discussion' started by bondage81, Feb 12, 2007.

  1. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    Can someone help a newb downgrade his 2.8.0 to 1.5 and upgrade to whatever the best custom firmware? Is the best oe-c that hexitnow has posted? I was told I don't need gta: lcs to downgrade is this correct or did I just buy my psp off ebay for nothing?
     
  2. jimmylee1

    jimmylee1 Member

    Joined:
    Feb 12, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    The way i downgraded to 1.5 was upgrading to 3.3something and the downgrading to 1.5 but i saw they said there was a chance of bricking. Have a look on google or wait a few minutes and i will find the site i used

    -Lee
     
  3. jimmylee1

    jimmylee1 Member

    Joined:
    Feb 12, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    Sorry dude my bad i only read the first part. why not get a copy of lcs? it is a good game lol. it need's to be the un patched one though i think. or you can put it back on ebay :)

    -Lee
     
  4. nate1229

    nate1229 Member

    Joined:
    Feb 10, 2007
    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    11
    dont google most of them downgraders are trash and will brick your psp

    find the guide on here!
     
  5. jimmylee1

    jimmylee1 Member

    Joined:
    Feb 12, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    Ok cocky :p lol
    Although I found my through google :)

    -Lee
     
  6. bondage81

    bondage81 Member

    Joined:
    Dec 16, 2005
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    16
    Thanks for trying fellow newbs but I put a thread out two days or so ago and this senior member said You only need gta:lcs if you have fw version 3.03. Hopefully I can find someone to help. Thanks anyway!
     
  7. jimmylee1

    jimmylee1 Member

    Joined:
    Feb 12, 2007
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    11
    Just to let you know dude there is no downgrader for 2.80 at this moment in time. wait a few weeks and there should be. I was stuck at 8.2 but used lcs to downgrade. Other then that i do not know what to do, sorry man!

    -Lee
     

Share This Page