1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.8 to 1.5 - not that simple

Discussion in 'Sony Handhelds' started by lexazver, Jul 14, 2007.

  1. lexazver

    lexazver Member

    Joined:
    Jul 14, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    Hi everybodey,
    Basically i had psp 3.03 which i downgraded to 1.5 and then upgraded to 3.10, then i was looking for some media players for psp and most of them seemed to only work on 1.5 firmware, so i downgraded back to 1.5. But then my mate decided to upgrade it to 2.8 from "need for speed" UMD so now im stuck with 2.8. Of corse i could upgrade it to 2.81 and then to 3.03 and then downgrade like i did before but in the readme file it said that if i try to upgrade back to 3.03 it will brick my psp. So my question is what is the best way to get it back to 1.5?
     
  2. mrmcman

    mrmcman Guest

    use the 2.80 downgrader. or, since u went to 3.10 and to 3.50, ur idstorage keys will have been cleaned and flash formatted. the psp would be safe to use the 3.03 downgrader
     
  3. lexazver

    lexazver Member

    Joined:
    Jul 14, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    sorry i never upgraded to 3.5 , where is downgrader for 2.80 i've googled it but all i could find is that it was impossible.
     
  4. mrmcman

    mrmcman Guest

Share This Page