1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.8 to 3.03 OE-B or 3.02 OE-B or 1.5

Discussion in 'Sony PSP - Mod and firmware discussion' started by ikillau, Jan 24, 2007.

  1. ikillau

    ikillau Guest

    Hi sry if this has been posted already i searched and nothing came up, im just undecided about what to do with my 2.8 psp ? which is better?
     
  2. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    1.5 is okay but u need apps to run iso games. U dont get internet browser and if u brick ur psp u cant unbrick it.

    3.03 OE-B would be the best. If u play psx games then I will chose 3.02 OE-B. Some games wont work for 3.03 OE. There is a app that lets the 3.03 OE to read 3.02 OE psx games.

    3.02 ... same thing as 3.03 OE. Except security and stuff ...
     
  3. ikillau

    ikillau Guest

    thanks alot i downdated to 1.5 succesfully!! i followed all instructions and now i am really confused on where to go ,i want one of the 3.03 oe versions where do i start? much apreciated mrgooey
     
  4. mrgooey

    mrgooey Regular member

    Joined:
    Nov 5, 2005
    Messages:
    4,058
    Likes Received:
    0
    Trophy Points:
    46
    Last edited: Jan 27, 2007
  5. gzach

    gzach Regular member

    Joined:
    May 29, 2006
    Messages:
    547
    Likes Received:
    0
    Trophy Points:
    26
    yeah update to 3.03 oe-c, its the latest in the oe series
     

Share This Page