1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.81 should i upgrade to 3.03 before download custom fireware?

Discussion in 'Sony PSP - Mod and firmware discussion' started by F150FX4, Apr 10, 2007.

  1. F150FX4

    F150FX4 Member

    Joined:
    Oct 27, 2006
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    I just bought psp 2.81 and i tried few games download and it kept ask me to upgrade ver to 3.03 or 3.3..

    Should i upgrade it or DONT ?? i m planning to update custom fireware sometime soon ( my friend will take care of it for me)

    Thanks!
    Jake
     
  2. RiPPERD

    RiPPERD Guest

    Do as follows...

    1. UPGRADE to 3.03 OFFICIAL NOT !!!3.30!!!

    2. use the 3.03 downgrader to take ya back to 1.50

    3. use the 3.03 or 3.10 Custom firmware upgrade (3.03 OE-C)

    4. have the best psp around.


    Files your need are here

    3.03 Official Upgrade : http://www.psp-hacks.com/file/958

    3.03 Downgrader : http://www.psp-hacks.com/file/1034

    3.03 OE-A-B-C Upgrades : MAKE SURE DO IN ORDER!!

    A - http://www.psp-hacks.com/file/998

    A2 - http://www.psp-hacks.com/file/1002

    B - http://www.psp-hacks.com/file/1005

    C - http://www.psp-hacks.com/file/1030

    MUST BE INSTALLED IN THIS ORDER!

    MAKE SURE PSP IS PLUGGED INTO WALL CHARGER OR USB!

    DONT TURN IT OFF WHILE FLASHING OR WILL BRICK.

    Once 3.03 OE-A (1st file installed) you will be able to recover your bricked psp if happens in future.

    hope all helped.
     
  3. Gamester1

    Gamester1 Regular member

    Joined:
    Sep 23, 2005
    Messages:
    186
    Likes Received:
    0
    Trophy Points:
    26
    can you use gta liberty city stiries umd with the 2.60 update ? to down grade from 3.03 to 1.50 ?
     
  4. F150FX4

    F150FX4 Member

    Joined:
    Oct 27, 2006
    Messages:
    56
    Likes Received:
    0
    Trophy Points:
    16
    Yeah i read some posted mentioned about GTA liberty...I found one new for 20.00 unpatched loacl store :) !

    Should i use that umd GTA Liberty or not to bother ???

    Thanks!
    Jake
     
  5. RiPPERD

    RiPPERD Guest

    yes u need the GTA:LCS 2.00 version not 2.60 sorry 2.60 users.
     
  6. thamike

    thamike Member

    Joined:
    Dec 28, 2005
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    11
    I am a bit confuses about the GTA:LCS 2.60 version, cause on the PSP-Hacks.com site it says that its unpatched if there is a red 18+ logo on the UMD and the cover shows some pictures of the unpatched version, same as my 2.60 version, see http://pspupdates.qj.net/How-to-find-a-Homebrew-Friendly-version-of-GTA-LCS-Updated/pg/49/aid/58178, that would mean my GTA:LCS 2.60 version should be homebrew friendly. Is this true, if i try can i brick my PSP if it doesnt work on my GTA version?
    link is http://pspupdates.qj.net/How-to-find-a-Homebrew-Friendly-version-of-GTA-LCS-Updated/pg/49/aid/58178
     
    Last edited: Apr 24, 2007
  7. ggbarnum

    ggbarnum Regular member

    Joined:
    Apr 14, 2006
    Messages:
    1,432
    Likes Received:
    0
    Trophy Points:
    46
    AS you have already being told, you need the GTA UMD with the 2.00 update on it. No other will do.
     
  8. RiPPERD

    RiPPERD Guest

    yes they do have pics for working out version but pics will be different in PAL / NTSC areas

    best way to tell is put it in the PSP and see wat update it has.

    2.00 UPDATE = your laughin!! (it will work)

    2.60 or higher UPDATE = someone laughin at you!! (it wont work)

    try rental stores most of em will let ya test it before u pay for it.

    or try ebay but make sure u ask seller first but dont tell em why or they prob just bullshit to ya anyway.
     

Share This Page