1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.81

Discussion in 'Sony PSP - Mod and firmware discussion' started by stubbur, Jul 16, 2007.

  1. stubbur

    stubbur Member

    Joined:
    Mar 11, 2007
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    16
    hi i just got my new pink psp :p an it started in Firm Ware 2.81 do i need a game for it or not?
     
  2. pspboydee

    pspboydee Regular member

    Joined:
    Apr 20, 2007
    Messages:
    123
    Likes Received:
    0
    Trophy Points:
    26
    what do you mean do you need a game for it
     
  3. XEnigmaX

    XEnigmaX Regular member

    Joined:
    Jun 16, 2006
    Messages:
    639
    Likes Received:
    0
    Trophy Points:
    26
    He means does he need a game for a downgrader, I'm guessing.

    The simple answer: Yes, you need either Lumines or Grand Theft Auto: Liberty City Stories.

    If you get GTA, make sure it has the 2.0 update, or else it won't work.

    Lumines is harder to find but more likely to be a version that allows downgrading. Check either Ebay or Amazon.
     
  4. stubbur

    stubbur Member

    Joined:
    Mar 11, 2007
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    16
    well it takes abute a month for a delivery from amazon to arrive so i'll think i'll get lumines but it is rather pricy 3500 kr
     
  5. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    What's kr stands for? Just wondering. Korean?
     
  6. stubbur

    stubbur Member

    Joined:
    Mar 11, 2007
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    16
    Krónur i'm from iceland
     

Share This Page