1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

2.82 Downgrader

Discussion in 'Sony PSP - Mod and firmware discussion' started by MetalGeat, Mar 31, 2007.

  1. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    Hello, I have 2 psp's one with 3.11 firmware(Im a newb and thought it would be cool to upgrade.) and one with 2.82.Can I run homebrew on a 2.82. And do I need to sign up for psp blender? Is that a good site? Thank you. I ' am a total psp newb
     
  2. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    yeah upgrading sucks

    3.11-nothing u can do
    2.82-upgrade to 3.03, downgrade to 1.5
     
  3. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    how do I upgrade?
     
  4. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
  5. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    First off, thank your for your help. Secondly, other people say I need gta-liberty city stories unpatched to upgrade, is that true?
     
  6. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    yes it is the only way, so don't ask if u can use another game
     
  7. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    does it matter if there is no writing near my psp umd door?
     
  8. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    i think that it means it isn't a ta-082 or higher motherboard. ur fine
     
  9. PeaInAPod

    PeaInAPod Active member

    Joined:
    Nov 28, 2005
    Messages:
    3,065
    Likes Received:
    0
    Trophy Points:
    66
    psp-blender is a useless site. nothing but a scam.

    A unpatched GTA: Liberty City Stories is needed to downgrade your PSP. The "unpatched" version is different from the other GTA:LCS in that it has a update for firmware 2.00 on it unlike the others that (I believe) have a update to firmware 2.6. These "unpatched" versions are no longer available in stores. To find one I suggest eBay. Simply search for "unpatched GTA" without the quotes and there you go. At the time of this post there were 47 auctions for a unpatched GTA:LCS.
     
  10. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    am a noob here and i also have the same question.i have a 2.82 vers. psp and i wanna downgrade it.i looked for a downgrader but they said that the 2.82 cannot be downgrade at this time.but chanman1 said that u can upgrade to 3.03 then downgrade to 1.5. is this true and where can i get the 3.03 downgrader prog. can u pls help me. am a total noob when it comes to psp.=/
     
  11. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
  12. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    ow...one more thing?! why do i need an "unpatched gta"? am using 2.82 right now. i need to upgrade it to 3.03 first and then down to 1.5. so why do i still need an "unpatched gta?"
     
  13. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    because the exploit to downgrade is in the unpatched one.
     
  14. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    so i need to patch the 2.0 first and upgrade to 3.03?is it like that? sorry if am being a pain to u chanman1. =S
     
  15. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    no the gta with the 2.00 update (if u insert it into ur psp, a 2.00 update option will appear under GAME) is the unpatched one, that is the umd that u use

    of course, like peainapod said, it isn't sold in stores anymore, so u'll u have to get it off ebay or find someone who has it and is willing to let u use it
     
  16. eggtrip

    eggtrip Member

    Joined:
    Apr 10, 2007
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    11
    do all "GTA: Liberty City Stories" have the 2.0 patch? i already bought one last night.i'll update u as soon as i get the game.thanks a lot chaman1 !!! =)
     
  17. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46
    no the patched ones have 2.6 update...sony released it i guess to get rid of the security hole in the unpatched one, to make it harder for people to downgrade
     
  18. gasconade

    gasconade Regular member

    Joined:
    Feb 17, 2007
    Messages:
    862
    Likes Received:
    0
    Trophy Points:
    26
    as far as ive seen, there are only 2 updates for that game, the 2.00 *unpatched, and the 2.6 *patched....

    look for the 2.00
     

Share This Page