1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

3.40 what can I do with this modded PSP?

Discussion in 'Sony PSP - Mod and firmware discussion' started by maxxnine, Jul 18, 2007.

  1. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Hi all,This is a great forum I just found and I'm new to psp. I'm thinking to get a modded psp with firmware 3.40. My questions is can I still play a regular UMD games if Buy from stores? where I can find/buy downloaded games ? such PS1 or PS2, SNES etc? thank you so much for any infos!.
     
  2. MetalGeat

    MetalGeat Regular member

    Joined:
    Mar 12, 2007
    Messages:
    616
    Likes Received:
    0
    Trophy Points:
    26
    Yes you can still do everything a normal psp could, except for alot of more cooler functions, like customizizng your icons, playing roms and recovery mode, http://www.isohunt.com and torrents can be used to download games, or rom sites like http://www.romnation.net
     
  3. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Thank you for the heads up and I just picked up the psp, it's still like new and everything is working fine (I check the firmware and it is 3.40). Btw any step by step on this forum on how to open the downloaded games? onto the psp? thanks again!!!.
     
  4. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    So I browse into isohunt and got lumines after i downloaded and transfer (lumines.iso into iso folder on the fisrt window, there are some other folder like psp, movies, music, MP_ROOT, etc) to my psp under ISO folder, I can not find any game in my psp once i back to psp mode. Under game and save uitlity data or saved data nothing was found. Did make any mistake? where would it be?. Could it be the game itself from isohunt?
     
  5. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    You said you have custom firmware, right? 3.40OE-A?? And its safe to assume that you have extracted (unpacked)the iso from the rar file you downloaded?
    First, you want to format your memory stick via the system settings menu (ensuring that you have backed up any data like pictures,MP3's,etc..prior to doing so)
    Once you have done that, connect your PSP to the computer and go into usb mode...Take the extracted iso that you downloaded and place it into the ISO folder in the root of your memory stick..Exit out of usb mode.
    Make sure you have a UMD game inserted in the slot-now browse over to the game icon, and select your game.
     
  6. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    It only says firmware 3.40 not 3.40 OE-A, I dunno if they are the same. But anyway on my screen once I connect on computer with the psp, the memory stick icon ( I opened it) and there are PSP, Music, movies, MP_ROOT folders and I created an ISO folder on the same page with them. Should I put that folder on game folder? as the game folder is inside the PSP folder. Or should I put under MP_ROOT folder as I found an iso folder already in there? anyway I also dowloaded a UMD emulator v.08C (followed all step by step instructions) and same thing happen corrupted data on my psp under the game icon, can't open it whatsoever.
     
  7. staxx

    staxx Regular member

    Joined:
    Nov 12, 2006
    Messages:
    817
    Likes Received:
    0
    Trophy Points:
    26
    You need to be on 3.40 oe-a...to get to that you'll need a copy of the lumines umd.

    Once you have your lumines umd you can use the 3.50 downgrader, you can find that along with all the files needed here... http://www.pspbrew.com/forum/viewtopic.php?t=8427

    Once you have successfully downgraded from 3.50 to 1.50 you can use this winstaller to get to 3.40 oe-a... http://forums.afterdawn.com/thread_view.cfm/500493

    Then all you have to do is place your iso and cso games in the iso folder to play them, and your emulators in the game150 folder.
     
  8. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    Ok, well that explains everything...You dont have custom firmware, you are still running the official Sony 3.40-Which is the reason why you are unable to play your iso's...

    What you will need to do first is get yourself a copy of the UMD game "Lumines" (the first one-NOT Lumines II), and you will need to get this update to get your PSP up to the official 3.50 firmware....Once you have done the update, and you have the game..Go ahead and get this downgrader to downgrade your PSP to v1.5 firmware...After you have successfully downgraded to 1.5-you can then install a custom firmware such as this one here..-At which time you will then be able to enjoy your iso's you have downloaded-
    If it seems like a lot of work, thats because it is..And the best advice I can give you is: do some research, read the instructions carefully for the downgraders and custom firmware installer..And take your time-because you are about to modify your PSP's internal memory so you can unlock its full potential,and thus turning your PSP into a really expensive paperweight if not done correctly..

    Good Luck!


    @staxx--well played...missed it by mere seconds...
     
    Last edited: Jul 18, 2007
  9. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Thanks again guys, and I found out that on my psp there's a lumines 1.5 updater installed. So so should I just update this via the one I have? and then the rest as you guys advise?
     
  10. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    No, thats not going to work...It sounds like you may have some kind of downgrader installed already, but you need the actual Lumines UMD game to run along with the 3.50 downgrader- Gotta go out and get that game, man...
     
    Last edited: Jul 19, 2007
  11. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Yeeeee haaaaaa I got it now the famous 3.40 OEA, thanks all fro all the infos. And now I would like to get info on how to load SNES, NES, Sega or PC into this PSP? any other firmware that I should download to my PSP? thank you all, you've been great!!!
     
  12. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    Congratulations on your successful upgrade...

    You can head over to either psp-hacks.com or qj.net and there you will find the emulators you need...Just be sure to follow the instructions...As far as the games(roms)themselves are concerned, you are on your own there...We can't give you links to sites for that,but let Google be your guide, and all of your dreams will come true!

    As far as other firmwares, you on on the most recent version that is the most stable..The new 3.51 has a few bugs that need to be worked out first..I would just stay with the 3.40OE for now...
     
    Last edited: Jul 21, 2007
  13. staxx

    staxx Regular member

    Joined:
    Nov 12, 2006
    Messages:
    817
    Likes Received:
    0
    Trophy Points:
    26
  14. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Deez Nutz or staxx, How do I dump the UMD into my psp via recovery mode? I try to use the usb special system storage but my macintosh does not recognize the device so the only way is via umd dumper on recovery mode. if there's a step by step instruction I could follow that will be great, Thanks again.

     
  15. glenquag

    glenquag Regular member

    Joined:
    Mar 7, 2007
    Messages:
    1,879
    Likes Received:
    0
    Trophy Points:
    46
    You can just download the game instead of ripping it because you own it anyways, so it's legal. Just download it to make your life easier. ;)
     
  16. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    I guess you are right but I saw some other games are code devhook.46 is that playable in 3.40 OEA? or I need another emulator? thank much!.
     
  17. haasmon92

    haasmon92 Regular member

    Joined:
    Jun 4, 2007
    Messages:
    366
    Likes Received:
    0
    Trophy Points:
    26
    u dont need devhook for anything
     
  18. grimmboy

    grimmboy Member

    Joined:
    Jul 26, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    Hey guys, been reading this forum for a while now but I just got my first PSP fw 3.40 it seems.
    Obvious question is how do I downgrade to be able to use ROMS on my PSP? I have read a lot of tutorials on this subject and found a link to a step-by-step. I just want to make sure that this walkthru is valid for my PSP fw 3.40...http://www.pspbrew.com/forum/viewtopic.php?t=8427.
    I want to make sure bc it references 3.50 fw. Do i need to upgrade to fw 3.5 prior to dowgrading? Any help is appreciated as I want to join the community.
     
  19. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    Yes, that looks good....You need to upgrade your 3.40 to 3.50 official firmware before downgrading. You can find the firmwares and downgraders and such on psp-hacks.com under the "downloads" section..
    Good Luck.
     
  20. maxxnine

    maxxnine Member

    Joined:
    Jul 18, 2007
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    11
    Guys, you forget to mention he/she will need the LUMINES UMD so the person can downgrade to 1.5 otherwise it will be like mine before (just an upadater installed instead the real downgrader).
     

Share This Page