1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

3.50 Downgrader or Emulator?

Discussion in 'Sony PSP - Mod and firmware discussion' started by ViperZoV, Jun 9, 2007.

  1. ViperZoV

    ViperZoV Member

    Joined:
    Mar 18, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    Is there is any way to play games in memory stick for 3.50? or downgrader? as i got a free PSP and it had 3.50 installed on it..

    Also what dows OE-A, B, C means? thanks
     
  2. ibjaredu

    ibjaredu Regular member

    Joined:
    Jul 1, 2006
    Messages:
    2,199
    Likes Received:
    0
    Trophy Points:
    46
    no, their is currently no emulators/downgraders for 3.50.

    The OE-A/B/C stands for Open Edition which is a custom firmware (it can only be installed from another firmware that allows firmware [1.5 , 2.71 SE , 3.03 OE C etc..])
     
  3. ViperZoV

    ViperZoV Member

    Joined:
    Mar 18, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    thank u for ur fast reply.. so there might be an emulator for 3.50 soon and that's mean no need for downgrade is that right?
     
  4. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    wrong...if and when the downgrader comes out for your firmware 3.50, you will still need to downgrade and use a custom firmware in order to use emulators and play ISO games from your memory stick.-Your best bet is to sell your PSP on eBay or something, and buy one that already has firmware version 1.50, or a custom firmware that allows emulators and such..until then, you are limited to what Sony tells you what you can do with your PSP...Sorry
     
  5. ibjaredu

    ibjaredu Regular member

    Joined:
    Jul 1, 2006
    Messages:
    2,199
    Likes Received:
    0
    Trophy Points:
    46
    Well thats not necessarily true considering an exploit could be found that allows non-kernel homebrew on 3.50
     
    Last edited: Jun 10, 2007
  6. dEEz_nUtz

    dEEz_nUtz Regular member

    Joined:
    Sep 10, 2006
    Messages:
    1,798
    Likes Received:
    0
    Trophy Points:
    46
    interesting...an exploit via the flash player perhaps?
     
  7. blackvamp

    blackvamp Regular member

    Joined:
    May 3, 2007
    Messages:
    1,173
    Likes Received:
    0
    Trophy Points:
    46
    No, kinda like the 2.71 hend thingy. However, you can't really do much with it, and it usually lead to a downgrader anyway. However, I doubt that will happen with anything above 3.11. Exploit from an umd game or something will most likely be needed.
     
  8. ibjaredu

    ibjaredu Regular member

    Joined:
    Jul 1, 2006
    Messages:
    2,199
    Likes Received:
    0
    Trophy Points:
    46
    i bet it will be something with a MPEG 4 or Savegame exploit like on PS3 due to the very similiar OS
     

Share This Page