1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

A Question About PSP Downgrading

Discussion in 'Sony PSP - Mod and firmware discussion' started by ger101, Mar 11, 2007.

  1. ger101

    ger101 Member

    Joined:
    Mar 11, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    Hi, I'm new to the fourm.

    I've just recently bought a PSP and it's a TA-082. I also have the piss-poor 3.11 firmware.

    So, what I want to know is: If a 3.11 downgrader IS released, could I downgrade my PSP?


    Thanks in advance.
     
  2. MidnightJ

    MidnightJ Guest

    Yes obviously, aslong as it supports your motherboard. (The downgrader) There will probably be a new downgrader in couple weeks or months, i don't like the whole idea of downgrading so i just use HEN-D.
     
  3. ger101

    ger101 Member

    Joined:
    Mar 11, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    DAMN! Would a downgrader for my motherboard come out along with the proper downgrader? Also...noob question...what's "HEN-D"? Can it work on my firmware?

    Thanks anyway, MidnightJ.
     
  4. MidnightJ

    MidnightJ Guest

    HEN is Homebrew Enabler, which basically allows you to run homebrew apps such as Devhook, GBA emualtors, any homebrew apps and games for PSP, without having to downgrade.

    HEN-D is basically the final version of HEN for a certain PSP version. I have PSP Version 2.71, so i use 2.71 HEN-D. There was HEN-B, and HEN-C before it, but HEN-D is the final "best" one if you want to call it that.

    HEN is availble for 2.71,2.80, and 3.03.

    As far as your motherboard, most of the new downgraders the come out including the recent one for 3.03, supports all motherboards, including the TA-082, which is most common i guess. So chances are when a downgrader will be released, you shouldn't have a problem with it since it will support your motherboard no doubt.

    Usually they release HEN with the downgrader, so if you don't want to downgrade and just emulate lower firmwares and run homebrew on your PSP through loaders and stuff, then you can just do that. And theres no way of damaging your PSP since it runs off your memory card.

    Though the custom firmwares are a lot more convienent, its not worth it if you brick your PSP in the process. Downgrading and having custom firmwares really is the way to go, but is risky, so i just stick with HEN. A couple years im probably going to downgrade since prices of PSP won't be as much. And well downgrading has become really safe, but theres still a small chance. Just stick around the forums and visit pspupdates.qj.net daily and you will see the next downgrader.

    Also if you decide to get tired of waiting for a downgrader and trade your PSP or something, and its a 2.71 or lower, update it to 2.71, and check out my new guide, on basically running 3.01 on your PSP without updating, and loading downloaded PSP games and homebrew. http://forums.afterdawn.com/thread_view.cfm/479682
     
    Last edited by a moderator: Mar 11, 2007
  5. ger101

    ger101 Member

    Joined:
    Mar 11, 2007
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the info, MidnightJ! I might use HEN instead of downgrading.

    Thanks again.
     
  6. MidnightJ

    MidnightJ Guest

    No problem, they have to release HEN for people to downgrade, since they can't just downgrade without it. Though it seems Dark_Alex and the other hacker teams has gone more into making custom firmwares then improving the HEN for people who still use HEN. Seems like 2.71 HEN was the most developed of them all. And they still add some stuff for 2.71 HEN users every now and then.

    Yeah just read the details on the newest HEN that came out a couple months back http://dl.qj.net/Homebrew-Enabler-(HEN)-Duff-for-3.03-PSP-s-PSP/pg/12/fid/12430/catid/114
     
    Last edited by a moderator: Mar 11, 2007

Share This Page