1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

authoring mpg to dvd compliant files after TMPGEnc

Discussion in 'MPEG-1 and MPEG-2 encoding (AVI to DVD)' started by loganic, Feb 25, 2005.

  1. loganic

    loganic Guest

    hi all, im hoping someone can help me here as im near admitting defeat. and i thought i was home and dry too!

    ive been using the avi to dvd guide from the guide list to do as the title says. ive followed it through exactly as said apart from stripping the audio to a .wav file and using that in the audio section of TMPGENnc.

    after 23(!!) hours of encoding ive finally got an .mpg file out of it. the file plays fine on my computer with audio working correctly.

    now when i try to author the file to dvd format (vob, bup files etc) using ifoedit, im having a couple of problems.

    firstly i have been going into dvd_author>author_new_dvd

    then when i try to browse for the video file in the right directory nothing apears unless i click on 'all_files'.

    if i select this file that now comes up and then select the wav audio file i created at the start to create the mpg (in TMPGEnc) for the audio section (this gets greyed out, i asume its not going to use this when authoring as the audio is already in the mpg, however if i do not put this in when clicking ok it just goes back to the main page with nothing happeneing) when i press ok i get an error message as follows just as it starts to encode.

    IfoEdit.exe has encountereda problem and needs to close. we are sorry for the inconvenience.
    If you are in the middle of something, the information you were working on might be lost.........etc, etc.

    ifoedit of course then closes.

    is this a problem with ifoedit? (i use windows xp as an os) or am i doing something wrong?

    if you need more info to answer my question please ask as i was trying to keep this as breif as possible to make easier reading. but if anyone does know the answer please please let me know as im pulling my hair out here!!

    many thanks in advance.
     
  2. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    23 hours is a bit long. Your settings are probably overkill.
    Try ReJig to author it instead of ifoedit.
    If you got some settings wrong in tmpgenc, you could end up with a non-compliant mpeg.
    What's your source video specs? (framerate, aspect size, compression codecs?)
     
  3. loganic

    loganic Guest

    hi rebootjim, thanks for the quick responce.

    these are the video specs ive got from AVIcodec:

    File : 699 MB (699 MB), duration: 1:50:28, type: AVI, 1 audio stream(s), quality: 49 %

    Video : 606 MB, 767 Kbps, 25.0 fps, 640*352 (16:9), XVID = XVID Mpeg-4, Supported

    Audio : 92 MB, 117 Kbps, 44100 Hz, 2 channels, 0x55 = MPEG Layer-3, Supported

    ive just noticed in the guide it says i should have ended up with a .m2v file and mine is a .mpg file. do you think this is the problem?
     
  4. loganic

    loganic Guest

    just tried rejig btw and exactly the same thing happened. :(
     
  5. loganic

    loganic Guest

    ok, so after going over what i did, im wondering if i forgot to select the checkbox that says 'Output video and audio as individual elementary streams' underneith the 'output file' on the 5th page of the TMPGEnc wizard.

    does this sound like it would cause the problem described with the miss matching file types described? if so looks like im in for another couple of days waiting whilst its encoding unless you could sujest any ways of speeding it up!

    is it entirely necessary to select 'highest quality (very slow)' in the 'motion search precision' section?

    im guessing this is what is making the progress so slow.
     
  6. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    First, it's an XviD encoded avi.
    Have you got the XviD codec installed?
    Second, it's a PAL video at 25fps. You're going to get lousy results if you try to change that to NTSC. What part of the world do you live in (Europe, North America, Japan, Australia or?).
    Audio is 44,100hz, needs to be transcoded to 48khz for dvd. Tmpgenc is NOT good at this, especially if it's VBR audio.
    Put a tick in the box "make elementary streams" if you want a separate m2v and mpa from tmpgenc.
     
  7. loganic

    loganic Guest

    i live in the UK so having PAL is ok. (at least somethings ok!)

    regarding xvid codec, how do i tell if i already have it installed? or is it a case of if i havent downloaded it it wont be there?

    and when it comes to the audio, i found i had to make a .wav file of the audio just to get it through TMPGEnc the first time. if i didnt use that it in the audio section it was putting the avi file in there and making the predicted length of the output file twice the size it should have been.

    i was going to re-encode this into mp2 using besweet (gui version) when i came to authoring the mpeg2 file. i had a quick go at this but everytime i had finnished going through the settings and clicked ok it just came up with a notepad, wasnt sure what to do after that. maybe theres a better programme out there to use?
     
  8. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Download and install the latest XviD codec.
    It will overwrite any older versions you may have.
    This will insure you have it.
    You had to extract audio to .wav because it's VBR mp3 audio, which tmpgenc can't do.
    Use ffmpeggui (free) to transcode the .wav audio to AC3 at 48khz for DVD spec.
     
  9. loganic

    loganic Guest

    ok, so i think im getting closer. thanks for your input so far.

    i made a .wav file in virtualdubmod as i said befor and coverted it into mp2 format using the besweet gui (had already done this by the time you sujested ffmpeggui so i'll give that a go next time).

    i then used this to encode with in TMPGEnc and got my mpg2 out of this after another 23 hour encoding session.

    i then used ifoedit to try and author the origonal mp2 file i had created and the mpeg2 file. when i clicked ok it came up with the following error message:

    'INTERNAL ERROR: additional data required but no free space in input buffer'

    clicked ok and it created the files which i burned to disc in nero to see what it had done. the movie played ok but it only had audio for about the first 10 seconds.

    why has this happened?

    i tryed using ReJig and no error message came up but once i played the disc in my dvd player the same thing happened again.

    ive listened to the mp2 audio file i created and there seems to be no problem with it. it plays the whole way through fine. the same with the mpg2 video file, plays fine.

    any idea whats going wrong here?

    once again, thanks for your help so far.
     
    Last edited by a moderator: Feb 26, 2005
  10. loganic

    loganic Guest

    just to add...

    ive tried using the audio file that TMPGEnc produced after encoding.the audio plays the whole way through the dvd now, however it gradualy goes out of sync throughout the film untill at about a third of the way through it is 1 or 2 seconds out, i asume it would get even worse as the movie continued, however i didnt watch anymore to find out.

    ive read aldaco12's sticky thread on the matter of sync problems and im starting to think this might be a lost cause as ive done everything that is described there.

    if you have anymore ideas please let me know. thanks.
     
  11. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Don't remux.
    Take the .wav, transcode in ffmpeggui.
    Enocde the VIDEO ONLY in tmpgenc.
    Author the AC3 audio and m2v video in ReJig, and burn.
    Better to author in DVDLab, but rejig should work with the elementary streams.
     

Share This Page