1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

avi/divx to DVD stuttering

Discussion in 'Video to DVD' started by pengu1n, Mar 2, 2005.

  1. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    Hi guys,

    I just managed to burn an Xvid to DVD using the excellent guide on this forum (16:9 anamorphic as well!). On my main DVD player (Sony newish) it plays fine, apart from the fact that the timer on the front of the DVD player doesn't work properly, it does count up but flicks, so could show 00:01, 00:05, 00:03, 00:10, 00:07 etc. On the other DVD player, older budget model, which still recognises the DVD and plays it, the video comes in bursts while the sound plays perfectly. This is also what happens when I preview the DVD after building it in IFOEdit.

    Could this be something to do with the encoding process - I'm using TMPGenc Plus?

    Thanks!
     
  2. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    What is the source aspect and framerate?
    If it's different than the finished dvd, then you can have problems like this.
     
  3. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    framerate's 23.976, aspect 608*256. am encoding to an NTSC dvd because of the framerate (as suggested in the guide) and using the 'full screen, keep aspect ratio) option in tmpgenc.

    thanks!
     
  4. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Are you using 3:2 pulldown during encode in tmpgenc?
    That could have a lot to do with it.
     
  5. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    On the 'video' tab once you've clicked 'settings' in the bottom right, for 'encode mode' it does say 3:2 pulldown on playback, and for 'framerate' higher up it says '23.976, internally 29.9'. Oddly, though, on the next 'advanced' tab the 3:2 pulldown box isn't checked.

    I've only been using the wizard, though, just changing the quality and telling TMPGEnc to encode fullscreen.

    If this is the problem, what's the solution?

    Thanks again for the responses!
     
  6. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Try setting a closed GOP of 15.
     
  7. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    how?!
     
  8. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    click on the GOP structure tab.
    Click on the Max number of frames in a GOP button.
    Click Unlock.
    Say OK to the warning.
    Change it to 15.
    Try a test encode of a few minutes.
    You could also try putting a tick in the, "Output bitstream for edit (closed GOP)" box.
     
  9. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    no difference :-(

    it's weird, in a different video to encode it happens the other way round - perfect video but the audio in bursts.

    are there any other easy ways to author a dvd than using tmpgenc and ifoedit?

    thanks!
     
  10. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Of course there is. There are at least 10 other encoders you could try, as well as at least 15 other authoring applications. Tmpgenc is slow and cumbersome, although tweakable. The Xpress version...nah, I won't say it.
    My preferred method is encode in Canopus Procoder, author in DVDLab Pro.
    IFOEdit sucks for authoring (NTSC), seems to do a bit better on PAL. Try ReJig for NTSC (for an autoplay dvd).
     
  11. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    well i've got the hang of tmpgenc for the minute and i don't have a problem with leaving the PC on overnight to encode something so i'll stick with that for the time being!

    will investigate ReJig, and the avis that have caused problems have all been NTSC, possibly IFOEdit's fault?

    cheers
     
  12. rebootjim

    rebootjim Active member

    Joined:
    May 13, 2004
    Messages:
    2,631
    Likes Received:
    0
    Trophy Points:
    66
    Entirely possible.
    It is not really designed to author DVD's, it's more to modify existing ones, and can totally mess up if you do something wrong.
    Once you get your video encoded, I would suggest you look at DVDLab or Tmpgenc DVD Author to do it right.
    These programs will tell you if there's anything wrong with your encoded video, so you can go back and adjust things in tmpgenc properly.
     
  13. pengu1n

    pengu1n Member

    Joined:
    Mar 2, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    11
    yeah. i've just done a test encode with tmpgenc express and tmpgenc dvd author and it seems to be working a lot better (plus they have a nicer gui...) so it looks like that should sort it.

    cheers for all the help!
     

Share This Page