1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

B-Frame decoder lag nothing to output

Discussion in 'DivX / XviD' started by isomaster, May 23, 2004.

  1. isomaster

    isomaster Member

    Joined:
    Feb 24, 2003
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    16
    hi guys

    i'v been putting my avi files on to dvd-r's now for a while with no problems but lately with XViD Movies at the very beginning of the first frame it comes up "B-Frame decoder lag nothing"# to output" needless to say when ecoding to mpeg2 it shows up on the first frames aswell only for a second mind but would like to know how to get rid of it done a search on google but nothing really helpful

    any help would be appreciated i'm stumped

    Graham
     
  2. Kingd

    Kingd Guest

    Check out the doom9 forums. My understanding is that xvid encodes that were made using Nic's mpeg2dec3.dll version and DVD2AVI 1.77.3 and older would get this message. It actually doesnt affect playback from what i understand. It does affect certain progs like virtualdub, but ive never experienced any problems with it. It's an advanced thing that doesnt affect any normal kind of play from what i understand. The latest gordianknot and autogknot use the newer DVD2AVI/mpeg2dec3.dll combination made by Neuron2 and that is supposed to fix that bug from what i understand. Im checking out the doom9 forums now and from what im reading, they say if you encode, enabling packed bitstream option in xvid encoder would do the trick. The B frames lag basicly means that the first frame in the movie is empty and it actually starts on frame 2, thats why you get that message in virtuadub or whatever it is your using.
     
  3. shiroh

    shiroh Guest

    using a different container than avi will solve this. matroska. or ogm.
     
  4. isomaster

    isomaster Member

    Joined:
    Feb 24, 2003
    Messages:
    91
    Likes Received:
    0
    Trophy Points:
    16
    Cheers guys Doom9 is usually my first port of call aswell will head over there to see what's what

    thanks again guys

    Graham
     
  5. shiroh

    shiroh Guest

    umm please do use the search first, with a couple of different keywords. :p
     
  6. ozwinpunk

    ozwinpunk Guest

    I have worked out a very easy fix to the problem. I came across the b frame decoder lag myself, and eventually realised that the 3ivx D4 codec does not use B frames! Simply re-encode the video in Virtual Dub with the 3ivx D4 codec and those horrible B frames are sorted. Video quality can be good as long as you are ok with 2-3 GB end result. Depending on the video you may need to forget the audio at this stage, then use Be sweet after to extract it and join the 2 afterwards. I had to do this to make some of my avi. to DVD conversions work, because obviously TMPGEnc cant handle the B frame decoder lag, but will take a 3ivx D4 .avi.

    Hope this helps.
     

Share This Page