1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

[b]HELP ME PLEASE[/b]

Discussion in 'Sony PSP - Mod and firmware discussion' started by amayfield, Sep 5, 2007.

  1. amayfield

    amayfield Guest

    Okay I would really like to play my psp games and my roms on the same psp. I currently am running 1.5 but I can't play any of my bought psp games. Can some one help me before I just go out and buy a another psp.
     
  2. rsrepp

    rsrepp Regular member

    Joined:
    Sep 3, 2006
    Messages:
    396
    Likes Received:
    0
    Trophy Points:
    26
    Um, Upgrade to a custom firmware. Either 3.52 m33 or 3.40 oe. Do a search on both of them.
     

Share This Page