1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Booting Issue

Discussion in 'Windows - General discussion' started by dixidic, Mar 21, 2007.

  1. dixidic

    dixidic Member

    Joined:
    Nov 21, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    I am running Windows XP Pro. The OS developed some minor issues so I tried installing the OS again but could not do so because of installation problems on the CD. Now when I boot the system, I have started to get choices of either selecting the Win XP Pro or Windows Default. My question is how to remove the Windows default option so that the system boots straight from the Win XP Pro. Please advise guys. Thanx
     
  2. whompus

    whompus Active member

    Joined:
    Dec 2, 2002
    Messages:
    1,370
    Likes Received:
    0
    Trophy Points:
    66
    Edit your boot.ini. You may need to remove the selection that hides protected system files. To do that open explorer and select tools, folder options, view. There will be 2 places there one is show hidden files the other is like 2 lines down from there, that say hide protected operating system files. Put a click in show hidden files and remove the click thats in hide operating system files, so you can get access to boot.ini.
     
  3. Morph416

    Morph416 Active member

    Joined:
    Jan 14, 2004
    Messages:
    1,861
    Likes Received:
    0
    Trophy Points:
    66
    In addition to Whompus' post...there's a second path.


    Right click My Computer, go to Properties. Click on the Advanced tab. Click on the Settings button under Startup and Recovery. Click the Edit button on the next screen to edit the boot.ini file.

    Always choose save...not save as.
     
  4. dixidic

    dixidic Member

    Joined:
    Nov 21, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    Thanx for the prompt reply guys. But I need to get help in the editing part also. . This is what is written in my Boot.ini file :

    [Boot Loader]
    Timeout=5
    Default=C:\$WIN_NT$.~BT\BOOTSECT.DAT
    [Operating Systems]
    multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /NoExecute=OptIn


    What do I delete and what do I keep guys ???
     
  5. Morph416

    Morph416 Active member

    Joined:
    Jan 14, 2004
    Messages:
    1,861
    Likes Received:
    0
    Trophy Points:
    66
    Interesting. I've never seen one like that.

    Here's what a typical, single installation boot.ini should look like:

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect


    Might be wise, to start setup again....but remove all your existing partitions and set up a new one to install to. Make sure your CD isn't scratched to bad, and clean out the CD/DVD drive with compressed air.
     
  6. dixidic

    dixidic Member

    Joined:
    Nov 21, 2006
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    11
    OK Morph, first thing is that I don't have any partition on my hard drive. In fact, I have two hard drives. The original I had was a 40 GB IDE and the new one that I got installed recently (along with a new motherboard and processor)is a 250 GB SATA. My XP is installed on the new hard drive and was done by a technician using his XP installation CD. However the installation CD I use starts OK but then after a while asks for the second CD with SP2 of which I don't have a clue about.It has no scratches at all. So there you are. What is my best approach now ???
     
  7. whompus

    whompus Active member

    Joined:
    Dec 2, 2002
    Messages:
    1,370
    Likes Received:
    0
    Trophy Points:
    66
    That BOOTSECT.DAT boots Recovery Console. You have it there because of a failed install at some point. You can delete that line from the ini file.

    You are likely being asked for the sp2 disk because you are installing over the top of xp that has sp2 and your copy doesn't. If so your best option would be to format the drive and start fresh.
     

Share This Page