1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Buying a PSP

Discussion in 'Sony PSP - Homebrew software' started by mz_, Apr 11, 2007.

  1. mz_

    mz_ Member

    Joined:
    Apr 11, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    I'm Looking around on eBay for a PSP. I'd like to play Homebrew, ISO/CSO, etc using the memory cards. What FW version should I look for, and is there anything else I might need to know?

    There are some with 1.5, but read on here briefly that 3.03 works? Some people say they can flash to any FW version also. Should I just get a 1.5 and flash up to that 3.03 version? Sorry if any of this information has been posted elsewhere, if so, just point me there. Thanks.
     
  2. beatz

    beatz Regular member

    Joined:
    Mar 7, 2007
    Messages:
    176
    Likes Received:
    0
    Trophy Points:
    26
    well have a look at my tutorial it has good psp applications that u mite want to use i would reccommend 3.03OE-C but yea (tutorial is in my signature link)
     
  3. ottesen07

    ottesen07 Regular member

    Joined:
    Aug 4, 2006
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    26
    1.5 is the best, from there you can do all kinds of stuff. You can upgrade to a Custom Firmware that allows you to play PSX games, and still use 1.5 homebrew.
     
  4. staxx

    staxx Regular member

    Joined:
    Nov 12, 2006
    Messages:
    817
    Likes Received:
    0
    Trophy Points:
    26
    I Strongly suggest you get a psp with firmware anywhere between 1.50 - 2.80. Mainly because you can downgrade/upgrade(mod) to custom firmware which will enable you to play "backup games" as i like to call them. As well as a lot of other nifty features.

    Or if available, i suggest you purchase one already at custom firmware 3.03 oe-c (make sure it says oe-c beside it) If its just plain sony 3.03 (without oe-c beside it) you'll have to purchase an unpatched version of GTA:LCS game which i'm sure your not looking to spend an extra 20-70 on. So just make sure it is oe-c.
     
  5. mz_

    mz_ Member

    Joined:
    Apr 11, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    Thanks for the info. I happened to have friend at work who was selling a PSP with version 2.60 on it. UMD door don't lock closed, but I can just get one on eBay and replace that.

    Does the above guide still apply to 2.60? or should I look at another guide?

    Also, I know someone that has 2.71 on his PSP, can anything be done with that? Thanks again.
     
  6. MikehMike

    MikehMike Guest

    The 2.6 PSP will need to be updated to 2.71. Then both can be downgraded to 1.5. Then you can update to custom firmware (best one is 3.03 OE-C).
     
  7. mz_

    mz_ Member

    Joined:
    Apr 11, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    So using the Downgrader2.50-2.60.exe won't work? I got the downgrader for 2.71.
     
  8. mz_

    mz_ Member

    Joined:
    Apr 11, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    11
    Nevermind. I guess I would need GTA:LCS unpatched to use the 2.50/2.60 downgrader. Updating to 2.71 seems easier, and cheaper. :)
     
  9. chanman1

    chanman1 Regular member

    Joined:
    Feb 6, 2006
    Messages:
    1,705
    Likes Received:
    0
    Trophy Points:
    46

Share This Page