1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can anyone help me? New to the PSP world

Discussion in 'Sony PSP - Mod and firmware discussion' started by dearjj, Mar 28, 2007.

  1. dearjj

    dearjj Member

    Joined:
    Jun 12, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Hi, need a little help.
    1. Just got a new PSP. In the game selection, it says version 2.6. However, in the setting, it says version 2.81? So what is the real version?
    2. If I want to play homebrew games, what is the best software I should download?
    3. Do I have to downgrade my PSP in order to play the homebrew games or can I stay with the current version?

    Thank you very much
     
  2. isbreen

    isbreen Regular member

    Joined:
    Sep 22, 2006
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    26
    Your fw version is whatever it tells you in system information. If you want to play homebrew you will have to downgrade and if you want to play back-up games ;) you will then have to upgrade to custom fw.
    If you decide you want to do this the best thing to do is start reading the forums on how to downgrade a 2.81fw as there are a couple of things you need to check. Use the search facility there is loads of info on it.
     
  3. dearjj

    dearjj Member

    Joined:
    Jun 12, 2013
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Thanks

    But I am a bit confused now, what is the difference between homebrew and backup games? What would be the better choice, as in terms as which has more selection to choose from?
     
  4. isbreen

    isbreen Regular member

    Joined:
    Sep 22, 2006
    Messages:
    118
    Likes Received:
    0
    Trophy Points:
    26
    Homebrew is games and applications developed and released for free by the PSP community. Back-up games are official sony UMD games which have been Backed-up so you can run them from your memstick. Both require you to downgrade. You can play and run homebrew from 1.5fw. If you want to play back-up games you will then have to upgrade to a custom fw which will allow you to use both Homebrew and back-up's. Again I advise searching and reading the forums to better familiarize yourself with how it all works.
     

Share This Page