1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can i Play ......

Discussion in 'Sony PSP - Mod and firmware discussion' started by alinouman, Aug 1, 2007.

  1. alinouman

    alinouman Member

    Joined:
    Aug 1, 2007
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    11
    Can i play a game which require 3.13 on 2.81 ??????
     
  2. mabarnett

    mabarnett Member

    Joined:
    May 15, 2007
    Messages:
    50
    Likes Received:
    0
    Trophy Points:
    16
    No, you need to update your firmware.
     

Share This Page