1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can you softmod a psp?

Discussion in 'Sony PSP - Mod and firmware discussion' started by gnarkills, Sep 3, 2007.

  1. gnarkills

    gnarkills Regular member

    Joined:
    Jun 14, 2005
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    26
    Is it possible to softmod a PSP and, if so, how do I do it?
     
  2. Shokz

    Shokz Regular member

    Joined:
    Jul 6, 2007
    Messages:
    3,002
    Likes Received:
    0
    Trophy Points:
    46
    Softmod = Downgrade + Custom firmware.

    What firmware are you on at the moment?
     
  3. pav1973

    pav1973 Member

    Joined:
    Sep 4, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    I basically have the same question, apart from that I already know it's possible, my main question is, how do i do it?

    I have firmware 1.52.
     
  4. Shokz

    Shokz Regular member

    Joined:
    Jul 6, 2007
    Messages:
    3,002
    Likes Received:
    0
    Trophy Points:
    46
    Any number of ways, upgrade to either 2.00, 2.60, or 2.71 and use a downgrader for that firmware. Or upgrade to 3.03 and use unpatched GTA:LCS, or 3.50 and use unpatched Lumines. Or downgrade with a Pandora battery. Your options are open :)
     
  5. gnarkills

    gnarkills Regular member

    Joined:
    Jun 14, 2005
    Messages:
    121
    Likes Received:
    0
    Trophy Points:
    26
    Is there a link where I can get all the stuff I need and how to do it?
     
  6. Shokz

    Shokz Regular member

    Joined:
    Jul 6, 2007
    Messages:
    3,002
    Likes Received:
    0
    Trophy Points:
    46
    Well, there are guides everywhere, but all for different firmwares/motherboards. So as i said, what firmware are you on at the moment and i can point you in the right direction.
     
  7. pav1973

    pav1973 Member

    Joined:
    Sep 4, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    So I have firmware 1.52 but I haven't got the (needed versions of the) games. How do I upgrade to 2.00? And from there on I can use a downgrader like Alex?
     
  8. sphynx630

    sphynx630 Regular member

    Joined:
    Mar 11, 2007
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    Here's the 2.0 update. After you update you can use the 2.0 downgrader.
     
  9. pav1973

    pav1973 Member

    Joined:
    Sep 4, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    The filename says US. Is it a problem my PSP is European?
     
  10. sphynx630

    sphynx630 Regular member

    Joined:
    Mar 11, 2007
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    You know to tell you the truth I'm not really sure! I only see a 2.00 update for us and japanese psp's but no european one. I'm sorry!
     
  11. Shokz

    Shokz Regular member

    Joined:
    Jul 6, 2007
    Messages:
    3,002
    Likes Received:
    0
    Trophy Points:
    46
    All updates are the same, i have a Jap PSP and most updates i do are US and Eur.
     
  12. sphynx630

    sphynx630 Regular member

    Joined:
    Mar 11, 2007
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    Thanks Shokz! pav1973 I guess you can update with ease!
     
  13. pav1973

    pav1973 Member

    Joined:
    Sep 4, 2007
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    11
    Thanks a lot. I will give it a try. Which downgrader you recommend?
     
  14. sphynx630

    sphynx630 Regular member

    Joined:
    Mar 11, 2007
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    The MPH 2.0 Downgrader.
     
  15. Shokz

    Shokz Regular member

    Joined:
    Jul 6, 2007
    Messages:
    3,002
    Likes Received:
    0
    Trophy Points:
    46
    Well, to be honest, i recommend the 3.50 downgrader :)

    It's very safe, but you need Lumines

    So, for you, i would suggest the 2.71 downgrader (As i've never tried the 2.00 with anything)

    All 2.00 downgraders should be much the same.
     
  16. sphynx630

    sphynx630 Regular member

    Joined:
    Mar 11, 2007
    Messages:
    253
    Likes Received:
    0
    Trophy Points:
    26
    Well he doesn't have any of the games plus this doesn't have a chance of bricking!
     
  17. Shokz

    Shokz Regular member

    Joined:
    Jul 6, 2007
    Messages:
    3,002
    Likes Received:
    0
    Trophy Points:
    46
    That's exactly why i said "But you'd need Lumines".

    Are you sure, no downgrader has 0% chance of bricking? (Apart from Pandora)
     

Share This Page