1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cannot update MSI engine for Product Setup

Discussion in 'Nero discussion' started by meesdroo, Jan 27, 2007.

  1. meesdroo

    meesdroo Member

    Joined:
    Jan 27, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I have recently updated an XP PRO system to Nero 7.7.5.1. This gave difficulties with Nero Product Setup (1.6.13.0 - it decided to uninstall nero modules first but never reinstalled anything after), however with the help of one of the update.exe modules from Ahead I'm now on 7.7.5.1 as mentioned earlier.
    Only Nero Product Setup itself remained at 1.6.13.0; it indicates that an update is available, but updating aborts with: "cannot update MSI engine. Please update manually". Not being able to find any separate update for Nero Product Setup on the Ahead sites, I assumed Installshields MSI was out of date and updated all available versions (from 2 up to 11) to their latest versions (I was already on 11, by the way); version 12 seems to be out but I could not find any installable client package for that. Just to make sure I also updated MS installer to 3.1 (v2), but nothing helps.
    Any good ideas left?????
     
  2. Saltgrass

    Saltgrass Regular member

    Joined:
    Apr 2, 2006
    Messages:
    1,116
    Likes Received:
    0
    Trophy Points:
    46
    I have only be able to get the Product Setup utility to do one good update out of many I have done. I would suggest you not even try to use it. Download the Clean tools for Nero 7 and use them to uninstall. Then just let the downloaded file to the install and use Custom install if you want to change the default procedure.

    Make sure you have your serial number.

    If the install you have now is working for you, then just wait until the next update and use the clean tool then. It appears I have Product Setup version 1.6.13.0 on this clean install of 7.7.5.1 on Vista.
     
    Last edited: Jan 27, 2007
  3. meesdroo

    meesdroo Member

    Joined:
    Jan 27, 2007
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    11
    I was already afraid you would say something like that .....
    For those with a more optimistic view of the world in general and nero more specifically I forgot to mention that I have all needed administrative rights, and that the folder "program files\common files\installshield" and all of its folders and files were made read/write accessible for all, just to make sure. The installshield updates (that are using installshield - isn't that scary) installed without any problems.
    So, who's next?
     
  4. fasfrank

    fasfrank Active member

    Joined:
    Oct 15, 2003
    Messages:
    4,117
    Likes Received:
    0
    Trophy Points:
    66
    Hehe, I'm in the same camp as Saltgrass. I got it to work one time and that was it. Looks like you have gotten further along and tried more things than we have. I just download and custom install without using the updater program. I haven't even tried to use it the last few times.
    I have an optimistic view of the world but not so much with Nero though.
     

Share This Page