1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Problem Can't install KODI17.1 jn M8S+

Discussion in 'Android TV boxes (Kodi, XBMC, etc)' started by marinafrtn, Jun 29, 2017.

  1. marinafrtn

    marinafrtn Newbie

    Joined:
    Jun 29, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I had KODI16. Follow video instruction I deleted everything, downloaded KODI17.1, but when I want to install it won't let me install it, says "Error". I tried to install KODI7.1 on another TVbox, but still the same "Error". It looks that I'm doing something wrong. Can anyone help me, please.
     
  2. glyntamly

    glyntamly Member

    Joined:
    Nov 19, 2008
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    11
    You need to be looking at version 17.3,and your box has to be 5 or above.Most of the boxes sold on e bay were kit kat rated 4.4.
     
  3. piopat

    piopat Active member

    Joined:
    Mar 11, 2008
    Messages:
    1,809
    Likes Received:
    44
    Trophy Points:
    58
    as glyn says your androis box AND ANY android box must have android software 5.1 or above in order to install kodi 17 . anything less than android 5.1 and kodi 17 wont install .

    HOWEVER if your box has android firmware 4.4 (or 4.4.2 / 4.4.5 ) you can install ebmc 4.4

    ebmc 4.4 is a modified verion of kodi 17 that works on older boxes that have android firmware 4.4 installed .

    so any older boxes that have android 4.4 can be updated to to kodi 17 all be it it will be called ebmc and not kodi , but in effect exactly the same .

    older boxes with android firmware below 4.4 can only go up to kodi 16 jarvis .
     
  4. marinafrtn

    marinafrtn Newbie

    Joined:
    Jun 29, 2017
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Thank you. I'll definitely try it
     

Share This Page