1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't upgrade psp from 1.5

Discussion in 'Sony Handhelds' started by Quangsta, Feb 23, 2007.

  1. Quangsta

    Quangsta Regular member

    Joined:
    Jan 3, 2007
    Messages:
    128
    Likes Received:
    0
    Trophy Points:
    26
    I have psp 1.5 and i cant upgrade to 2.81.(80020148) error. HELP
     
  2. johnc1234

    johnc1234 Regular member

    Joined:
    Nov 29, 2006
    Messages:
    706
    Likes Received:
    0
    Trophy Points:
    26
    right, i upgraded my psp to version 2.00 first. but if you want, put a new game in, which requires f/w 2.81 an try upgrading, why you would want to upgrader from 1.5 baffles me. coz you can play free games with 1.5 XD
     

Share This Page